+ Post New Thread
Results 1 to 9 of 9
Windows Server 2012 Thread, Weird sysvol replication issue in Technical; I have 3 DC's DC1, DC2 and DC3 DC2 and DC3 replicate to each other and to DC1 (host master) ...
  1. #1

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212

    Weird sysvol replication issue

    I have 3 DC's

    DC1, DC2 and DC3


    DC2 and DC3 replicate to each other and to DC1 (host master)

    DC1 receives the other replications but fails to replicate back to either DC2 or DC3.

    What could cause this?

  2. #2

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212
    Some further info -

    All DC's pass dcdiag /test:replications

    All DC's pass repadmin /showrepl

    DCDIAG /V /C /D /E /s:yourdcname > c:\dcdiag.log throws up -
    Warning:
    Missing SRV record at DNS server 10.124.0.1:
    _ldap._tcp.gc._msdcs.C.internal

    Warning:
    Missing SRV record at DNS server 10.124.0.2:
    _ldap._tcp.gc._msdcs.C.internal
    These are there in DNS on DC2 and DC3 ... only DC1 shows these errors and even then the record "look" identical across all servers
    Last edited by CHR1S; 2nd December 2013 at 04:29 PM.

  3. #3

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212
    repadmin.exe /showrepl dc* /verbose /all /intersite > c:\repl.txt shows all DC's writeable with no errors

    ntfrsutl ds your_dc_name > c:\sysvol.log
    ERROR - Cannot bind w/authentication to computer, DC2; 000006d9 (1753)
    ERROR - Cannot bind w/o authentication to computer, DC2; 000006d9 (1753)
    ERROR - Cannot RPC to computer, DC2; 000006d9 (1753)
    Last edited by CHR1S; 2nd December 2013 at 04:35 PM.

  4. #4

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,248
    Thank Post
    239
    Thanked 1,567 Times in 1,249 Posts
    Rep Power
    339
    Is DNS allowed to replicate in both directions on all servers?

  5. #5

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212
    Quote Originally Posted by Michael View Post
    Is DNS allowed to replicate in both directions on all servers?
    Its AD integrated, I am probably assuming its wrongly working.
    Whats the best way to check?

  6. #6

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212
    I have recreated all the NTDS links in AD Sites and Services, they are all auto-generated.

    Repadmin still shows no replication issues.

  7. #7

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212
    Ok, I now have full replication of new files!!

    It did not replicate the existing however. Is that default behaviour?

  8. #8

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,248
    Thank Post
    239
    Thanked 1,567 Times in 1,249 Posts
    Rep Power
    339
    Just sounds like a blip somewhere. I would keep an eye on it.

  9. Thanks to Michael from:

    CHR1S (3rd December 2013)

  10. #9

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,486
    Thank Post
    1,570
    Thanked 459 Times in 300 Posts
    Rep Power
    212
    Its weird, every test passes, nothing unexpected in the logs bar a few failed to replicate violations of open files.

    Hey ho, thanks for the help

SHARE:
+ Post New Thread

Similar Threads

  1. Weird Domain joining issue XP and Server 2003
    By MacBriar in forum Windows
    Replies: 1
    Last Post: 1st October 2009, 05:10 PM
  2. Weird IP/DHCP Issue
    By enjay in forum Wireless Networks
    Replies: 8
    Last Post: 11th May 2009, 03:44 PM
  3. Weird print queue issue
    By HodgeHi in forum Windows
    Replies: 2
    Last Post: 30th September 2008, 03:49 PM
  4. SYSVOL Replication
    By Badger in forum Windows
    Replies: 19
    Last Post: 8th June 2007, 01:23 PM
  5. SYSVOL Replication
    By Norphy in forum Windows
    Replies: 10
    Last Post: 26th April 2007, 08:43 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •