+ Post New Thread
Results 1 to 5 of 5
Windows Server 2012 Thread, Multicast joy using the legacy adapter in Technical; So after weeks of testing/playing etc. WDS on server 2012 as a VM guest on a hyper v host sucks ...
  1. #1
    free780's Avatar
    Join Date
    Sep 2012
    Posts
    1,068
    Thank Post
    45
    Thanked 86 Times in 81 Posts
    Rep Power
    23

    Multicast joy using the legacy adapter

    So after weeks of testing/playing etc. WDS on server 2012 as a VM guest on a hyper v host sucks at multicast 1000kbps (if your lucky) through the hyperv vm nic. About 7000-8000kbps though the legacy adapter. Does anybody know how you can force a slowdown request to the wds server? I don't really want to use the legacy nic as its not recommended, it also eats up the cpu. The client is getting flooded with packets due the host being on a gig port. Flow Control helps but only if available on hyper v vm nics (which it isn't).

  2. #2

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,212 Times in 761 Posts
    Rep Power
    395
    Perhaps enable bandwidth management on the NIC in the VM settings? Will affect the whole VM unfortunately, not just WDS, but might be worth a try.

  3. #3
    free780's Avatar
    Join Date
    Sep 2012
    Posts
    1,068
    Thank Post
    45
    Thanked 86 Times in 81 Posts
    Rep Power
    23
    Tried it. No change. Other than I can throttle it down below 1000kbps.

  4. #4

    Join Date
    Jan 2008
    Location
    South West
    Posts
    1,826
    Thank Post
    217
    Thanked 268 Times in 217 Posts
    Rep Power
    68
    I was told never to use hardware flow control (or I suppose emulated hardware) as the TCP/IP Stack has flow control built in and they conflict?

  5. #5
    free780's Avatar
    Join Date
    Sep 2012
    Posts
    1,068
    Thank Post
    45
    Thanked 86 Times in 81 Posts
    Rep Power
    23
    Solved it:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\WDSServer\Providers\WDSMC\Protocol
    Change TpMaxBandwidth to 1 (the default is 100) that's decimal not hex. This works with a mdt server in hyper v with a 1gbps physical nic and 100mbps clients. If anyone ever has a issue with this let me know as I have literally spent 2 months on this issue. I wish M$ would document all registry keys.
    Last edited by free780; 14th October 2013 at 05:29 PM.



SHARE:
+ Post New Thread

Similar Threads

  1. Anyone use the Bromcom system?
    By tarquel in forum MIS Systems
    Replies: 38
    Last Post: 25th May 2007, 05:11 PM
  2. Using the R2 mmc features on a XP pc
    By Kyle in forum Windows
    Replies: 6
    Last Post: 23rd November 2006, 09:38 PM
  3. Help and advice on using the GPMC
    By standunstan in forum Windows
    Replies: 6
    Last Post: 21st March 2006, 10:46 PM
  4. Replies: 3
    Last Post: 21st February 2006, 05:20 PM
  5. Parental Consent to use the internet at school
    By mark in forum School ICT Policies
    Replies: 20
    Last Post: 24th June 2005, 12:18 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •