+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21
Windows Server 2012 Thread, Windows update hangs in Technical; When I try to check for updates, the server just hangs there. I can't close or move the window. Other ...
  1. #1
    ICT_GUY's Avatar
    Join Date
    Feb 2007
    Location
    Weymouth
    Posts
    2,261
    Thank Post
    646
    Thanked 283 Times in 204 Posts
    Rep Power
    104

    Windows update hangs

    When I try to check for updates, the server just hangs there. I can't close or move the window. Other people seem to have this problem, I just wondered if there was an obvious fix.

    I have managed to run it once successfully.

  2. #2
    ICT_GUY's Avatar
    Join Date
    Feb 2007
    Location
    Weymouth
    Posts
    2,261
    Thank Post
    646
    Thanked 283 Times in 204 Posts
    Rep Power
    104
    1. Click Start
    2. Type ‘cmd’ in the search bar.
    3. Right click Command prompt and choose “Run as Administrator”
    4. At the command prompt, type the following, commands and then press ENTER after each command:
    a. net stop wuauserv

    b. net stop bits

    c. net stop cryptsvc

    Please do not close the Command Prompt window.



    Rename folders pertaining to Windows Update.

    At the command prompt, type the following commands, and then press Enter after each command:
    a) ren %systemroot%\System32\Catroot2 Catroot2.old

    b) ren %systemroot%\SoftwareDistribution SoftwareDistribution.old

    At the command prompt, type the following, commands and then press ENTER after each command:

    a) net start wuauserv

    b) net start bits

    c) net start cryptsvc

    This got it to stop hanging, so far. :-/ Don't know what was upsetting it though :-(

  3. #3
    ICT_GUY's Avatar
    Join Date
    Feb 2007
    Location
    Weymouth
    Posts
    2,261
    Thank Post
    646
    Thanked 283 Times in 204 Posts
    Rep Power
    104
    My best guess on this was forwarders not being set up correctly for DNS.

    Fixed and happy now.

  4. #4
    ICT_GUY's Avatar
    Join Date
    Feb 2007
    Location
    Weymouth
    Posts
    2,261
    Thank Post
    646
    Thanked 283 Times in 204 Posts
    Rep Power
    104
    I lied, It still keeps hanging. I get to install updates then I have to repeat the above.

  5. #5
    Zourous's Avatar
    Join Date
    Mar 2007
    Location
    East Sussex
    Posts
    341
    Thank Post
    96
    Thanked 118 Times in 40 Posts
    Rep Power
    54
    Maybe try a few updates at a time to see if it is a particular one screwing things up!

  6. Thanks to Zourous from:

    ICT_GUY (16th July 2013)

  7. #6
    ICT_GUY's Avatar
    Join Date
    Feb 2007
    Location
    Weymouth
    Posts
    2,261
    Thank Post
    646
    Thanked 283 Times in 204 Posts
    Rep Power
    104
    All updates seem to complete eventually, Windows update seems to be problematic on all my servers but this is the worst. I do wonder if its something to do with SWGL and their proxy.

    I am fighting my way through the updates atm.

  8. #7
    Zourous's Avatar
    Join Date
    Mar 2007
    Location
    East Sussex
    Posts
    341
    Thank Post
    96
    Thanked 118 Times in 40 Posts
    Rep Power
    54
    I guess if you had a proxy bypass address, you would have used it.

  9. #8
    ICT_GUY's Avatar
    Join Date
    Feb 2007
    Location
    Weymouth
    Posts
    2,261
    Thank Post
    646
    Thanked 283 Times in 204 Posts
    Rep Power
    104
    Im not going through a local proxy, just the swgfl one. There is no bypass that you don't have to loginto :-(

  10. #9

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,505
    Thank Post
    1,585
    Thanked 486 Times in 304 Posts
    Rep Power
    217
    Having the exact same issue today on a fresh VM install of 2012 .... weird

  11. #10
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,538
    Thank Post
    361
    Thanked 263 Times in 215 Posts
    Rep Power
    100
    Both of you on VMware VMs? What version?

    Was an issue in vSphere 5 pre update 1 if you had an old version of vmware tools that caused this. Unlikely in this instance i guess but still something to look out for.

  12. #11
    ICT_GUY's Avatar
    Join Date
    Feb 2007
    Location
    Weymouth
    Posts
    2,261
    Thank Post
    646
    Thanked 283 Times in 204 Posts
    Rep Power
    104
    Mine is a fresh install on a dedicated server.

    It has updated and it has downloaded the new updates but it just freezes up.

  13. #12

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,505
    Thank Post
    1,585
    Thanked 486 Times in 304 Posts
    Rep Power
    217
    Install of new updates sits at 99%

    Hyper-V 3 (thats the 2012 version right)

  14. Thanks to CHR1S from:

    ICT_GUY (16th July 2013)

  15. #13

    CHR1S's Avatar
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    4,505
    Thank Post
    1,585
    Thanked 486 Times in 304 Posts
    Rep Power
    217
    My issue seems to be fixed here now. Probably an MS issue or what not

  16. Thanks to CHR1S from:

    ICT_GUY (16th July 2013)

  17. #14
    AJWhite1970's Avatar
    Join Date
    Sep 2012
    Location
    Wiltshire
    Posts
    339
    Thank Post
    90
    Thanked 76 Times in 58 Posts
    Rep Power
    17
    Just to help with your troubleshooting, I've just checked Windows Updates going through the SWGfL proxy on my 2012 servers and no issues or hangs

    Andrew

  18. Thanks to AJWhite1970 from:

    ICT_GUY (16th July 2013)

  19. #15
    ICT_GUY's Avatar
    Join Date
    Feb 2007
    Location
    Weymouth
    Posts
    2,261
    Thank Post
    646
    Thanked 283 Times in 204 Posts
    Rep Power
    104
    Quote Originally Posted by AJWhite1970 View Post
    Just to help with your troubleshooting, I've just checked Windows Updates going through the SWGfL proxy on my 2012 servers and no issues or hangs






    Andrew
    Cheers. Can I ask you what swgfl dns servers you are using for your forwarders? Please.

    I have 62.171.194.104 & 105

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Windows update won't work on 2000 pro
    By woody in forum Windows
    Replies: 4
    Last Post: 22nd December 2006, 08:59 AM
  2. Replies: 11
    Last Post: 20th October 2006, 04:14 PM
  3. Windows Update for Non-IE browsers.
    By Geoff in forum Links
    Replies: 2
    Last Post: 22nd November 2005, 02:26 PM
  4. windows update
    By darkstar in forum Windows
    Replies: 7
    Last Post: 10th November 2005, 10:03 PM
  5. Windows Updates
    By nawbus in forum Windows
    Replies: 11
    Last Post: 8th November 2005, 12:31 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •