+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 25 of 25
Windows Server 2012 Thread, IIS 8 HTTP 500 FastCGI problem in Technical; What is your file upload limit set as? Is could be an issue with the upload limit being greater then ...
  1. #16
    penfold_99's Avatar
    Join Date
    Feb 2008
    Location
    East Sussex
    Posts
    975
    Thank Post
    58
    Thanked 165 Times in 117 Posts
    Rep Power
    68
    What is your file upload limit set as?

    Is could be an issue with the upload limit being greater then the da file size it can server.

    Have a look at the value Maximum allowed content length in IIS under Request Filtering > Edit Feature Settings: Set 'Maximum allowed content length'
    The default value is 28mb, set it to something like 536870912 which is 512mb.

  2. #17

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,108
    Thank Post
    892
    Thanked 1,754 Times in 1,512 Posts
    Blog Entries
    12
    Rep Power
    458
    Just done that, doesn't seem to help. Is it the upload limit in PHP that could be the issue? Sorry about the long reply.

  3. #18
    InterwebsGuy's Avatar
    Join Date
    Jan 2011
    Posts
    233
    Thank Post
    59
    Thanked 25 Times in 25 Posts
    Rep Power
    12
    Quote Originally Posted by FN-GM View Post
    Just done that, doesn't seem to help. Is it the upload limit in PHP that could be the issue? Sorry about the long reply.
    Yes, that should also match the IIS value.

    If it were failing to upload due to that limit, that wouldn't really make sense as to why they might display in one browser but not another.
    Last edited by InterwebsGuy; 25th July 2013 at 10:20 AM.

  4. #19

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,108
    Thank Post
    892
    Thanked 1,754 Times in 1,512 Posts
    Blog Entries
    12
    Rep Power
    458
    Set memory, upload to 512 and the IIS settings that @penfold_99 said and its still happening

  5. #20
    InterwebsGuy's Avatar
    Join Date
    Jan 2011
    Posts
    233
    Thank Post
    59
    Thanked 25 Times in 25 Posts
    Rep Power
    12
    Quote Originally Posted by FN-GM View Post
    Set memory, upload to 512 and the IIS settings that @penfold_99 said and its still happening
    Can you confirm I understand correctly; an image that is failing to display in one browser displays in another? Because if so that really would rule out server settings I would imagine.

  6. #21

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,108
    Thank Post
    892
    Thanked 1,754 Times in 1,512 Posts
    Blog Entries
    12
    Rep Power
    458
    Not quite. In IE sometimes the images display sometimes they dont. If i refresh different images fail to load. Same in chrome. Firefox seems to work fine every time.

    I can see in chrome its a 500 error message.

  7. #22
    InterwebsGuy's Avatar
    Join Date
    Jan 2011
    Posts
    233
    Thank Post
    59
    Thanked 25 Times in 25 Posts
    Rep Power
    12
    Quote Originally Posted by FN-GM View Post
    Not quite. In IE sometimes the images display sometimes they dont. If i refresh different images fail to load. Same in chrome. Firefox seems to work fine every time.

    I can see in chrome its a 500 error message.
    Do you have Zlib compression enabled in the PHP.ini? If you do it might be worth disabling that and seeing if the outcome is any different. Give the IIS service a restart after that to ensure it takes effect. To be honest, I'd be inclined to disable any IIS compression that may be happening too.

    Do you have anything other than Moodle on your server? If so, any issues with that?

  8. #23

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,108
    Thank Post
    892
    Thanked 1,754 Times in 1,512 Posts
    Blog Entries
    12
    Rep Power
    458
    zlib.output_compression = Off

    Only got moodle on the box. I dont think i have any IIS compression.

    THanks

  9. #24
    InterwebsGuy's Avatar
    Join Date
    Jan 2011
    Posts
    233
    Thank Post
    59
    Thanked 25 Times in 25 Posts
    Rep Power
    12
    Quote Originally Posted by FN-GM View Post
    zlib.output_compression = Off

    Only got moodle on the box. I dont think i have any IIS compression.

    THanks
    I think IIS has some compression on by default, but IRC zlib compression is often the problematic one.

    I'm really out of ideas for now, if I think of anything else, I'll let you know.

  10. Thanks to InterwebsGuy from:

    FN-GM (25th July 2013)

  11. #25

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,108
    Thank Post
    892
    Thanked 1,754 Times in 1,512 Posts
    Blog Entries
    12
    Rep Power
    458
    Im still stuck on this if someone else has any ideas please?

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Smartboard 500 series Problems
    By witch in forum Hardware
    Replies: 1
    Last Post: 27th May 2011, 11:51 AM
  2. IIS problems http to https redirection
    By cheredenine in forum Internet Related/Filtering/Firewall
    Replies: 7
    Last Post: 27th February 2009, 05:14 PM
  3. IIS 6 Problem - HELP
    By Nij.UK in forum Windows
    Replies: 0
    Last Post: 7th February 2007, 12:01 PM
  4. IE6 https problem
    By Spongor in forum Windows
    Replies: 7
    Last Post: 2nd November 2006, 09:25 AM
  5. Liberum problems on IIS
    By OverWorked in forum Windows
    Replies: 8
    Last Post: 31st March 2006, 12:34 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •