+ Post New Thread
Results 1 to 15 of 15
Windows Server 2008 Thread, Urgent Help Needed! (School Website) in Technical; Hi Guys I have just been updating our web server Updated moodle fine Updated mysql fine Now php is the ...
  1. #1
    pritchardavid's Avatar
    Join Date
    Sep 2009
    Location
    South Ockendon, Thurrock, United Kingdom
    Posts
    932
    Thank Post
    18
    Thanked 64 Times in 58 Posts
    Rep Power
    26

    Urgent Help Needed! (School Website)

    Hi Guys

    I have just been updating our web server

    Updated moodle fine
    Updated mysql fine


    Now php is the problem

    Ok I uninstalled 5.2

    And installed the latest 5.3

    Now everytime I go to the website, it doesnt open - if you want to try -
    http://www.ockendonschool.com/

    But php is working because I can pull up the phpinfo.php
    phpinfo()



    Even tried copying over the old php.ini into the php, that hasent helped eithier



    Any ideas?

    Could removing php 5.2 removed some setting in iis7?
    I did set this up to start with, with the microsft web platform


    Wish I have never touched it now

  2. #2


    tom_newton's Avatar
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    4,507
    Thank Post
    871
    Thanked 862 Times in 681 Posts
    Rep Power
    199
    Anything in the logs?

  3. #3

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,376
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Is your server x64?

    You will need to set a compatibility setting in IIS if it is

  4. #4
    pritchardavid's Avatar
    Join Date
    Sep 2009
    Location
    South Ockendon, Thurrock, United Kingdom
    Posts
    932
    Thank Post
    18
    Thanked 64 Times in 58 Posts
    Rep Power
    26
    nope nothing in the logs

  5. #5
    pritchardavid's Avatar
    Join Date
    Sep 2009
    Location
    South Ockendon, Thurrock, United Kingdom
    Posts
    932
    Thank Post
    18
    Thanked 64 Times in 58 Posts
    Rep Power
    26
    Quote Originally Posted by FN-GM View Post
    Is your server x64?

    You will need to set a compatibility setting in IIS if it is
    nope it's running server 2008 x86

  6. #6

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,376
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Quote Originally Posted by p-dave View Post
    nope it's running server 2008 x86
    Dam thought i had it then

  7. #7
    pritchardavid's Avatar
    Join Date
    Sep 2009
    Location
    South Ockendon, Thurrock, United Kingdom
    Posts
    932
    Thank Post
    18
    Thanked 64 Times in 58 Posts
    Rep Power
    26
    even install the old 5.2 on there aint working, even pasting back my 5.2 ini file that I backed up with all the settings

  8. #8

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,867
    Thank Post
    412
    Thanked 778 Times in 651 Posts
    Rep Power
    183
    Seems fine to me...

  9. #9


    Join Date
    Sep 2008
    Posts
    1,858
    Thank Post
    354
    Thanked 264 Times in 216 Posts
    Rep Power
    121
    Fine to me too.

  10. #10

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    5,375
    Thank Post
    958
    Thanked 1,630 Times in 1,103 Posts
    Blog Entries
    47
    Rep Power
    711
    Working for me... whatever you did overnight fixed it

  11. #11

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,460
    Thank Post
    409
    Thanked 672 Times in 614 Posts
    Rep Power
    192
    Working here too.

  12. #12

    Join Date
    May 2010
    Location
    Kent
    Posts
    375
    Thank Post
    43
    Thanked 47 Times in 45 Posts
    Rep Power
    26
    Looks absolutely fine. One of those things maybe?

  13. #13
    Aaron's Avatar
    Join Date
    Feb 2009
    Location
    N.Ireland
    Posts
    251
    Thank Post
    78
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    yea everything working here

  14. #14
    pritchardavid's Avatar
    Join Date
    Sep 2009
    Location
    South Ockendon, Thurrock, United Kingdom
    Posts
    932
    Thank Post
    18
    Thanked 64 Times in 58 Posts
    Rep Power
    26
    That's weird my post must of never went through

    Had to install php 5.2 from the Microsoft web platform to get it working in the end


    Any one know how to get it working with php5.3?

  15. #15
    tonyd's Avatar
    Join Date
    Mar 2006
    Location
    Kent (Sometimes), UK
    Posts
    163
    Thank Post
    17
    Thanked 42 Times in 31 Posts
    Rep Power
    25
    Looking at this, http://moodle.org/mod/forum/discuss.php?d=154577, I'd say you'd be best sticking with the mature 5.2.x version for a while yet. 5.3.x is still quite young, and does not seem to be really well supported by moodle yet.



SHARE:
+ Post New Thread

Similar Threads

  1. Urgent info needed.
    By laserblazer in forum General Chat
    Replies: 22
    Last Post: 17th June 2010, 04:22 PM
  2. Urgent Fix Needed
    By pritchardavid in forum Wireless Networks
    Replies: 15
    Last Post: 26th February 2010, 11:42 PM
  3. Outsourcing school website, advice needed.
    By dblclick in forum General Chat
    Replies: 12
    Last Post: 9th October 2008, 09:06 AM
  4. Urgent Help needed!
    By The_GuRu in forum Network and Classroom Management
    Replies: 27
    Last Post: 20th February 2008, 10:20 AM
  5. needed ...urgent
    By russdev in forum General EduGeek News/Announcements
    Replies: 2
    Last Post: 10th February 2006, 10:59 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •