+ Post New Thread
Results 1 to 6 of 6
Windows Server 2008 Thread, Web Server 2008 services won't start in Technical; I've just looked at my external ePortal server (Web Server 2008) and nothing much is running on it. It's virtualised ...
  1. #1
    OverWorked's Avatar
    Join Date
    Jul 2005
    Location
    N. Yorks
    Posts
    1,010
    Thank Post
    196
    Thanked 42 Times in 34 Posts
    Rep Power
    30

    Web Server 2008 services won't start

    I've just looked at my external ePortal server (Web Server 2008) and nothing much is running on it. It's virtualised (VMWare Server) but that shouldn't make a difference.

    There's no network connection, and a lot of automatic services aren't running. When I try to start any of them I get error 1053. The event viewer doesn't show anything obvious about services not running (I think that's another symptom - events just aren't getting logged - Windows Error Reporting Service isn't running). Even if I try to restart some of the running services, they won't restart.

    I back up the VM every week with a script to stop it, copy and restart it. The backup is also corrupt.

    I could just create a new VM, and reinstall ePortal and the SSL cert, although on IIS7 that's not a quick job.

    Any ideas?

    Automatic Services not running:-

    Application Experience
    Application Host Helper
    Cryptographic Services
    Diagnostic Policy Service
    Distributed Link Tracking Client
    Facility Data Server
    Facility ePortal
    IKE...
    IP Helper
    IPSec policy
    Network List Service
    Network Location Awareness
    Print Spooler
    Remote Registry
    Secondary logon
    Server
    Sophos (various)
    Terminal Services
    VMWare Tools
    Windows Error Reporting Service
    WMI
    Windows Time
    WWW Publishing
    Distributed Transaction
    KtmRm
    TPM Base
    Windows Remote Management
    Windows Update

    Thanks!

  2. #2

    Join Date
    Apr 2006
    Posts
    387
    Thank Post
    23
    Thanked 95 Times in 61 Posts
    Rep Power
    44
    How about setting them to manual, except for the error reporting service, and see if it boots happily - then bring the services up one at a time and keep an eye on the error log?

  3. Thanks to theriver from:

    OverWorked (4th February 2010)

  4. #3

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,777
    Thank Post
    865
    Thanked 1,664 Times in 1,449 Posts
    Blog Entries
    11
    Rep Power
    442
    Sounds like the IP stack needs reseting. Give it a shot - How to reset Internet Protocol (TCP/IP)

    I had a similar problem here on an IIS server. Most services wouldn't start. Got all sorts of various error messages when i tried to start them one of them was "a service that should never failed has failed"
    Last edited by FN-GM; 3rd February 2010 at 07:26 PM.

  5. #4

    Join Date
    Aug 2005
    Location
    London
    Posts
    3,154
    Thank Post
    114
    Thanked 527 Times in 450 Posts
    Blog Entries
    2
    Rep Power
    123
    Maybe a stupid question, but have you run out of disc space?

    Error reporting shouldn't be running - it's the thing which deals with sending reports to MS after blue screens etc.

    Could the permissions be messed up? SYSTEM needs full control pretty much everywhere and if it hasn't got it then I'd expect weirdness (but no idea how that could happen!)

    Bad news about the backups. Do you have more than 1? If you could get a working server back from one of them then you could perhaps get data off the current machine (although without networking it's harder but you should be able to just add it as a second drive to the working VM)

  6. #5
    OverWorked's Avatar
    Join Date
    Jul 2005
    Location
    N. Yorks
    Posts
    1,010
    Thank Post
    196
    Thanked 42 Times in 34 Posts
    Rep Power
    30

    Working again

    Thanks everyone. I got it working again, but couldn't find the cause.

    In order, I tried:-

    1) FN-GM's suggestion for the IP stack. Good idea, but made no difference.
    2) srochford: disk space OK, SYSTEM permissions looked OK.
    3) theriver: had to restart in safe mode, then used msconfig to disable the non-ms services, and the services control to set the ms services to manual. Rebooted OK, and slowly restarted each service and set back to auto. No problems.

    I've spent about 4 hours and rebooted several times with all the stopped services now running and it's perfectly OK.

    I have no idea what was causing the problem. System and application logs show nothing untoward. Total mystery.

    Thanks for all the suggestions.

  7. #6

    Join Date
    Sep 2011
    Location
    Darlington
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi

    Just to bump an old thread, i ran the ip reset command and this didnt work. Then went into safe mode, just rebooted out of safe mode and voila things started working again. God knows why this fixed it but the cause in our case was a power outage made it unhappy.

    So the above post is bang on.

    Cheers

SHARE:
+ Post New Thread

Similar Threads

  1. Moodle / Server 2008 / IIS7 / MS SQL Server 2008 Express
    By Kamran7860 in forum Virtual Learning Platforms
    Replies: 3
    Last Post: 23rd November 2010, 06:03 AM
  2. [Windows Software] Server 2008 R2 Remote Desktop Services
    By HMCTech in forum Licensing Questions
    Replies: 1
    Last Post: 4th November 2009, 10:49 AM
  3. Start a disabled service using server 2008 GPO
    By FN-GM in forum Windows Server 2008
    Replies: 4
    Last Post: 12th March 2009, 10:13 PM
  4. Replies: 8
    Last Post: 23rd April 2008, 10:33 PM
  5. Power mac G3 won't start
    By dezt in forum Mac
    Replies: 5
    Last Post: 10th January 2007, 04:15 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •