+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 17
Windows Server 2008 Thread, iis7 server 2008 setup in Technical; I want to setup our new joomla site on 2008, So I looked for some tutorials and so Far I've ...
  1. #1
    PEO
    PEO is offline
    PEO's Avatar
    Join Date
    Oct 2007
    Posts
    2,093
    Thank Post
    457
    Thanked 150 Times in 95 Posts
    Rep Power
    71

    iis7 server 2008 setup

    I want to setup our new joomla site on 2008, So I looked for some tutorials and so Far I've done the following

    installed IIS7, MYSQL, MYPHP

    Before I go any further I wanted to make sure that a simple static website could be created.

    So I created one called staff.... this was 2 hours ago.. I just cant seem to access a simple static webpage.

    if I type in to browser from remote machine

    http://staff it struggles to find then shoots off to google.

    now If type http://(server name)/staff I get a "404 Error file or directory not found"

    Any Ideas?

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,955
    Thank Post
    886
    Thanked 1,700 Times in 1,477 Posts
    Blog Entries
    12
    Rep Power
    448
    Did you put an A record in DNS called staff and pointed it to the Server?

  3. Thanks to FN-GM from:

    PEO (27th July 2009)

  4. #3

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,763
    Thank Post
    3,273
    Thanked 1,053 Times in 974 Posts
    Rep Power
    365
    Quote Originally Posted by FN-GM View Post
    Did you put an A record in DNS called staff and pointed it to the Server?
    that or alter the clients host file to point to the server ?

  5. Thanks to mac_shinobi from:

    PEO (27th July 2009)

  6. #4
    PEO
    PEO is offline
    PEO's Avatar
    Join Date
    Oct 2007
    Posts
    2,093
    Thank Post
    457
    Thanked 150 Times in 95 Posts
    Rep Power
    71
    nope

  7. #5
    PEO
    PEO is offline
    PEO's Avatar
    Join Date
    Oct 2007
    Posts
    2,093
    Thank Post
    457
    Thanked 150 Times in 95 Posts
    Rep Power
    71
    I have 1 week off work and I make a school boy error as easy as that... cheers

  8. #6

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,955
    Thank Post
    886
    Thanked 1,700 Times in 1,477 Posts
    Blog Entries
    12
    Rep Power
    448
    Quote Originally Posted by PEO View Post
    I have 1 week off work and I make a school boy error as easy as that... cheers
    No problem, i do it all the time. Glad you got it sorted.

  9. Thanks to FN-GM from:

    PEO (27th July 2009)

  10. #7
    PEO
    PEO is offline
    PEO's Avatar
    Join Date
    Oct 2007
    Posts
    2,093
    Thank Post
    457
    Thanked 150 Times in 95 Posts
    Rep Power
    71
    Right I've copied across joomla files to do a setup on the server and I am getting the following

    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

    anyone come across this?
    Last edited by PEO; 27th July 2009 at 03:25 PM.

  11. #8

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,955
    Thank Post
    886
    Thanked 1,700 Times in 1,477 Posts
    Blog Entries
    12
    Rep Power
    448
    Have you installed PHP?

  12. #9
    PEO
    PEO is offline
    PEO's Avatar
    Join Date
    Oct 2007
    Posts
    2,093
    Thank Post
    457
    Thanked 150 Times in 95 Posts
    Rep Power
    71
    Quote Originally Posted by FN-GM View Post
    Have you installed PHP?
    Yes


    php.ini file attached
    Attached Files Attached Files

  13. #10


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,690
    Thank Post
    352
    Thanked 796 Times in 715 Posts
    Rep Power
    347
    Knock up a .php file and try and browse to it with the following content.

    Code:
    <?php
    phpinfo();
    ?>
    See if that works.

  14. #11

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,763
    Thank Post
    3,273
    Thanked 1,053 Times in 974 Posts
    Rep Power
    365
    Turn Off Friendly HTTP Error Messages in IE - Internet Explorer

    Should try and help you debug the error message you are getting.

  15. #12
    PEO
    PEO is offline
    PEO's Avatar
    Join Date
    Oct 2007
    Posts
    2,093
    Thank Post
    457
    Thanked 150 Times in 95 Posts
    Rep Power
    71
    ok created php file caled it index.php

    also turned off freindley error messages in IE.

    Still getting Server Error
    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

  16. #13
    dgsmith's Avatar
    Join Date
    Nov 2007
    Location
    Merseyside, England
    Posts
    1,104
    Thank Post
    118
    Thanked 90 Times in 78 Posts
    Rep Power
    36
    For what it's worth, I have also just setup an installation recently of server 2008, with php and mysql, and was getting 500 errors with PHP. I just needed to browse to php.ini and set the config for error logging (you can make it log to a file or the internal system events); on my installation, neither was setup, and I did the latter, and then php pages loaded as expected.

    I have no idea if this will help or even work for you (I don't think I did anything else besides this, but maybe I did sub-conciously and not realise it). Give it a try at least - if it does work, chances are that is what the problem was for me. I did some fiddling too with the security on the php.ini file and subfolders within, but can't recall if this was during or after fixing our 500 error!

  17. Thanks to dgsmith from:

    PEO (27th July 2009)

  18. #14
    PEO
    PEO is offline
    PEO's Avatar
    Join Date
    Oct 2007
    Posts
    2,093
    Thank Post
    457
    Thanked 150 Times in 95 Posts
    Rep Power
    71
    which line is it please?

  19. #15
    dgsmith's Avatar
    Join Date
    Nov 2007
    Location
    Merseyside, England
    Posts
    1,104
    Thank Post
    118
    Thanked 90 Times in 78 Posts
    Rep Power
    36
    Code:
    ; Log errors to specified file.
    ;error_log = C:\Program Files (x86)\PHP\logs\php.log
    
    ; Log errors to syslog (Event Log on NT, not valid in Windows 95).
    error_log = syslog
    For me, the second "error_log" was commented out (with ; in front). Line numbers may differ, so I guess just search the file for error_log.

    It may not even be that, but worth a check I guess. We're running Windows in 64bit if that makes any difference..

  20. Thanks to dgsmith from:

    PEO (28th July 2009)

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Moodle / Server 2008 / IIS7 / MS SQL Server 2008 Express
    By Kamran7860 in forum Virtual Learning Platforms
    Replies: 3
    Last Post: 23rd November 2010, 06:03 AM
  2. Radius setup with 2008 server
    By ful56_uk in forum Wireless Networks
    Replies: 1
    Last Post: 17th July 2009, 10:19 PM
  3. Server 2008 R2 RC & Ms Hyper-V Server 2008 R2 Beta
    By Kamran7860 in forum Windows Server 2008 R2
    Replies: 4
    Last Post: 12th May 2009, 06:04 PM
  4. IIS7, Server 2008 & MediaWiki! Grrr!
    By flexyjerkov in forum Windows
    Replies: 0
    Last Post: 12th May 2009, 09:07 AM
  5. Replies: 1
    Last Post: 5th May 2009, 02:17 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •