+ Post New Thread
Results 1 to 12 of 12
Windows Server 2008 Thread, Desktop.ini and My Documents in Technical; System almost ready for next week and just looking at home folder and notice that user folders are now My ...
  1. #1
    TechSupp's Avatar
    Join Date
    Mar 2007
    Location
    South Yorkshire
    Posts
    1,927
    Thank Post
    318
    Thanked 122 Times in 103 Posts
    Rep Power
    42

    Desktop.ini and My Documents

    System almost ready for next week and just looking at home folder and notice that user folders are now My Documents. I know of this problem and when setting it up a powershell script to deny users access to the desktop.ini to stop this and it seemed to be working, however now users are logging on I seem to have My Documents again? We use redirected folders etc and local profiles and did read that this goes away after first creation of that local profile? Anyone confirm that?

    Whats the best way to stop this happening or can I just do a massive search and delete of all the desktop.ini files in the folders of the users in the home directory?
    I have for the moment just added the Filename column to the explorer view to see whats what but not ideal as I need to run a file dialogue box which shows up the folder names as displayed and I cant see which one to select as it stands only in a windows explorer view.
    Last edited by TechSupp; 1st September 2012 at 08:24 PM.

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,229
    Thank Post
    894
    Thanked 1,780 Times in 1,534 Posts
    Blog Entries
    12
    Rep Power
    462
    Dont deny permissions this will slow your login process. We did this and it added 30 - 45 seconds onto the login times.

    There are lots of solutions on here for it. We put all our home folders in a sub folder.

    For example

    -JohnSmith
    --Documents

  3. #3
    TechSupp's Avatar
    Join Date
    Mar 2007
    Location
    South Yorkshire
    Posts
    1,927
    Thank Post
    318
    Thanked 122 Times in 103 Posts
    Rep Power
    42
    Quote Originally Posted by FN-GM View Post
    Dont deny permissions this will slow your login process. We did this and it added 30 - 45 seconds onto the login times.

    There are lots of solutions on here for it. We put all our home folders in a sub folder.

    For example

    -JohnSmith
    --Documents
    Thanks, but that was one of the options given on here somewhere. Dont want to go messing with the folder structure now as everyone back in on Monday and not risking doing it remotely.
    What about the quick and dirty fix of just deleting all the desktop.ini files found? Have got a routine that will do that as each user logs off but dont know if that would work.

  4. #4
    oxide54's Avatar
    Join Date
    Mar 2009
    Posts
    798
    Thank Post
    51
    Thanked 55 Times in 54 Posts
    Rep Power
    23

  5. #5
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    Quote Originally Posted by FN-GM View Post
    Dont deny permissions this will slow your login process. We did this and it added 30 - 45 seconds onto the login times.
    I also had the same issue, but you can work around it by doing folder redirection manually (e.g. use a login script to set registry keys) instead of using folder redirection through group policy.

  6. #6

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    Leave the my docs as is but add a new column to show the user name.

  7. #7
    TechSupp's Avatar
    Join Date
    Mar 2007
    Location
    South Yorkshire
    Posts
    1,927
    Thank Post
    318
    Thanked 122 Times in 103 Posts
    Rep Power
    42
    Yep, done that so can see names but cant see that column when using a file selection dialogue box, thatz half my problem.

  8. #8

    Join Date
    Feb 2009
    Location
    Essex
    Posts
    225
    Thank Post
    22
    Thanked 16 Times in 12 Posts
    Rep Power
    14
    Best solution I found was to add a Logoff Script to the GPO for the users.

    Save this as anything.vbs and then add it to:
    User Config>Policies>Windows Settings>Scripts>Logoff

    When users logoff it deletes the desktop.ini file solving this problem.

    Code:
    On Error Resume Next
    Set WSHShell = WScript.CreateObject("WScript.Shell")
    Set FSO = CreateObject("Scripting.FileSystemObject")
    
    DocsPath = WSHShell.SpecialFolders("MyDocuments")
    
    If FSO.FileExists (DocsPath & "\desktop.ini") Then
      FSO.DeleteFile (DocsPath & "\desktop.ini")
    End If

  9. 2 Thanks to CommodoreS:

    3s-gtech (18th September 2012), zag (18th September 2012)

  10. #9

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,229
    Thank Post
    894
    Thanked 1,780 Times in 1,534 Posts
    Blog Entries
    12
    Rep Power
    462
    Quote Originally Posted by CommodoreS View Post
    Best solution I found was to add a Logoff Script to the GPO for the users.

    Save this as anything.vbs and then add it to:
    User Config>Policies>Windows Settings>Scripts>Logoff

    When users logoff it deletes the desktop.ini file solving this problem.

    Code:
    On Error Resume Next
    Set WSHShell = WScript.CreateObject("WScript.Shell")
    Set FSO = CreateObject("Scripting.FileSystemObject")
    
    DocsPath = WSHShell.SpecialFolders("MyDocuments")
    
    If FSO.FileExists (DocsPath & "\desktop.ini") Then
      FSO.DeleteFile (DocsPath & "\desktop.ini")
    End If


    No good if they dont log off properly or they are still logged on when finding the home area.

  11. #10
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,907
    Thank Post
    954
    Thanked 451 Times in 380 Posts
    Blog Entries
    12
    Rep Power
    93
    Thanks for that script.

    This has been driving me nuts for years now.

  12. #11
    detjo's Avatar
    Join Date
    Feb 2008
    Posts
    364
    Thank Post
    13
    Thanked 48 Times in 39 Posts
    Rep Power
    31
    As suggested in the linked thread, I use FSRM for this.

    Docs folders are redirected to \\Server\Doc$\Staff\%username% I had an 'executable' policy in FSRM anyway (for \\Server\Doc$ to cover students as well) so i added 'desktop.ini' to that as it was only one file.
    It's been working great for about a year or so

  13. Thanks to detjo from:

    oxide54 (26th September 2012)

  14. #12
    oxide54's Avatar
    Join Date
    Mar 2009
    Posts
    798
    Thank Post
    51
    Thanked 55 Times in 54 Posts
    Rep Power
    23
    Quote Originally Posted by detjo View Post
    As suggested in the linked thread, I use FSRM for this.

    Docs folders are redirected to \\Server\Doc$\Staff\%username% I had an 'executable' policy in FSRM anyway (for \\Server\Doc$ to cover students as well) so i added 'desktop.ini' to that as it was only one file.
    It's been working great for about a year or so

    that answer was the reason i subscribed to this thread!

SHARE:
+ Post New Thread

Similar Threads

  1. sync external hard drive and my documents on domain
    By imiddleton25 in forum General Chat
    Replies: 1
    Last Post: 3rd June 2011, 10:04 AM
  2. Moving Servers - Profiles and My Documents
    By benIT in forum Windows
    Replies: 13
    Last Post: 10th December 2009, 12:05 PM
  3. Replies: 12
    Last Post: 11th October 2009, 11:56 PM
  4. Placing the My Documents on Desktop via GPO or Script
    By ninjabeaver in forum Windows Server 2000/2003
    Replies: 3
    Last Post: 29th August 2009, 12:14 AM
  5. Mandatory profiles and my documents problem
    By NIKKI19 in forum Network and Classroom Management
    Replies: 1
    Last Post: 19th May 2009, 03:20 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •