Hello!

Im having some problems with setting up a Remote Desktop Web access connection. Ive installed all the RD roles except for virtualization and broker. I'm not 100% sure that I have configured everything correctly, but Ive been following a few guides and threads from different forums.

Ill go through my settins from the RemoteApp Manager window:

RD Session Host Server Settings:
Clients will connect to: remoteserver (I have not typed FQDN or the domain name at all here. Simply the computer name of the RDserver)
Port 3389(default)
Show a remote desktop connection to this RD Sesstion Host server in RD Web Access
Do not allow users to start unlisted programs or initial connection(Recommended)
RD Gateway Settings:
Set to automatically detect RD Gateway server settings
Digital Signature Settings:
Created a digital signature which is signed as : FQDN (remoteserver.domain.se)
RDP Settings:
Custom RDP settings set;
- Printers, Clipboard, Supported Plug and Play devices, Disk drivers, Smart cards
-Allow font smoothing color 32 bit.
Not checked: Use all client monitors...
Distribution with RD Web Access
The Web Access Computers group is populated with Domain Users
All RemoteApp programs are visible in RD Web Access
RD Gateway Manager:
Resource Authorization Policies;
- Default Name, Group: Domain Users, Allowed resources: Access allowed to all network resources, Location: Not Applicable, Port: 3389, Status: Enabled
Connection Authorization Policies;
- Default Name, Group: Domain Users, Client computer Groups: Not applicable, Status: Enabled

------------------------------------------


I can reach the RDWeb connection just fine internally from the local network its hosted from. But when trying to reach it from an external source(which is the reason I want this) I just get error 404 when trying to access: https:// remoteserver.domain.se/RDWeb

Ive also turned off the whole firewall on my RD server,
Added a CNAME value to my webhost for our website(the setting looks something like the following) : remoteserver.domain.se CNAME domain.se
The CNAME I was told to add through a GUIDE I used, but I don't know if I set it up correctly.
Also added this to my router config:
WAN TCP (External port) 443 HTTPS 192.168.20.8(remote server internal IP) (Internal Port) 443 HTTPS


Any clues what I might have done wrong?