+ Post New Thread
Results 1 to 6 of 6
Windows Server 2008 R2 Thread, rdp 2008 r2 firewall rule issue in Technical; 2008r2 behind nat router, port forwarding rdp to server. I have static ip, again behind nat router. want to set ...
  1. #1

    Join Date
    May 2006
    Location
    Lytham
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    rdp 2008 r2 firewall rule issue

    2008r2 behind nat router, port forwarding rdp to server.
    I have static ip, again behind nat router.
    want to set firewall to only accept rdp from my ip (static public IP of my router)
    2008f.png
    So i assume that i would put my ip in the lower of the two boxes.
    Surprise, it doesn't work.....
    So for a gold star and 10 brownie points
    Does port forwarding on a NAT router forward or does it handle the communication? (i.e. change the source IP in the packet header)?
    or is there another issue here?

    TIA

    Roy
    Last edited by roymorden; 26th May 2012 at 07:53 PM.

  2. #2

    m25man's Avatar
    Join Date
    Oct 2005
    Location
    Romford, Essex
    Posts
    1,618
    Thank Post
    49
    Thanked 448 Times in 331 Posts
    Rep Power
    136
    Your firewall will need to be set to accept connections from your real public IP (of the initiating client)

  3. #3

    Join Date
    May 2006
    Location
    Lytham
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    That's what I did, put my public IP in the lower section and it doesn't work

  4. #4

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,789
    Thank Post
    272
    Thanked 1,132 Times in 1,028 Posts
    Rep Power
    349
    It depends what firewall you are using - it may be showing that the session is coming from it rather that the outside world. But depends what firewall your using.

  5. #5

    m25man's Avatar
    Join Date
    Oct 2005
    Location
    Romford, Essex
    Posts
    1,618
    Thank Post
    49
    Thanked 448 Times in 331 Posts
    Rep Power
    136
    I assume you have tested your RDP works internally first.
    If it does, try setting up your IPsec to/from an internal client before you begin looking at the router.

  6. #6

    Join Date
    May 2006
    Location
    Lytham
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    RDP works internally and externally.(with no restriction on source IP)
    Firewall is the one that ships with R2
    router is a thompson (similar to o2 and Be)
    Site is some distance away so no local access hence the rdp.
    Will look at securing with IPSEC.
    Thanks for trying

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 20
    Last Post: 24th September 2011, 12:51 PM
  2. 2008 R2 Print Server - any issues?
    By gshaw in forum Windows Server 2008 R2
    Replies: 2
    Last Post: 7th April 2011, 11:23 AM
  3. Server 2008 R2 Ricoh printer margin issue URGENT!
    By rocknrollstar in forum Windows Server 2008 R2
    Replies: 1
    Last Post: 6th September 2010, 09:57 PM
  4. Replies: 0
    Last Post: 17th May 2010, 09:25 AM
  5. Server 2008 R2 SP1 and RemoteFX bring full 3D over RDP
    By SYNACK in forum Windows Server 2008 R2
    Replies: 0
    Last Post: 19th March 2010, 12:27 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •