+ Post New Thread
Results 1 to 11 of 11
Windows Server 2008 R2 Thread, My Documents Homedrive in Technical; Curious problem, hoping someone can help me with. We have our student my documents folder redirected using group policies to ...
  1. #1
    Bezwick's Avatar
    Join Date
    Feb 2008
    Location
    Nottinghamshire
    Posts
    354
    Thank Post
    92
    Thanked 54 Times in 41 Posts
    Rep Power
    24

    Smile My Documents Homedrive

    Curious problem, hoping someone can help me with.

    We have our student my documents folder redirected using group policies to

    \\server\year$\%username%

    It all works fine, except recently i have noticed that some of the students homespaces when looked at from the server reay as lots of my documents folders instead of their usernames. Anyone know whats causing this as its a real pain when trying to fina a students work on the server.
    The permissions are remaining correct and the students are not having any problems saving its just difficult to find their homespace when i need to find or restore files.

    We are running a Windows Server 2008 R2 network mostly with Windows XP, and a few Windows 7 clients.

    Anyone have any ideas as it seams to be spreading to more and more students. So far staff have been unaffected.

    Cheers

  2. #2

    Join Date
    May 2010
    Posts
    993
    Thank Post
    98
    Thanked 74 Times in 60 Posts
    Rep Power
    45

  3. Thanks to caffrey from:

    Bezwick (29th November 2011)

  4. #3
    DAZZD88's Avatar
    Join Date
    Apr 2009
    Location
    Sunderland, Tyne and Wear
    Posts
    788
    Thank Post
    163
    Thanked 77 Times in 66 Posts
    Rep Power
    47
    Quote Originally Posted by caffrey View Post
    I've not tried to fix it yet, just wondered how other people are fixing this?
    I hate to be the guy to say it but there are many posts on here about this, some by myself and they include solutions too. A search should bring up some threads.

  5. #4

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,786
    Thank Post
    272
    Thanked 1,130 Times in 1,026 Posts
    Rep Power
    348
    if you do a directory listing from the command line it comes up correctly - its an win 7/2k8r2 bug

  6. #5
    Bezwick's Avatar
    Join Date
    Feb 2008
    Location
    Nottinghamshire
    Posts
    354
    Thank Post
    92
    Thanked 54 Times in 41 Posts
    Rep Power
    24
    Just tried their deleting the desktop.ini file at logoff and it appears to solve the problem. Brilliant

  7. #6

    Join Date
    May 2010
    Posts
    993
    Thank Post
    98
    Thanked 74 Times in 60 Posts
    Rep Power
    45
    Quote Originally Posted by DAZZD88 View Post
    I hate to be the guy to say it but there are many posts on here about this, some by myself and they include solutions too. A search should bring up some threads.
    heh I know, just this happened to be the first thread when i searched, I was alread actively seeking a solution

    tbh this solution seems easier

    Since Windows Vista and Windows 7, user home directories will all be renamed 'My Documents', but there's a simple way around this without using scripts! Navigate to the folder where your home directories are located. Right click in the column 'Size' > 'More...' Select 'Filename' in the list, then click OK. The username will now be displayed.

  8. #7

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,241
    Thank Post
    239
    Thanked 1,567 Times in 1,249 Posts
    Rep Power
    339
    That looks like one of my quotes Caffrey

  9. #8

    Join Date
    May 2010
    Posts
    993
    Thank Post
    98
    Thanked 74 Times in 60 Posts
    Rep Power
    45
    yeah sorry about that, i'd already cut and pasted and forgot where i got it from!

    thanks

  10. #9

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,773
    Thank Post
    865
    Thanked 1,663 Times in 1,448 Posts
    Blog Entries
    11
    Rep Power
    442
    Quote Originally Posted by caffrey View Post

    Since Windows Vista and Windows 7, user home directories will all be renamed 'My Documents', but there's a simple way around this without using scripts! Navigate to the folder where your home directories are located. Right click in the column 'Size' > 'More...' Select 'Filename' in the list, then click OK. The username will now be displayed.
    @Michael and others.
    Does anyone know a way in group policy to deploy this change on mass please?

    Thanks

  11. #10

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,241
    Thank Post
    239
    Thanked 1,567 Times in 1,249 Posts
    Rep Power
    339
    Quote Originally Posted by FN-GM View Post
    @Michael and others.
    Does anyone know a way in group policy to deploy this change on mass please?

    Thanks
    It's a good question. I explored this sometime ago and there is no documented method. It's something Microsoft may introduce in Windows Server 8.

    I just created a small userguide for staff who required this option.

  12. #11

    Join Date
    Feb 2012
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hello,
    This might help,
    Try using AutoIt3 for creating share or map drive instead of roaming their documents.

SHARE:
+ Post New Thread

Similar Threads

  1. My Documents Redirection
    By robbied69 in forum Windows
    Replies: 5
    Last Post: 28th September 2006, 09:23 AM
  2. wired my documents problem
    By ind13 in forum Windows
    Replies: 22
    Last Post: 12th September 2006, 03:46 PM
  3. Script to Create My Documents Subject Folders
    By SwedishChef in forum Scripts
    Replies: 15
    Last Post: 5th July 2006, 08:14 AM
  4. Redirecting "My Documents" Not Working!
    By secman in forum Windows
    Replies: 7
    Last Post: 14th February 2006, 11:56 AM
  5. Replies: 2
    Last Post: 9th January 2006, 07:43 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •