+ Post New Thread
Results 1 to 2 of 2
Windows Server 2008 R2 Thread, Permalinks IIS 7.5 (Server 2008 R2) in Technical; Having a bit of a problem with Permalinks links on the server. Im creating a new website for our Academy, ...
  1. #1
    pritchardavid's Avatar
    Join Date
    Sep 2009
    Location
    South Ockendon, Thurrock, United Kingdom
    Posts
    932
    Thank Post
    18
    Thanked 64 Times in 58 Posts
    Rep Power
    26

    Permalinks IIS 7.5 (Server 2008 R2)

    Having a bit of a problem with Permalinks links on the server.

    Im creating a new website for our Academy, and would like to make the links more user friendly hence I would like to use Permalinks.

    I have installed

    - IIS with every feature installed
    - Latest PHP
    - Latest MySQL
    - URl Rewriter 2.0
    - HTML is on top of the list for to be ran first

    I have the following running

    - Latest Moodle (In a subfolder)
    - Latest Wordpress which is the current website (In a subfolder)
    - Latest PHPMyAdmin
    - index.html in root which redirects to a subfolder called wordpress (website)
    - New wordpress installed at the root

    Now everytime I copy the web.config over to the root that wordpress made the CPU usage goes up to 100% about 30 seconds later of when I guess someone goes onto to one of the sites.

    Its php-cgi.exe that causing the CPU usage


    This is what is in the web.config file

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <rewrite>
    <rules>
    <rule name="wordpress" patternSyntax="Wildcard">
    <match url="*"/>
    <conditions>
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true"/>
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true"/>
    </conditions>
    <action type="Rewrite" url="index.php"/>
    </rule></rules>
    </rewrite>
    </system.webServer>
    </configuration>

    Ignore the layout of this, the forum has changed it

    Any ideas guys?

  2. #2
    pritchardavid's Avatar
    Join Date
    Sep 2009
    Location
    South Ockendon, Thurrock, United Kingdom
    Posts
    932
    Thank Post
    18
    Thanked 64 Times in 58 Posts
    Rep Power
    26
    never mind have sorted it finally!

    This has been annoying for the last 1-2 weeks!

    Seems it was getting permalinks settings from the root to the wordpress sub-directory, so disabled it from IIS under URL rewriting, then enable permalinks on the current website.

SHARE:
+ Post New Thread

Similar Threads

  1. Setting up Moodle on Server 2008 R2 IIS 7 SQL
    By thesk8rjesus in forum Web Development
    Replies: 2
    Last Post: 8th June 2010, 01:53 PM
  2. Server 2008 R2 Adprep Problem
    By FN-GM in forum Windows Server 2008 R2
    Replies: 25
    Last Post: 14th August 2009, 05:52 PM
  3. Server 2008 R2 Board
    By FN-GM in forum Comments and Suggestions
    Replies: 5
    Last Post: 24th June 2009, 01:36 PM
  4. Server 2008 R2 RC & Ms Hyper-V Server 2008 R2 Beta
    By Kamran7860 in forum Windows Server 2008 R2
    Replies: 4
    Last Post: 12th May 2009, 06:04 PM
  5. Replies: 1
    Last Post: 5th May 2009, 02:17 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •