+ Post New Thread
Results 1 to 6 of 6
Windows Server 2008 R2 Thread, Windows Internal Database in Technical; Hello all, I'm trying to install WSUS on 2008 R2, however it appears to fail when trying to install the ...
  1. #1

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328

    Windows Internal Database

    Hello all,

    I'm trying to install WSUS on 2008 R2, however it appears to fail when trying to install the Windows Internal Database.

    Here's the info I'm given:

    Code:
    2011-10-01 20:39:54  Success   MWUSSetup          Detected that setup was launched through Server Manager
    2011-10-01 20:39:55  Success   MWUSSetup          Validating pre-requisites...
    2011-10-01 20:39:55  Error     MWUSSetup          Failed to determine if an higher version of WSUS is installed. Assuming it is not... (Error 0x80070002: The system cannot find the file specified.)
    2011-10-01 20:39:55  Error     MWUSSetup          WSUS is outdated. But this will not block setup (Error 0x00000000: The operation completed successfully.)
    2011-10-01 20:40:04  Success   MWUSSetup          Initializing installation details
    2011-10-01 20:40:04  Success   MWUSSetup          Skipping Asp.Net install since not running on win2k3...
    2011-10-01 20:40:04  Success   MWUSSetup          Installing wYukon using ocsetup
    2011-10-01 20:40:04  Success   MWUSSetup          Installing Windows Internal database using ocsetup with command line as "ocsetup "WSSEE" /quiet /norestart"
    2011-10-01 20:40:17  Error     MWUSSetup          The process ocsetup "WSSEE" /quiet /norestart returned error: 0x643 (Error 0x80070643: Fatal error during installation.)
    2011-10-01 20:40:17  Error     MWUSSetup          ExecCmd failed (Error 0x80070643: Fatal error during installation.)
    2011-10-01 20:40:17  Error     MWUSSetup          Install Windows Internal database: Failed to execute "ocsetup "WSSEE" /quiet /norestart" (Error 0x80070643: Fatal error during installation.)
    2011-10-01 20:40:17  Error     MWUSSetup          CInstallDriver::PerformSetup: Installation of wYukon failed (Error 0x80070643: Fatal error during installation.)
    2011-10-01 20:40:17  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80070643: Fatal error during installation.)
    The problem I believe is on the 5th line from the bottom:

    Code:
    The process ocsetup "WSSEE" /quiet /norestart returned error: 0x643 (Error 0x80070643: Fatal error during installation.)
    Any ideas how to fix this? Many thanks.

  2. #2


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,208
    Thank Post
    218
    Thanked 812 Times in 694 Posts
    Rep Power
    274
    Have you tried downloading it rather than adding it as a role i find lea proxy makes add role fail

  3. #3

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    If I download WSUS 3 SP2 x64 and run it manually, it fails at exactly the same point - just as when I add it from the Server Manager. WSUS is failing because the Windows Internal Database (WID) cannot be installed.

    WID is there though, as it's located in: C:\Windows\SysMsiCache\WSSEE however Microsoft don't allow you to add it manually. It's supposed to get installed when it's needed. I suspect it's something registry related, because if I add another component which also needs the WID - such as the Windows System Resource Manager (under Features), this also fails.

  4. #4


    Join Date
    Feb 2007
    Location
    51.405546, -0.510212
    Posts
    8,113
    Thank Post
    203
    Thanked 2,385 Times in 1,765 Posts
    Rep Power
    703
    Have you tried installing SP1 for 2008 R2 (if it isn't already)?

  5. #5

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    Yes it's already installed. It was installed already integrated 'as new' during the summer. All my newly installed servers are running 2008 R2 with SP1.

    I downloaded it directly from Microsoft and isn't/wasn't a DVD I created.

  6. #6

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    I finally resolved this issue by migrating FSMO roles and other critical domain information, formatted the server, installed as new and migrated everything back.

    All is now well and the Windows Internal Database and WSUS works perfectly. I can only assume that there was something corrupt or missing in the registry.

SHARE:
+ Post New Thread

Similar Threads

  1. WSUS internal database V SQL2008
    By edutech4schools in forum Windows Server 2000/2003
    Replies: 4
    Last Post: 27th January 2011, 09:11 AM
  2. [Windows Software] Windows 2008 Server Student Access Licence
    By adamf in forum Licensing Questions
    Replies: 4
    Last Post: 4th February 2010, 04:51 PM
  3. [Windows Software] Windows 7 Student Offer
    By dannyjay in forum Licensing Questions
    Replies: 10
    Last Post: 30th October 2009, 11:31 AM
  4. Replies: 1
    Last Post: 8th November 2007, 08:22 PM
  5. Windows internal control error
    By witch in forum Windows
    Replies: 0
    Last Post: 15th June 2007, 08:25 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •