+ Post New Thread
Results 1 to 3 of 3
Windows Server 2008 R2 Thread, Slow Shutdown 2008 R2 in Technical; Hello all, Recently I have started deploying Windows Server 2008 R2, however in all cases, the Shutdown process is incredibly ...
  1. #1

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328

    Slow Shutdown 2008 R2

    Hello all,

    Recently I have started deploying Windows Server 2008 R2, however in all cases, the Shutdown process is incredibly long - anywhere between 30-45 minutes. This is because 2008 R2 clears the pagefile when shutting down Windows. I don't know if this affects Server 2008 R1.

    There's a simple fix for this:

    Open up Group Policy Management and disable the following under Default Domain Controllers Policy:

    Computer Config > Windows Settings > Security Settings > Local Policies > Security Options

    Shutdown: Clear virtual memory pagefile - Disabled

    When I disabled this and ran gpupdate /force, the Shutdown sequence (on a 2008 R2 domain controller) was less than 2 minutes.

    The way I like to setup Active Directory is to create an OU under Domain Controllers called Member Servers. By dragging all server computer objects, all future 2008 R2 servers will then pick up the policy.

  2. #2
    jamesfed's Avatar
    Join Date
    Sep 2009
    Location
    Reading
    Posts
    2,145
    Thank Post
    127
    Thanked 326 Times in 275 Posts
    Rep Power
    81
    Thats most odd and I can never say I've had that problem and we are all 2008 R2 here (both fresh install and upgrades) - oviously it is a page file thing if that GPO works but I would look at other causes too.

    Maybe something to do with the hardware you are running?

  3. #3

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    Well I did think hardware, but the servers in question are operating on decent Intel Snowhill motherboards, and under 2003 R2 this was never a problem. Both are using Intel Matrix RAID too, but I cannot imagine this being the problem.

    If you google the problem, other people have had the same problem, so I can only assume it's a bug possibly. This small tweak just makes restarting servers that bit easier without the wait

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 2
    Last Post: 8th June 2011, 10:21 PM
  2. Server 2008 R2 Board
    By FN-GM in forum Comments and Suggestions
    Replies: 5
    Last Post: 24th June 2009, 01:36 PM
  3. 2008 R2
    By TronXP in forum Windows Server 2008
    Replies: 23
    Last Post: 22nd June 2009, 10:15 AM
  4. Server 2008 R2 RC & Ms Hyper-V Server 2008 R2 Beta
    By Kamran7860 in forum Windows Server 2008 R2
    Replies: 4
    Last Post: 12th May 2009, 06:04 PM
  5. Replies: 1
    Last Post: 5th May 2009, 02:17 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •