+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21
Windows Server 2008 R2 Thread, 2008R2 sp1 killed our Wyse S10's RDP Connection in Technical; None of our clients have been able to connect since applying the SP, so we're going to have to return ...
  1. #1

    Join Date
    Jul 2009
    Location
    Ryde
    Posts
    118
    Thank Post
    4
    Thanked 3 Times in 3 Posts
    Rep Power
    12

    Unhappy 2008R2 sp1 killed our Wyse S10's RDP Connection

    None of our clients have been able to connect since applying the SP, so we're going to have to return to roll back, what we've found is that it wont let us turn off Network level authentication, if anyone can suggest a way to work around this then I would be very appreciative. We no longer have a support contract and I couldnt say what firmware they are on, but they did work with R2 previously with security set to negotiate on the server.

  2. #2

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,144
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    78
    Hi

    Have you downloaded the latest RDC Client to connect to the R2SP1 server?

    Regards
    Sukh

  3. #3

    Join Date
    Jul 2009
    Location
    Ryde
    Posts
    118
    Thank Post
    4
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    They are thin terminals, there is no downloadable client, desktop machines connect fine.

    we uninstalled the service pack, but they still cant connect. it's the only thing we have changed on that server in a very long time!

    if I change the wnos.ini answer file to point to a different terminal server (2003) that works okay...but thats a staff rd server, the weird thing is that this all worked prior to the sp.

    gah

  4. #4

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,144
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    78
    Hi

    Thin clients- What OS?
    How did you connect before?
    Can you check the R2 Server event logs and post the exact error message.
    Ensure no GPP is being applied controlling the setting.

    To configure Network Level Authentication for a connection
    On the RD Session Host server, open Remote Desktop Session Host Configuration. To open Remote Desktop Session Host Configuration, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click Remote Desktop Session Host Configuration.

    Under Connections, right-click the name of the connection, and then click Properties.

    On the General tab, select the Allow connections only from computers running Remote Desktop with Network Level Authentication check box.

    If the Allow connections only from computers running Remote Desktop with Network Level Authentication check box is selected and is not enabled, the Require user authentication for remote connections by using Network Level Authentication Group Policy setting has been enabled and has been applied to the RD Session Host server.

    Click OK.



    Regards
    Sukh
    Last edited by sukh; 3rd March 2011 at 03:00 PM.

  5. #5

    Join Date
    Jul 2009
    Location
    Ryde
    Posts
    118
    Thank Post
    4
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    WYSE S10 with WTOS 5.3.0.09

    machines pick up dhcp option to pick up WNOS.ini answer file from ftp server (this works)
    answer file tells them to run rdp connection to server 'studentRD; 172.16.45.103'
    this brings up an rdp connection on full screen normally, now we just get a short message saying "Connection "studentrd": connection failed.
    on the terminal event log I get loads of invalid statement:"random characters" after the 'Accessing system profile' event, may I reiterate that this event log is on the CLIENT

    the server doesnt really provide any information in the event log, before we removed the service pack it was showing some error messages specifically stating those machine names, but they seem to have disappeared now. i'm tempted to reinstall the service pack to see if they start showing up again

  6. #6

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,144
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    78
    Hi

    Have you tried to change the Network Level Authentication?

    Regards
    Sukh

  7. #7

    Join Date
    Jul 2009
    Location
    Ryde
    Posts
    118
    Thank Post
    4
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    re-read my original post,

    but to add

    security layer - negotiate
    Encryption Level - Client Compatible
    Cert - (Domain CA provided)
    Enforce NLA - greyed out due to Negotiate selected making it 'optional'

  8. #8

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,144
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    78
    Hi

    See Wyse S10 and WT1200LE with RDP/Win2k8

    Does this help you.

    Regards
    Sukh

  9. #9

    Join Date
    Jul 2009
    Location
    Ryde
    Posts
    118
    Thank Post
    4
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    does anyone know if there is a way to force disable NLA in 2008r2sp1, as I think that this would solve all of our issues.

    all the options under remote connections are greyed out and the options in TS dont seem to do anything either.

  10. #10

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,144
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    78
    Hi

    The option "Allow connections only from computers running Remote Desktop with Network Level Authentication".

    Is this ticked or not?

    Thanks
    Sukh

  11. #11
    alexsanger's Avatar
    Join Date
    Oct 2009
    Location
    London
    Posts
    117
    Thank Post
    21
    Thanked 23 Times in 21 Posts
    Rep Power
    15
    The RDP setting “Allow connections from all clients” worked for me when I had issues from XP clients to a 2008 SP1 box. Not using thin client though, so just a suggestion.

  12. #12

    Join Date
    Jul 2009
    Location
    Ryde
    Posts
    118
    Thank Post
    4
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Quote Originally Posted by sukh View Post
    Hi

    The option "Allow connections only from computers running Remote Desktop with Network Level Authentication".

    Is this ticked or not?




    Thanks
    Sukh
    please read my previous posts as I have already provided this information.

    Enforce NLA - greyed out due to Negotiate selected making it 'optional'

  13. #13

    Join Date
    Jul 2009
    Location
    Ryde
    Posts
    118
    Thank Post
    4
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Quote Originally Posted by alexsanger View Post
    The RDP setting “Allow connections from all clients” worked for me when I had issues from XP clients to a 2008 SP1 box. Not using thin client though, so just a suggestion.
    unfortunately this doesn't seem to be an option on R2 (that i can see)

  14. #14


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,706
    Thank Post
    354
    Thanked 807 Times in 722 Posts
    Rep Power
    348
    Quote Originally Posted by sacrej View Post
    unfortunately this doesn't seem to be an option on R2 (that i can see)
    It's there on my 2008r2 SP1 TS. Right click my computer, properties, remote settings, 3 options, pick the middle one (any version of remote desktop)

  15. #15

    Join Date
    Jul 2009
    Location
    Ryde
    Posts
    118
    Thank Post
    4
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Quote Originally Posted by kmount View Post
    It's there on my 2008r2 SP1 TS. Right click my computer, properties, remote settings, 3 options, pick the middle one (any version of remote desktop)
    Oh those options, yes I have those - however they are all grayed out with the bottom option selected (Enforce NLA)

    not sure how to 'un-gray' them :/

    I am logged in as a domain admin, local admin has the same issue.



SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 26th April 2010, 02:05 PM
  2. wyse VX0 connection refused
    By imiddleton25 in forum Thin Client and Virtual Machines
    Replies: 0
    Last Post: 26th March 2010, 06:08 PM
  3. Server 2008 R2 SP1 and RemoteFX bring full 3D over RDP
    By SYNACK in forum Windows Server 2008 R2
    Replies: 0
    Last Post: 19th March 2010, 01:27 PM
  4. Lenovo S10-2 dos drivers
    By ndavies in forum Netbooks, PDA and Phones
    Replies: 0
    Last Post: 4th December 2009, 06:26 PM
  5. Exchange 2007 sp1 just killed my exchange
    By everton4europe in forum Windows
    Replies: 3
    Last Post: 16th January 2008, 06:01 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •