+ Post New Thread
Results 1 to 11 of 11
Windows Server 2008 R2 Thread, My Docs Redirection... Have I missed something? in Technical; We've just rebuilt our fileserver (having upgrdaed it to 2008 R2), restored all of the documents and everything appeared to ...
  1. #1

    Join Date
    Apr 2007
    Location
    Croydon
    Posts
    493
    Thank Post
    18
    Thanked 30 Times in 29 Posts
    Rep Power
    20

    Question My Docs Redirection... Have I missed something?

    We've just rebuilt our fileserver (having upgrdaed it to 2008 R2), restored all of the documents and everything appeared to be working fine with my documents redirection... or so I thought.

    When a member of staff logs in they are able to access their my documents through Windows Explorer without any problems. When they go into an application (say Word or Excel) and click File->Open, they get accessed denied because Word is trying to access the root of the share, \\servername\staff instead of \\servername\staff\%username%

    Any ideas why?

    Server is 2008 R2 Std, Clients are XP SP3, Office 2003

  2. #2

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,582
    Thank Post
    107
    Thanked 761 Times in 592 Posts
    Rep Power
    180
    Chances are that the file permissions haven't copied properly. Make sure the users have sufficient rights to list the folder contents of \\server\share

  3. #3

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    2,502
    Thank Post
    134
    Thanked 493 Times in 441 Posts
    Rep Power
    140
    Remember that there are two settings that relate to My Documents, the Group Policy one and the Active Directory one. For example, I have the AD setting as \\server\directory\%username% and the GP setting as 'Redirect to the user's home directory'. You may encounter problems if using the GP setting 'Create a folder for each user under the root path'. When setting this GP up, make absolutely sure that under Settings, 'Grant the user exclusive rights to documents' is unticked!

  4. #4

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,707
    Thank Post
    829
    Thanked 2,571 Times in 2,188 Posts
    Blog Entries
    9
    Rep Power
    731
    Quote Originally Posted by 3s-gtech View Post
    When setting this GP up, make absolutely sure that under Settings, 'Grant the user exclusive rights to documents' is unticked!
    As far as I know this setting leaves it with everyone having full permission which is not great for file security. Are you running a script afterwards to lock down the permissions?

  5. #5

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    2,502
    Thank Post
    134
    Thanked 493 Times in 441 Posts
    Rep Power
    140
    Yeah, using a chown/cacls script afterwards.
    Last edited by 3s-gtech; 22nd February 2011 at 02:24 PM.

  6. #6

    Join Date
    Jun 2005
    Location
    London, UK
    Posts
    114
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    19
    If your permissions are set correctly on the root no scripts are required. The whole point of folder redirection is that the folders are correctly permissioned when created on first logon.

  7. #7

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    2,502
    Thank Post
    134
    Thanked 493 Times in 441 Posts
    Rep Power
    140
    I found that having this setting checked in GP meant that I couldn't access the home areas without grabbing ownership, meaning that tools like Treesize didn't work, and a load of unwanted files started turning up in home folders as I couldn't check.

  8. #8

    Join Date
    Apr 2007
    Location
    Croydon
    Posts
    493
    Thank Post
    18
    Thanked 30 Times in 29 Posts
    Rep Power
    20
    I don't think it's down to permissions..... I've set this up on a W2K8 R2 share and a W2K3 R2 share - W2K3 works, W2K8 does not:

    Share Permissions:

    Everyone: Full Control

    NTFS Permissions on root share:

    All Staff: Traverse folder, Create Folder

    In terms of group policy....

    Target Folder Location: Redirect to the user's home directory
    Settings: All 3 options are ticked

    Quote Originally Posted by 3s-gtech
    I found that having this setting checked in GP meant that I couldn't access the home areas without grabbing ownership, meaning that tools like Treesize didn't work, and a load of unwanted files started turning up in home folders as I couldn't check.
    It's not case of the user not being able to access their home folder, it works as expected in Windows Explorer, but not from the Open dialogs in Word, Excel etc...

  9. #9

    Join Date
    Jul 2006
    Location
    London
    Posts
    1,134
    Thank Post
    100
    Thanked 218 Times in 176 Posts
    Blog Entries
    1
    Rep Power
    69
    Try adding the NTFS permission "List Folder/Read Data"/"This Folder only" on the root of the shared folder.

    The Office2003 File dialogue is not the standard one built into windows, so it's behaviour can sometimes differ to that of Explorer's.

    If that doesn't work, add in order:
    Read Attributes
    Read Extended Attributes
    Read Permissions
    (This folder only)

    By the time you've done that you've basically assigned 'Read and Execute' (this folder only). I'm not sure if you have a good reason not to want this level of access to that folder?

    If you can live with it, great, if not you could then try itterating through removing a Read permission at a time until it stops working again.
    Last edited by psydii; 23rd February 2011 at 09:39 AM.

  10. Thanks to psydii from:

    adamf (24th February 2011)

  11. #10

    Join Date
    Apr 2007
    Location
    Croydon
    Posts
    493
    Thank Post
    18
    Thanked 30 Times in 29 Posts
    Rep Power
    20
    Quote Originally Posted by psydii View Post
    Try adding the NTFS permission "List Folder/Read Data"/"This Folder only" on the root of the shared folder.

    The Office2003 File dialogue is not the standard one built into windows, so it's behaviour can sometimes differ to that of Explorer's.

    If that doesn't work, add in order:
    Read Attributes
    Read Extended Attributes
    Read Permissions
    (This folder only)

    By the time you've done that you've basically assigned 'Read and Execute' (this folder only). I'm not sure if you have a good reason not to want this level of access to that folder?

    If you can live with it, great, if not you could then try itterating through removing a Read permission at a time until it stops working again.
    That fixed it! Although, why it worked on a W2K3 share without those permissions I do not know!

    Thanks

  12. #11

    Join Date
    Jul 2006
    Location
    London
    Posts
    1,134
    Thank Post
    100
    Thanked 218 Times in 176 Posts
    Blog Entries
    1
    Rep Power
    69
    Glad to hear it. :-)

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 29
    Last Post: 21st June 2012, 09:40 AM
  2. My Docs redirection
    By boogster in forum Windows Server 2008
    Replies: 9
    Last Post: 9th August 2010, 06:36 PM
  3. Why has the birthdaybot missed me and Brian?
    By CHR1S in forum General Chat
    Replies: 7
    Last Post: 8th February 2010, 02:07 PM
  4. An Update, cos I know you all missed me...
    By indiegirl in forum General Chat
    Replies: 2
    Last Post: 4th September 2006, 09:48 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •