+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 35
Windows Server 2008 R2 Thread, wds stops working on clients pxe-e32 tftp open timeout in Technical; Yeah, great fix pobably saved me spending half the day going through the Microsoft "help". Cheers mate!!...
  1. #16

    Join Date
    Oct 2006
    Posts
    5
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yeah, great fix pobably saved me spending half the day going through the Microsoft "help". Cheers mate!!

  2. #17

    Join Date
    Nov 2011
    Posts
    217
    Thank Post
    260
    Thanked 23 Times in 19 Posts
    Rep Power
    11
    This problem still seems to be happening as I just encountered it.

    There does seem to be a Microsoft Knowledge Base article on it now at least.

  3. #18


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,579
    Thank Post
    228
    Thanked 853 Times in 732 Posts
    Rep Power
    294
    I suspect its due to running wds on a dc but when you have 1 server tough

  4. #19

    Join Date
    Sep 2010
    Location
    wilson
    Posts
    20
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Arrived to work this morning and same problem. thanks for the fix

  5. #20

    Join Date
    Feb 2012
    Location
    London, North Yorkshire
    Posts
    75
    Thank Post
    4
    Thanked 10 Times in 10 Posts
    Rep Power
    7
    Just came and found this issue when I have 5 brand new ThinkCentre Edge PCs to build... THANK YOU!!!

  6. #21

    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Posts
    7
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    This thread may be nearly three years old but this just fixed a WDS on one of my sites. Thanks for the fix.

  7. #22
    Griff's Avatar
    Join Date
    Feb 2009
    Location
    Bedfordshire
    Posts
    514
    Thank Post
    199
    Thanked 95 Times in 77 Posts
    Rep Power
    38
    Good fix thanks, did not solve my problem immediately but if anyone else is still having the same problem after this fix check that your UDP Port Range in the Network Settings of WDS are set from 50000 to 65000 seems to have fixed the issue for me.

  8. Thanks to Griff from:

    hyb80 (26th July 2013)

  9. #23

    Join Date
    Oct 2011
    Posts
    10
    Thank Post
    6
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    awesome

    This saved my clonezill asetup thanks so much


    Quote Originally Posted by sted View Post
    incase this happens to anyone else (just happened to me after installing an update on the server and a couple of clients i rebuilt wouldnt boot as they just hung waiting for a tftp offer)

    has happened to me after a windows update on server 2008 r2 (aparantly happens on straight 2008 as well) basically its due to having dns server on the same machine as wds dns pinches the ports the tftp service needs. This can leed to pcs not booting at all just sitting there failing to tftp if their boot order has lan set higher than hdd.

    2008r2 fix

    run regedit

    go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\WDSServer\Parameters

    Right-click UdpPortPolicy, and then click Modify.
    In the Value data box, type 0, and then click OK.
    On the File menu, click Exit to exit Registry Editor.
    Restart the Windows Deployment Services service.

    2008 r1

    Click Start Collapse this imageExpand this image, click Administrative Tools, and then click Windows Deployment Services. If there is no server that is listed under the Servers node, right-click the Servers node, and then click Add Server to add the local computer.
    In the navigation pane of the Windows Deployment Services MMC snap-in, expand the list of servers.
    Right-click the server for Windows Deployment Services, and then click Properties.
    Under Network, increase the UDP Port range. For example, if the current port range is 3,000 ports, increase the port range to 4,000 ports

  10. #24

    Join Date
    Oct 2013
    Location
    United Kingdom
    Posts
    4
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    In case anyone else gets this error and they have tried both increasing the port range and tweaking the UDPportPolicy setting via the registry, I have found another possible cause and solution.

    In the past I have found that either "increasing the port range" or "tweaking the UDPportPolicy via the registry" sorts any problems that I have had with WDS and client computers displaying the PXE - tftp open timeout errors when attempting to download images. Naturally these were the first things I tried when I came to work today and found that other techs were reporting clients displaying the infamous open timeout error. Unlucky for me this didn't work.

    Solution

    1)Looking in the "Application and Services Log> Deployment-Services-Diagnostics" -on the WDS Server, I could see that the client was booting and talking to the WDS server successfully. IP on the clients PXE boot screen tallied with the IP logged on the WDS server with this event below;
    Event ID: 4096
    The Following Client PXE Booted:
    MAC: 00000000000000BLAHBLAH
    IP: 123.123.123.50

    I could see however that the server wasn't logging any of the following normal events to signify that the client managed to get the boot wim.
    Event ID's: 4099 or 4100
    The Following Client started the TFTP Download

    2) Looking in "Windows Logs> Application" I discovered this lovely error message, indicating trouble with UDP port 69 when setting up the TFTP endpoint.
    Event ID: 772
    An error occurred while trying to create the UDP endpoint for WDSTFTP provider on interface 123.123.456.26:69. This can happen if
    the network interface was disabled or changed, or some other application is already using the port. The provider
    will not be able to receive requests on this interface.

    Error Information: 0x2740

    3)Next, I dumped the info about ports running using; netstat -abn >> NewFile.txt
    Searching the output for port 69 I discovered that javaw.exe was the culprit.
    UDP 123.123.456.26:69 *:*
    [javaw.exe]

    As it turns out there had been an update for java a few days before this, after a restart javaw.exe decided it wanted to use port 69, which WDS requires for TFTP. Javaw.exe managed to nab the port before WDS got a chance, thus our lovely open timeout error.

    4) I killed the javaw.exe process

    5) Restarted the WDS service & boom, back in action, no more TFTP open timeout errors.


    OK, I hope this helps someone else.

  11. Thanks to andyire from:

    Menov321 (23rd October 2013)

  12. #25
    free780's Avatar
    Join Date
    Sep 2012
    Posts
    908
    Thank Post
    41
    Thanked 69 Times in 66 Posts
    Rep Power
    18
    How come your running wds on the same server as dns?

  13. #26


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,579
    Thank Post
    228
    Thanked 853 Times in 732 Posts
    Rep Power
    294
    Quote Originally Posted by free780 View Post
    How come your running wds on the same server as dns?
    in most cases i have 1 server so i cant not

  14. #27

    Join Date
    Jan 2014
    Location
    Sasebo, Japan
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hello everyone.
    I've been having this issue for quite some time now. I followed the instructions posted by OP by changing the UDP ports to reflect 50000-65000, with no joy.

    I attempted to follow the procedures in the comment below and found in the "netstat -abn" that only 1 process was using port 69. That is the 'svchost.exe' and it shows that WDS is using it.
    That doesn't help at all because 1) I'm assuming WDS is supposed to be using it and 2) even if I needed to kill it, there are about 15 'svchost.exe' currently running when I check Processes.


    Quote Originally Posted by andyire View Post
    In case anyone else gets this error and they have tried both increasing the port range and tweaking the UDPportPolicy setting via the registry, I have found another possible cause and solution.

    In the past I have found that either "increasing the port range" or "tweaking the UDPportPolicy via the registry" sorts any problems that I have had with WDS and client computers displaying the PXE - tftp open timeout errors when attempting to download images. Naturally these were the first things I tried when I came to work today and found that other techs were reporting clients displaying the infamous open timeout error. Unlucky for me this didn't work.

    Solution

    1)Looking in the "Application and Services Log> Deployment-Services-Diagnostics" -on the WDS Server, I could see that the client was booting and talking to the WDS server successfully. IP on the clients PXE boot screen tallied with the IP logged on the WDS server with this event below;
    Event ID: 4096
    The Following Client PXE Booted:
    MAC: 00000000000000BLAHBLAH
    IP: 123.123.123.50

    I could see however that the server wasn't logging any of the following normal events to signify that the client managed to get the boot wim.
    Event ID's: 4099 or 4100
    The Following Client started the TFTP Download

    2) Looking in "Windows Logs> Application" I discovered this lovely error message, indicating trouble with UDP port 69 when setting up the TFTP endpoint.
    Event ID: 772
    An error occurred while trying to create the UDP endpoint for WDSTFTP provider on interface 123.123.456.26:69. This can happen if
    the network interface was disabled or changed, or some other application is already using the port. The provider
    will not be able to receive requests on this interface.

    Error Information: 0x2740

    3)Next, I dumped the info about ports running using; netstat -abn >> NewFile.txt
    Searching the output for port 69 I discovered that javaw.exe was the culprit.
    UDP 123.123.456.26:69 *:*
    [javaw.exe]

    As it turns out there had been an update for java a few days before this, after a restart javaw.exe decided it wanted to use port 69, which WDS requires for TFTP. Javaw.exe managed to nab the port before WDS got a chance, thus our lovely open timeout error.

    4) I killed the javaw.exe process

    5) Restarted the WDS service & boom, back in action, no more TFTP open timeout errors.


    OK, I hope this helps someone else.
    If anyone has any other ideas I would greatly appreciate it.

  15. #28

    Join Date
    Nov 2011
    Posts
    217
    Thank Post
    260
    Thanked 23 Times in 19 Posts
    Rep Power
    11
    Quote Originally Posted by DaneDaughtrey View Post
    I attempted to follow the procedures in the comment below and found in the "netstat -abn" that only 1 process was using port 69. That is the 'svchost.exe' and it shows that WDS is using it.
    That doesn't help at all because 1) I'm assuming WDS is supposed to be using it and 2) even if I needed to kill it, there are about 15 'svchost.exe' currently running when I check Processes.
    If you add the -o switch to netstat (so netstat -abno) then it will also give you the process id of the svchost process that is using the port. You can then use something like process explorer to see what services are running in the svchost process with that id (services tab of the properties for the process in process explorer). There are likely to be several services in the process so it may not give you the culprit, but it might help.

  16. #29

    Join Date
    Dec 2011
    Location
    Australia
    Posts
    2
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    What version of Windows server are you running ?
    Have you tried:
    ================================================== =================================================
    2008r2 fix (Also applies to SBS2011)

    run regedit

    go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\WDSServer\Parameters

    Right-click UdpPortPolicy, and then click Modify.
    In the Value data box, type 0, and then click OK.
    On the File menu, click Exit to exit Registry Editor.
    Restart the Windows Deployment Services service.

    2008 r1

    Click Start Collapse this imageExpand this image, click Administrative Tools, and then click Windows Deployment Services. If there is no server that is listed under the Servers node, right-click the Servers node, and then click Add Server to add the local computer.
    In the navigation pane of the Windows Deployment Services MMC snap-in, expand the list of servers.
    Right-click the server for Windows Deployment Services, and then click Properties.
    Under Network, increase the UDP Port range. For example, if the current port range is 3,000 ports, increase the port range to 4,000 ports
    ================================================== ============================================
    Are you running SharePoint on this server ?
    If you are running SharePoint look for & fix any & all SharePoint related errors.

  17. #30

    Join Date
    Jan 2014
    Location
    Sasebo, Japan
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by james-aus View Post
    What version of Windows server are you running ?
    Have you tried:
    ================================================== =================================================
    2008r2 fix (Also applies to SBS2011)

    run regedit

    go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\WDSServer\Parameters

    Right-click UdpPortPolicy, and then click Modify.
    In the Value data box, type 0, and then click OK.
    On the File menu, click Exit to exit Registry Editor.
    Restart the Windows Deployment Services service.

    2008 r1

    Click Start Collapse this imageExpand this image, click Administrative Tools, and then click Windows Deployment Services. If there is no server that is listed under the Servers node, right-click the Servers node, and then click Add Server to add the local computer.
    In the navigation pane of the Windows Deployment Services MMC snap-in, expand the list of servers.
    Right-click the server for Windows Deployment Services, and then click Properties.
    Under Network, increase the UDP Port range. For example, if the current port range is 3,000 ports, increase the port range to 4,000 ports
    ================================================== ============================================
    Are you running SharePoint on this server ?
    If you are running SharePoint look for & fix any & all SharePoint related errors.
    This is was the first thing I tried after reading this thread with no joy.
    I'm running Server 2008 R1, and this IS NOT our Sharepoint server. It is, however, our WSUS server.

    If you add the -o switch to netstat (so netstat -abno) then it will also give you the process id of the svchost process that is using the port. You can then use something like process explorer to see what services are running in the svchost process with that id (services tab of the properties for the process in process explorer). There are likely to be several services in the process so it may not give you the culprit, but it might help.
    I will give this a shot and see if I can find the exact one. If I can find it should I go through the process of Stopping WDS service, killing the process, and restarting the WDS service?
    That sounds about right, I will post with an update soon.

SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Sonicwall & PXE/TFTP
    By bmittleider in forum Wireless Networks
    Replies: 7
    Last Post: 1st December 2010, 11:51 PM
  2. [Fog] PXE TFTP Timeout on Certain Machines
    By telnet in forum O/S Deployment
    Replies: 6
    Last Post: 25th June 2010, 10:53 AM
  3. [Fog] TFTP Open Timeout when imaging more than one client
    By TheElusiveOrangeButton in forum O/S Deployment
    Replies: 1
    Last Post: 24th May 2010, 03:20 PM
  4. (MDT), WDS and PXE TFTP not happening
    By PiqueABoo in forum Windows Server 2008
    Replies: 5
    Last Post: 14th November 2009, 03:17 PM
  5. Replies: 8
    Last Post: 8th June 2007, 09:32 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •