+ Post New Thread
Results 1 to 8 of 8
Windows Server 2008 R2 Thread, NTP and Hyper-V in Technical; Hi Folks, Spent far too long getting no where, tralling through sites to find an answer, but I think i've ...
  1. #1
    EJWill's Avatar
    Join Date
    May 2009
    Location
    Dunstable
    Posts
    55
    Thank Post
    4
    Thanked 36 Times in 13 Posts
    Rep Power
    17

    Angry NTP and Hyper-V

    Hi Folks,

    Spent far too long getting no where, tralling through sites to find an answer, but I think i've come to my wits end.

    We're trying to get our PDC to sync time with an external NTP server. The PDC is a VM hosted on a server running Hyper-V. By default Hyper-V will try to sync all guests with the hosts time. This has been disabled to allow us to setup the external NTP connection. This is what I used to configure our PDC:

    net stop w32time

    w32tm /config /update /manualpeerlist:"pool.ntp.org time.windows.com",0x1 /syncfromflags:manual /reliable:yes

    net start w32time

    This was deemed to be the correct way in configuring Windows Time Sync to use an external NTP server.

    However, when querying the peers used using w32tm /query /peers it appears to have ignored my configuration entirely and stuck with the old time.windows.com and worse still if I then try w32tm /query /status it says it's still trying to sync with the LOCAL CMOS!

    In the registry all entires are correct, it's taken my changes from earlier, but the Windows Time Service is running some kind of stubborn default that I can't work out why.

    Any help on the matter would be greatly appreciated.

  2. #2

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,707
    Thank Post
    829
    Thanked 2,571 Times in 2,188 Posts
    Blog Entries
    9
    Rep Power
    731
    Did you restart the VMs after removing the auto time sync setting from the Hyper-V manager properties page for each. I don't think it takes effect untill after a restart.

  3. #3
    sjl
    sjl is offline
    sjl's Avatar
    Join Date
    Apr 2009
    Location
    Liverpool
    Posts
    62
    Thank Post
    17
    Thanked 20 Times in 15 Posts
    Rep Power
    14
    I did the same 2 weeks ago only we use VMWARE. I followed the guide on Configuring the Windows Time Service and it worked fine first time.

  4. #4
    EJWill's Avatar
    Join Date
    May 2009
    Location
    Dunstable
    Posts
    55
    Thank Post
    4
    Thanked 36 Times in 13 Posts
    Rep Power
    17
    Good morrow to you two fine gentlemen,

    Unfortunatly yes, I had already restarted the VM's. I also tried permenantly disabling the Hyper-V Time Sync Service on the server to no avail.

    Also came across the guide you mentioned in my travels, and followed it closely, among many others that were all very similar. Still no go.

    Edit:

    It does appear that I have managed to at least get the peers to properly show up with w32tm /query /peers now, but the status still shows the time source and Local CMOS. At least one of the hurdles is out of the way. It ended up being group policy overiding the peers list.

    Just got to find out how to modify the source to NTP (or why it is ignoring the w32tm config).
    Last edited by EJWill; 29th September 2010 at 10:01 AM.

  5. #5
    EJWill's Avatar
    Join Date
    May 2009
    Location
    Dunstable
    Posts
    55
    Thank Post
    4
    Thanked 36 Times in 13 Posts
    Rep Power
    17
    Just a quick update.

    It would appear that the settings were being modified correctly, and was attempting to sync with the chosen peer. We noticed this when going through our ISA logs.

    However, even though a connection is made and data is sent too the NTP (probably a request), we get no response back. We have tried Windows, BBC and Pool NTP's with the same results each time. We're not blocking any responses from these servers. They all just seem reluctant to service our request.

  6. #6


    Join Date
    Feb 2007
    Location
    51.405546, -0.510212
    Posts
    8,142
    Thank Post
    204
    Thanked 2,398 Times in 1,774 Posts
    Rep Power
    705
    I'm not sure if the following will help, but I thought it might be worth posting?

    http://blogs.dirteam.com/blogs/sande...y-default.aspx

    The resolution to this problem is to make sure:

    • Disable Time Synchronization between the virtualization platform and any virtual Domain Controller in the Integration Components/VMware tools
    • Enable Domain Controllers in your Forest Root Domain to communicate with NTP servers on the Internet through your corporate firewall. (UDP 123)
    • Manually configure the Domain Controller holding the Domain Controller, holding the Primary Domain Controller emulator (PDCe) Flexible Single Master Operations (FSMO) role in the Forest Root Domain with a reliable external time source,
    • defining at least two different NTP servers by their Fully Qualified Domain Names (FQDNs)
      • defining at least two different NTP servers by their IP addresses (to make sure Time Synchronization continues to work when DNS fails)
      • A viable command line to configure the Domain Controller would be:

        w32tm /config /manualpeerlist:"europe.pool.ntp.org time.nist.gov 192.43.244.18 193.67.79.202" /syncfromflags:manual /reliable:yes /update
    Last edited by Arthur; 30th September 2010 at 11:17 PM.

  7. #7
    EJWill's Avatar
    Join Date
    May 2009
    Location
    Dunstable
    Posts
    55
    Thank Post
    4
    Thanked 36 Times in 13 Posts
    Rep Power
    17
    Just tried giving 2 FQDN's and 2 direct IP's.

    Our ISA logs tell us that a connection is being initiated, but no response from any of the servers. Doesn't look like a DNS problem.

    We go through the E2BN filters if that makes a difference, does anyone else use E2BN and able to connect to an external NTP?

  8. #8

    Join Date
    Jan 2009
    Location
    England
    Posts
    1,466
    Thank Post
    292
    Thanked 301 Times in 260 Posts
    Rep Power
    80
    Your RBC may prevent you from accessing external NTP servers. I know SEGfL does. They provide a NTP server that can be used instead.

SHARE:
+ Post New Thread

Similar Threads

  1. NTP Servers
    By Grommit in forum Hardware
    Replies: 10
    Last Post: 1st October 2010, 11:51 AM
  2. NTP to keep my Ruckus inline
    By SimpleSi in forum Windows
    Replies: 4
    Last Post: 9th September 2010, 04:27 PM
  3. NTP through isa 2004
    By ithelp in forum Internet Related/Filtering/Firewall
    Replies: 3
    Last Post: 21st May 2010, 01:19 PM
  4. Disk quotas - anyone using NTP QFS?
    By pantscat in forum How do you do....it?
    Replies: 8
    Last Post: 8th December 2009, 11:34 AM
  5. Ubuntu 7.10 NTP in parallels 5608
    By HodgeHi in forum *nix
    Replies: 4
    Last Post: 30th June 2008, 05:10 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •