+ Post New Thread
Results 1 to 8 of 8
Windows Server 2008 R2 Thread, Hyper-V "Failed to register service principal name." in Technical; I've joined a server to the domain and then installed Hyper-V role. I now get this error in the event ...
  1. #1
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,806
    Thank Post
    905
    Thanked 420 Times in 353 Posts
    Blog Entries
    12
    Rep Power
    87

    Hyper-V "Failed to register service principal name."

    I've joined a server to the domain and then installed Hyper-V role.

    I now get this error in the event log

    "Failed to register service principal name."
    EventID: 14050
    Source: Hyper-V-VMMS

    Has anyone else encountered this? Is it even a problem?

  2. #2
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,806
    Thank Post
    905
    Thanked 420 Times in 353 Posts
    Blog Entries
    12
    Rep Power
    87
    Installing the windows updates seemed to fix the problem.

  3. #3

    Join Date
    Feb 2011
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    It may be late for this Thread. Recently i faced same issue, tried all the Google search options.. no luck.
    When final installation of Hyper-V Role, the Gateway IP has been removed by default installation. So, i added back that IP and restarted the server. My server communication started.

  4. #4

    Join Date
    Feb 2011
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Funny, since I'm looking at the same issue today. Do you have one NIC or two? We have two, and the second one purposefully doesn't have a gateway (there's a warning when you try to enter one), so I wonder if that's the issue. If there's only one NIC, I can certainly see how that would be the problem--though you'd have more noticeable problems than this, I think.

  5. #5

    Join Date
    Feb 2011
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Answer1:
    I have 4 NICs. In this case you have to set priority on Network Adapters windows. Open Network and Sharing Center, Left side click Change Adapter Settings, hope you will your two NICs, When you on that window, press ALT key once, you will get Menu bar, go to Advanced Menu and Select Advanced Settings, on Adapters Binding tab, below connections; select & move internal communication NIC to top & ok.\

    Answer2:
    When you have two NICs, we will not use two gateways directly from Network adapter settings. If you are use NIC1 for internal access & NIC2 for external or something else; use "Route ADD" command at command prompt and add gateway and assign NIC2 gateway through Graphical window, your problem will be solved.

    If not solved your issue above, post me your senario details; hope i will have answer

  6. #6

    Join Date
    Feb 2011
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    My thought in having two NICs was for RDS: NIC1 handles the RDS traffic, while NIC2 handles backchannel communication between the RDS server and our domain server (transferring files that people open, etc). I'm just trying to distribute the load a bit, and the traffic accumulation on each (light for NIC1, heavy for NIC2) bears that out.

    There's only one subnet, so I don't think adding a route is appropriate, right? NIC1 has the gateway configured, NIC2 does not.

    I looked at the bindings and see that right now the internal-only virtual network I setup for HyperV is first (it didn't even exist initially--I just added it today), NIC2 is second, and NIC1 is last.

    Armed with that information, what do you suggest?

    Thanks

  7. #7

    Join Date
    Feb 2011
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    If your subnet is having same gateway for two NICs, remove gateway addresses from two nics and just add one command line "route add" to your gateway. this will resolve your issue. So, on graphical screen both the networks will not have gateways.
    Later, on application you do which NIC is using for what.... hope this also will help

  8. #8

    Join Date
    Feb 2011
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    It might very well have resolved it, but I was still unclear on the particulars. I found a workaround, however: set the Hyper-V Network Management Service on delayed automatic start (in the properties of the service). That allows enough time for the network to start before Hyper-V jumps in and tries to use it.

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] SQL migration "Login failed: Reason 0"
    By zag in forum MIS Systems
    Replies: 52
    Last Post: 16th January 2011, 03:15 PM
  2. Replies: 0
    Last Post: 23rd September 2009, 01:00 PM
  3. Epson printers "service required"
    By contink in forum Hardware
    Replies: 6
    Last Post: 9th April 2008, 09:59 AM
  4. Replies: 5
    Last Post: 15th March 2008, 12:37 AM
  5. Moodle causing "Service Unavailable" [FIXED]
    By fooby in forum Web Development
    Replies: 0
    Last Post: 19th January 2006, 12:15 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •