+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
Windows Server 2008 R2 Thread, Staff Share loses connection on laptops in Technical; Hey Guys Really hoping you can help me, I did call up county but that was a week ago and ...
  1. #1

    abillybob's Avatar
    Join Date
    May 2013
    Location
    Shropshire
    Posts
    1,277
    Thank Post
    106
    Thanked 162 Times in 111 Posts
    Rep Power
    107

    Staff Share loses connection on laptops

    Hey Guys

    Really hoping you can help me, I did call up county but that was a week ago and they still can't help me! Basically I have a file server which has the Staff's home drive, Pupil's home drive, Staff share and Pupil share on it. These are all mapped from my Domain Controller server using Group Policy. When teachers are using their laptops and the laptops go to sleep the laptops drop connection from the server for a few seconds and loose connection to all the mapped drives. Once the wifi reconnects itself they all reconnect again no problem. Except for the staff share which to enable to reconnect you must full restart your machine. I can't understand why this is really hoping you guys could shed some light on this as a lot of staff are getting annoyed about this!

    Thanks
    Alex

  2. #2
    DevilsAdvocate's Avatar
    Join Date
    May 2007
    Location
    West Midlands
    Posts
    384
    Thank Post
    19
    Thanked 39 Times in 30 Posts
    Rep Power
    22
    No idea how much difference this setting makes as I've always enabled it, but do you have the 'reconnect' setting checked on your staff share mapped drive?

    Capture.PNG

  3. #3

    abillybob's Avatar
    Join Date
    May 2013
    Location
    Shropshire
    Posts
    1,277
    Thank Post
    106
    Thanked 162 Times in 111 Posts
    Rep Power
    107
    Hi Mate

    Yeah I have checked that option and they all have it ticked. I have also checked the sharing properties and all drives have the same options ticked!! So strange :/

    Alex

  4. #4
    DevilsAdvocate's Avatar
    Join Date
    May 2007
    Location
    West Midlands
    Posts
    384
    Thank Post
    19
    Thanked 39 Times in 30 Posts
    Rep Power
    22
    Do you get any kind of error message when attempting to connect to the staff share drive after you wake the laptop from sleep?

  5. #5

    abillybob's Avatar
    Join Date
    May 2013
    Location
    Shropshire
    Posts
    1,277
    Thank Post
    106
    Thanked 162 Times in 111 Posts
    Rep Power
    107
    Yeah, it just says Could not connect to B: Drive. No reason behind it because if you go onto run and type \\filecloud\staffshare it will reconnect to it again!

  6. #6
    Joanne's Avatar
    Join Date
    Nov 2007
    Location
    Lancashire
    Posts
    1,122
    Thank Post
    49
    Thanked 53 Times in 50 Posts
    Blog Entries
    17
    Rep Power
    24
    I've found that sleeping machines cause all sorts of issues, so the power options are to turn off the display, but never sleep. Try applying that policy to the laptops, at least they will always retain their connection that way :-)

  7. #7

    Join Date
    Dec 2013
    Location
    North East
    Posts
    30
    Thank Post
    15
    Thanked 5 Times in 5 Posts
    Rep Power
    1
    I got around this by creating a small VB program that is installed on staff laptops, it checks if it can ping a domain server every 10 seconds, if it can and the drives are disconnected then it will re-map them. It seems pretty efficient, hardly touches the laptops resources but we are on new Macbooks here.

    Alternatively if Staff are allowed to run VBS files, you could just create a small script which maps the drives back in and tell them to run it if they ever lose connection.
    Last edited by jb2201; 9th December 2013 at 11:10 AM.

  8. #8
    GeekyPete's Avatar
    Join Date
    Mar 2013
    Location
    In a cold dark server room.
    Posts
    318
    Thank Post
    22
    Thanked 76 Times in 57 Posts
    Rep Power
    25
    Try mapping the same share to a drive other than B:\. B: was originally reserved for removable drives (a second floppy!, showing my age). It certainly used to behave differently to c: and above. If I am honest, I don't think I have used b:\ for over 15 years so they may have changed things since Windows 95. Anyway, it's very easy to test. Map the second drive letter to the same share, if one works and the other doesn't sorted. If not then you've only lost 10 minute of time...

  9. #9

    abillybob's Avatar
    Join Date
    May 2013
    Location
    Shropshire
    Posts
    1,277
    Thank Post
    106
    Thanked 162 Times in 111 Posts
    Rep Power
    107
    Hi mate how can I set this in a policy?? I don't want to have to go round to every laptop as we're a school of 300 of the things!!!
    Quote Originally Posted by Joanne View Post
    I've found that sleeping machines cause all sorts of issues, so the power options are to turn off the display, but never sleep. Try applying that policy to the laptops, at least they will always retain their connection that way :-)

  10. #10

    abillybob's Avatar
    Join Date
    May 2013
    Location
    Shropshire
    Posts
    1,277
    Thank Post
    106
    Thanked 162 Times in 111 Posts
    Rep Power
    107
    Thanks mate great idea although staff here can't run VBS files or scripts!
    Quote Originally Posted by jb2201 View Post
    I got around this by creating a small VB program that is installed on staff laptops, it checks if it can ping a domain server every 10 seconds, if it can and the drives are disconnected then it will re-map them. It seems pretty efficient, hardly touches the laptops resources but we are on new Macbooks here.

    Alternatively if Staff are allowed to run VBS files, you could just create a small script which maps the drives back in and tell them to run it if they ever lose connection.

  11. #11

    abillybob's Avatar
    Join Date
    May 2013
    Location
    Shropshire
    Posts
    1,277
    Thank Post
    106
    Thanked 162 Times in 111 Posts
    Rep Power
    107
    I've checked with Drive letter viewer and nothing is using B: though I will give it a go see if it makes a difference
    Quote Originally Posted by GeekyPete View Post
    Try mapping the same share to a drive other than B:\. B: was originally reserved for removable drives (a second floppy!, showing my age). It certainly used to behave differently to c: and above. If I am honest, I don't think I have used b:\ for over 15 years so they may have changed things since Windows 95. Anyway, it's very easy to test. Map the second drive letter to the same share, if one works and the other doesn't sorted. If not then you've only lost 10 minute of time...

  12. #12
    Duke5A's Avatar
    Join Date
    Jul 2010
    Posts
    731
    Thank Post
    74
    Thanked 113 Times in 99 Posts
    Blog Entries
    8
    Rep Power
    27
    Quote Originally Posted by alexbillbridgnorth View Post
    I've checked with Drive letter viewer and nothing is using B: though I will give it a go see if it makes a difference
    Doesn't matter if anything is on that drive letter or not. @GeekyPete nailed it with it being reserved for floppy drives. Back in the day you could use it as a ghost drive for copying between floppy disks in a single floppy drive system. It's probably something legacy related when the machine comes out of sleep.

  13. #13
    Joanne's Avatar
    Join Date
    Nov 2007
    Location
    Lancashire
    Posts
    1,122
    Thank Post
    49
    Thanked 53 Times in 50 Posts
    Blog Entries
    17
    Rep Power
    24
    Quote Originally Posted by alexbillbridgnorth View Post
    Hi mate how can I set this in a policy?? I don't want to have to go round to every laptop as we're a school of 300 of the things!!!
    It's User Configuration | Preferences | Control Panel Settings | Power Options (right click) > new > Power Plan

  14. Thanks to Joanne from:

    abillybob (10th December 2013)

  15. #14
    GeekyPete's Avatar
    Join Date
    Mar 2013
    Location
    In a cold dark server room.
    Posts
    318
    Thank Post
    22
    Thanked 76 Times in 57 Posts
    Rep Power
    25
    But after you try any other drive than b: right....

  16. #15

    abillybob's Avatar
    Join Date
    May 2013
    Location
    Shropshire
    Posts
    1,277
    Thank Post
    106
    Thanked 162 Times in 111 Posts
    Rep Power
    107
    Hmm restarted the file server last night and don't seem to have had anyone come chase me down! Thanks for all your help though! I have had things that use the letter B: before now and I've never had an issue. Saying that I will change the drive letter if anything goes wrong and see what happens cheers guys

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 3
    Last Post: 9th June 2010, 11:02 AM
  2. Wireless laptops lose connection to 08 server
    By IT_Monkeh in forum Windows Server 2008
    Replies: 6
    Last Post: 5th May 2010, 09:48 AM
  3. Replies: 23
    Last Post: 11th March 2010, 03:59 PM
  4. Replies: 8
    Last Post: 9th November 2007, 01:33 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •