+ Post New Thread
Results 1 to 3 of 3
Windows Server 2008 R2 Thread, IE group policy not working for some users in same groups? in Technical; I'm really baffled by this. I have a staff user who doesn't get her proxy set with our STAFF GPO ...
  1. #1
    reggiep's Avatar
    Join Date
    Apr 2008
    Location
    In the vast area of space and time
    Posts
    1,550
    Thank Post
    518
    Thanked 56 Times in 50 Posts
    Rep Power
    30

    IE group policy not working for some users in same groups?

    I'm really baffled by this. I have a staff user who doesn't get her proxy set with our STAFF GPO no matter where they log in. So I thought I'd just create a new user to see if it happens for them too, and sure enough this new user doesn't get it set either.
    I created a new enforced policy to just set that but it fails too for both these users.
    I have used group policy modelling which tells me that the proxy does get set by these policies!
    I have other staff users who are completely fine and do get the proxy set?

    Can anyone suggest where I should be poking now to see what's going on?

    Thanks

  2. #2
    reggiep's Avatar
    Join Date
    Apr 2008
    Location
    In the vast area of space and time
    Posts
    1,550
    Thank Post
    518
    Thanked 56 Times in 50 Posts
    Rep Power
    30
    As a quick fix, for now, does anyone know how to set the proxy and exceptions with a script.

    I found this...

    <job>
    <script language="VBScript">
    Option Explicit
    Dim valUserIn
    Dim objShell, RegLocate, RegLocate1
    Set objShell = WScript.CreateObject("WScript.Shell")
    On Error Resume Next
    valUserIn = Inputbox("Enter the Proxy server you want to use.","Proxy Server Required")
    RegLocate = "HKEY_CURRENT_USER\Software\Microsoft\Windows\Curr entVersion\Internet Settings\ProxyServer"
    objShell.RegWrite RegLocate,valUserIn,"REG_SZ"
    RegLocate = "HKEY_CURRENT_USER\Software\Microsoft\Windows\Curr entVersion\Internet Settings\ProxyEnable"
    objShell.RegWrite RegLocate,"1","REG_DWORD"
    MsgBox "Proxy is Enabled"
    WScript.Quit
    </script>
    </job>
    Which sets the proxy via a prompt, I'm going to hack at it to just set it, but not sure how I can do exceptions as well.

  3. #3
    reggiep's Avatar
    Join Date
    Apr 2008
    Location
    In the vast area of space and time
    Posts
    1,550
    Thank Post
    518
    Thanked 56 Times in 50 Posts
    Rep Power
    30
    I ended up with this for the script until I can work out what is going on...
    <job>
    <script language="VBScript">
    Option Explicit
    Dim valUserIn
    Dim objShell, RegLocate, RegLocate1, RegLocate2
    Set objShell = WScript.CreateObject("WScript.Shell")
    On Error Resume Next

    RegLocate = "HKEY_CURRENT_USER\Software\Microsoft\Windows\Curr entVersion\Internet Settings\ProxyServer"
    objShell.RegWrite RegLocate,"13.24.4.122:3128","REG_SZ"

    RegLocate = "HKEY_CURRENT_USER\Software\Microsoft\Windows\Curr entVersion\Internet Settings\ProxyEnable"
    objShell.RegWrite RegLocate,"1","REG_DWORD"

    RegLocate = "HKEY_CURRENT_USER\Software\Microsoft\Windows\Curr entVersion\Internet Settings\ProxyOverRide"
    objShell.RegWrite RegLocate,"*.prenton.internal;10.*","REG_SZ"

    MsgBox "Proxy is Enabled"
    WScript.Quit
    </script>
    </job>

  4. Thanks to reggiep from:

    xenonive (24th September 2013)

SHARE:
+ Post New Thread

Similar Threads

  1. Active Inspire not working for one user on Mac
    By jackvine in forum Promethean Direct Support
    Replies: 6
    Last Post: 24th March 2011, 01:03 PM
  2. Logon message using group policy not working
    By Kaustubh in forum Windows Server 2000/2003
    Replies: 4
    Last Post: 1st March 2011, 07:53 PM
  3. Wireless Will Not Work for Some Pupils
    By TurnItOffAndOn in forum Wireless Networks
    Replies: 1
    Last Post: 7th February 2011, 12:10 PM
  4. Internet Explorer Settings Via Group Policy: Not Working
    By DaveP in forum How do you do....it?
    Replies: 16
    Last Post: 30th April 2010, 10:32 AM
  5. OWA Not Working For New Users
    By FN-GM in forum Windows
    Replies: 8
    Last Post: 22nd January 2008, 05:57 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •