+ Post New Thread
Results 1 to 13 of 13
Windows Server 2008 R2 Thread, No write permission to c:\! in Technical; Please can anyone help me get to the bottom of this. I have spent ages trying to sort it. I ...
  1. #1
    Sir
    Sir is offline

    Join Date
    Feb 2009
    Location
    The Space Bar
    Posts
    66
    Thank Post
    81
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    No write permission to c:\!

    Please can anyone help me get to the bottom of this. I have spent ages trying to sort it. I have create a user as i have done 1000's of times before in AD. She has the same group membership as others that have write access to c:\ on win 7 machines. On her logon and hers alone on a variety of machines tested on the network, she cannot use a financial mngmt package as she has no full control of c:\. Others with the same properties in AD have no problem! AAAAAh. Any suggestions please?

  2. #2
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    426
    Thank Post
    74
    Thanked 43 Times in 39 Posts
    Rep Power
    19
    Is deleting and recreating the user account an option? Also - double check security group membership, I've been caught out by that in the past.

  3. Thanks to FishCustard from:

    Sir (23rd July 2013)

  4. #3

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,271
    Thank Post
    884
    Thanked 2,749 Times in 2,322 Posts
    Blog Entries
    11
    Rep Power
    785
    Is her client machine Windows Vista or a above, current windows is way less tolerant of incompetent software design and will block calls to some places. Your best option may be to give her local admin rights and configure the shortcut to run as administrator in compatibility settings. Also make sure UAC is on so it can apply security properly for the software at runtime.

    Next step is to upgrade your software to something reasonable if possible.

  5. Thanks to SYNACK from:

    Sir (23rd July 2013)

  6. #4
    Sir
    Sir is offline

    Join Date
    Feb 2009
    Location
    The Space Bar
    Posts
    66
    Thank Post
    81
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for this, both of you. I was booted out of school at 4 so will try in the morning. the software if a financial mngnt package from Capita (run with SIMS) an is up to date. Sims permissions all checked, too!

  7. #5
    Sir
    Sir is offline

    Join Date
    Feb 2009
    Location
    The Space Bar
    Posts
    66
    Thank Post
    81
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Capita support insist it is a writing to c:\ permissions problem. I just wonder why it is this user only......

  8. #6

    Join Date
    Oct 2005
    Location
    mnah mnah!
    Posts
    1,127
    Thank Post
    275
    Thanked 227 Times in 173 Posts
    Rep Power
    113
    Quote Originally Posted by Sir View Post
    Capita support insist it is a writing to c:\ permissions problem. I just wonder why it is this user only......
    I would ask them two things at this point
    1) can they show you where this permissions error is occurring (I suspect this is someone just reading from a script that says "this error = permissions issue" and possibly ignoring your point about other users with the same rights working.

    2) when are they going to fix their faulty software. "Modern" windows application software simply shouldn't be writing to the root of the c:\ drive during use.

  9. #7
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    426
    Thank Post
    74
    Thanked 43 Times in 39 Posts
    Rep Power
    19
    Quote Originally Posted by Roberto View Post
    2) when are they going to fix their faulty software. "Modern" windows application software simply shouldn't be writing to the root of the c:\ drive during use.
    Capita finance package = SIMS FMS, right? So that's 'modern software' out of the equation... :P

    Can you screenshot the error she's getting? It may well be to do with the ODBC connection to the database, rather than file read/write permissions.
    Last edited by FishCustard; 24th July 2013 at 01:24 AM.

  10. #8


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,810
    Thank Post
    262
    Thanked 2,969 Times in 2,183 Posts
    Rep Power
    847
    Quote Originally Posted by Sir View Post
    Capita support insist it is a writing to c:\ permissions problem.
    With UAC on, shouldn't the data be written to the "%UserProfile%\AppData\Local\VirtualStore" folder instead? The software will still think it's saving to the root of C:\, but the data will be automatically saved to your user profile.

  11. #9

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,271
    Thank Post
    884
    Thanked 2,749 Times in 2,322 Posts
    Blog Entries
    11
    Rep Power
    785
    Quote Originally Posted by Arthur View Post
    With UAC on, shouldn't the data be written to the "%UserProfile%\AppData\Local\VirtualStore" folder instead? The software will still think it's saving to the root of C:\, but the data will be automatically saved to your user profile.
    That is the idea but is does not always work, usually when software accesses stuff in odd ways rather than through the proper apis so that they can't be redirected easily on the fly. Think Windows 3.1 design principals where the local sheriff did his best against the nefarious league of software bandits that has persisted to this day and maybe even got worse.

  12. #10
    Sam_Brown's Avatar
    Join Date
    Sep 2009
    Location
    Northampton
    Posts
    610
    Thank Post
    102
    Thanked 42 Times in 40 Posts
    Rep Power
    19
    Not used FMS for years but does it still insist on that f***ing stupid PDOXUSRS.net file being on the route of the C:\ drive? We used to have issues with this that sounds similar to the ones you're having that could be resolved by moving the file from the route of C:\ to a folder and configuring FMS to look for the file somewhere else.

  13. #11
    round2it's Avatar
    Join Date
    May 2009
    Location
    UK
    Posts
    1,084
    Thank Post
    255
    Thanked 161 Times in 116 Posts
    Rep Power
    41
    Quote Originally Posted by Sam_Brown View Post
    Not used FMS for years but does it still insist on that f***ing stupid PDOXUSRS.net file being on the route of the C:\ drive? We used to have issues with this that sounds similar to the ones you're having that could be resolved by moving the file from the route of C:\ to a folder and configuring FMS to look for the file somewhere else.
    Yes definitely that file caused me no end of trouble.

  14. #12
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    426
    Thank Post
    74
    Thanked 43 Times in 39 Posts
    Rep Power
    19
    Yep, I can confirm that FMS still requires the <bleep> <bleep>ing PDOXUSRS.net being at the root of C:\

  15. #13
    Sir
    Sir is offline

    Join Date
    Feb 2009
    Location
    The Space Bar
    Posts
    66
    Thank Post
    81
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thank you all. Just got back..... Yes to all the above; what a program. Granted user local admin rights.grrrrrrrrrrrrr



SHARE:
+ Post New Thread

Similar Threads

  1. Is it possible to give a teacher permission to SynchronEyes 6.1 Preferences
    By dfc in forum Network and Classroom Management
    Replies: 1
    Last Post: 24th October 2009, 11:37 PM
  2. Replies: 3
    Last Post: 2nd April 2009, 01:00 AM
  3. Permission to install SIMS please
    By andy in forum MIS Systems
    Replies: 13
    Last Post: 18th July 2008, 11:54 AM
  4. Replies: 19
    Last Post: 30th April 2008, 01:32 AM
  5. Home paths in server 2k3 + full permissions to user
    By Oops_my_bad in forum Windows
    Replies: 7
    Last Post: 21st June 2007, 12:07 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •