+ Post New Thread
Results 1 to 7 of 7
Windows Server 2008 R2 Thread, Mass creating users...almost there! in Technical; So I need to create users for all the students in the school. I've used Active User Manager to make ...
  1. #1

    Join Date
    Feb 2012
    Location
    Birmingham
    Posts
    48
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Mass creating users...almost there!

    So I need to create users for all the students in the school. I've used Active User Manager to make the users with a .csv file, they've all got a shared folder (\\server\username$) which is set in Active Directory to map to their Z drives, permissions are all set. All I need to do is to set a policy to redirect their My Documents to their folder. Redirecting it to "\\server\%username%$" doesn't work, how do I do this?

    I've only made 1 year group so far for testing purposes, and I pretty much manually created every folder so if there's an easier way to do this, then I don't mind starting from scratch. I know you can set a home folder with active user manager, but is that My Documents or what? I'd rather stick with group policy but any suggestions would be great!

    Thanks for any replies.
    Last edited by Kineas; 11th July 2013 at 04:51 PM.

  2. #2
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    420
    Thank Post
    72
    Thanked 40 Times in 36 Posts
    Rep Power
    17
    Use the 'Redirect to the user's home directory' option (assuming you're doing this via GPP - if not you can use the %homeshare% environment variable).

  3. Thanks to FishCustard from:

    Kineas (12th July 2013)

  4. #3

    Join Date
    May 2011
    Location
    Jus North of London, close but not too close
    Posts
    717
    Thank Post
    170
    Thanked 53 Times in 51 Posts
    Rep Power
    34
    Redirection is pretty different and as you say is done through GPO unfortunately the GPO's don't seem to be very happy with normal wildcards i.e. %username%

    A lot of people go down the route of sharing the root folder not the individual folders as this seems to work well on Vanilla Windows networks better the idea of sharing the individuals folder is similar to the way RM works

    Sorry to be not much of help, please post if you manage to do this.

  5. #4
    soveryapt's Avatar
    Join Date
    Jan 2009
    Location
    Lancashire
    Posts
    2,401
    Thank Post
    648
    Thanked 277 Times in 244 Posts
    Rep Power
    78
    In the GPO for the students, you need to add in the root share for the users, and the GPO will do the rest.

    So Users > Policies > Windows Settings > Folder Redirection then right click on Documents and set that to being the root of where they are stored.

    The best thing to do is actually have a shared folder on your system that includes all the users, or to have individual folders for staff, students etc. Then in the GPO I've mentioned above, you can set it to being \\server1\students and it will fill in the %username% bit for you (it should show you what the end product will turn out like on the Folder Rediction settings screen.

    Under pictures / movies etc, make sure you have it set to Follow Documents unless you have a particular drive you want to redirect such things to, else it will just confuse everything.

  6. #5

    Join Date
    Feb 2012
    Location
    Birmingham
    Posts
    48
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for the replies, but I've sorted it. The home folder is set as the users home directory in AD, and I missed the option in group policy that allows you to redirect My Documents to the users home folder. Did that and it works great

  7. #6


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,506
    Thank Post
    227
    Thanked 848 Times in 727 Posts
    Rep Power
    287
    Quote Originally Posted by Kineas View Post
    Thanks for the replies, but I've sorted it. The home folder is set as the users home directory in AD, and I missed the option in group policy that allows you to redirect My Documents to the users home folder. Did that and it works great
    but not ideal as your user share will end up filled with "my documents"

  8. #7
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    420
    Thank Post
    72
    Thanked 40 Times in 36 Posts
    Rep Power
    17
    Quote Originally Posted by sted View Post
    but not ideal as your user share will end up filled with "my documents"
    Which you can solve using FSRM - use an Audit policy to deny Administrators read access to the desktop.ini files and the folders will have the right names.

    Or, redirect to \\server\share\%username%\Documents. That way the %username% folder won't be affected.

SHARE:
+ Post New Thread

Similar Threads

  1. Create User DSN has failed
    By button_ripple in forum MIS Systems
    Replies: 4
    Last Post: 30th January 2013, 02:58 PM
  2. Cannot create users in Active Directory
    By WithoutMotive in forum Windows
    Replies: 17
    Last Post: 6th February 2009, 11:20 AM
  3. Replies: 1
    Last Post: 6th October 2008, 10:13 AM
  4. Replies: 4
    Last Post: 27th September 2006, 02:31 PM
  5. Replies: 4
    Last Post: 12th July 2006, 09:59 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •