Hi all, i've set up a 2008 R2 server at work with Remote Desktop Services on and have rolled out thin clients to one of our offices who can connect up fine and dandy and work as I'd like them to, they can even plug in USB pens and they are picked up fine in their session.

However i've just come to setting up some new systems with Windows ThinPC instead of buying thin clients and i've got the machine all set up so that it boots straight to the RDP connection window, but for some reason I can't get it to redirect the USB drive that is plugged in on the local machine. Ive tried it both before i've been logged on and whilst logged on and it won't show up for me and I can't figure out why!

I've checked the local resources in the RDP connection file and ive got the boxes ticked for 'drives that I plug in later' and also 'other supported plug and play devices' but this has not worked. I've also explicitly ticked the USB drive when I have it plugged in prior to connection to the server but this still does not work. Anyone any ideas? I can't understand why it works fine on the Wyse thin clients but not on these Windows ThinPC machines. Could it be a group policy i've set? I've had a brief look but can't put my finger on anything?!