+ Post New Thread
Results 1 to 3 of 3
Windows Server 2000/2003 Thread, IIS 6 won't start webpage in Technical; Getting error starting an ASP page: ADODB.Connection error '800a0e7a' Provider cannot be found. It may not be properly installed. /dinners/index.asp, ...
  1. #1

    Join Date
    Jul 2007
    Posts
    16
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    IIS 6 won't start webpage

    Getting error starting an ASP page:

    ADODB.Connection error '800a0e7a'

    Provider cannot be found. It may not be properly installed.

    /dinners/index.asp, line 44
    Line referred to is:
    objconn.open session("strconn")

    Following lines (if this helps!)are:
    set objRS = server.createobject("ADODB.recordset")
    set objRS.activeconnection = objConn

    This has been moved from a 32bit Windows 2003 server to a 64bit one. All the suggestions I've found anywhere don't seem to work (Some turned out to be for IIS 7).

    ANY suggestions appreciated as I'm no expert on IIS and ASP (rather a novice in fact!!)

  2. #2

    Join Date
    Apr 2006
    Posts
    387
    Thank Post
    23
    Thanked 95 Times in 61 Posts
    Rep Power
    44
    Your ASP page is trying to connect to a data source, but either there's a problem with the connection library it's trying to use, or it's not installed on the new server.

    Do you know what the connection string is? This will tell you what provider it's trying to use.

  3. Thanks to theriver from:

    mac_shinobi (10th July 2012)

  4. #3

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,680
    Thank Post
    3,210
    Thanked 1,030 Times in 955 Posts
    Rep Power
    361
    Quote Originally Posted by theriver View Post
    Your ASP page is trying to connect to a data source, but either there's a problem with the connection library it's trying to use, or it's not installed on the new server.

    Do you know what the connection string is? This will tell you what provider it's trying to use.
    We could do with seeing more of the code from the ASP page as per above in relation to the connection string, also what data source or database is it that you are using ie access 2003, access 2007, 2010, SQL, MySQL or what exactly ??

    So Server 2003 64 bit and what version of IIS ? IIS 6 or 7 ?

    I did find the below but not sure if you have already come across this in your googling / searching

    http://stackoverflow.com/questions/3590546/adodb-connection-error-800a0e7a

    In regards to connection string -->

    http://tutorials.aspfaq.com/8000xxxx...7a-errors.html
    Last edited by mac_shinobi; 10th July 2012 at 10:20 PM.

SHARE:
+ Post New Thread

Similar Threads

  1. Web Server 2008 services won't start
    By OverWorked in forum Windows Server 2008
    Replies: 5
    Last Post: 19th September 2011, 03:36 PM
  2. DNS won't start until all servers running?
    By Cache in forum Windows Server 2000/2003
    Replies: 8
    Last Post: 31st August 2010, 01:25 PM
  3. ISA 2004 - MS Firewall Won't Start with https rules
    By Killer_Bot in forum Windows Server 2000/2003
    Replies: 2
    Last Post: 7th December 2009, 05:51 PM
  4. Spiceworks won't start when running on Vista Business
    By Number6 in forum Network and Classroom Management
    Replies: 6
    Last Post: 15th March 2009, 11:31 PM
  5. Power mac G3 won't start
    By dezt in forum Mac
    Replies: 5
    Last Post: 10th January 2007, 04:15 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •