+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21
Windows Server 2000/2003 Thread, WSUS not working on some pcs in Technical; Hi Please use PsGetSid and download PSGetSid. Just run the command and note down the computer SID. The run sysprep ...
  1. #16

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,144
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    77
    Hi

    Please use PsGetSid and download PSGetSid. Just run the command and note down the computer SID.

    The run sysprep and select (OOBE) with the generalise option. After a reboot, you may have to enter some configs again suvch as keyboard layout etc..

    After the reboot, run PSGetSid again and confirm you have a different Computer SID. Once confirmed, then go back to previous step and run the script, then run wuauclt /detectnow.

    Thanks
    Sukh

  2. #17

    Join Date
    Apr 2010
    Posts
    2,038
    Thank Post
    83
    Thanked 187 Times in 154 Posts
    Rep Power
    83
    Sukh, thanks for all your time and help. All working on the W7 test box. Just need to do the same on other machines around the school. One odd thing to note, after doing the sysprep and running the script both the old & new computer name got listed in WSUS.

    Thanks again.

  3. #18

    Join Date
    Dec 2008
    Location
    Essex
    Posts
    2,144
    Thank Post
    1
    Thanked 326 Times in 316 Posts
    Rep Power
    77
    Hi

    No Problem.

    Regards
    Sukh

  4. #19
    quietriot1983's Avatar
    Join Date
    Dec 2010
    Location
    Manchester
    Posts
    105
    Thank Post
    15
    Thanked 6 Times in 6 Posts
    Rep Power
    9
    I'm not fully convinced by the SID/sysprep argument. I had problems with WSUS, the desktop machines I had cloned didn't show up until I changed their SIDs, but I also had a set of 30 netbooks, again, cloned, that all showed themselves in the WSUS list first time, no problems.

  5. #20

    Join Date
    Apr 2010
    Posts
    2,038
    Thank Post
    83
    Thanked 187 Times in 154 Posts
    Rep Power
    83
    I agree but the sysprep does fix it. I have some computers from the same image showing and some not.

  6. #21

    Join Date
    Mar 2011
    Location
    Northants
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi not sure if you still have issue - however I would try running this batchfile on a client machine with the wsus issue - as I feel problem could be related to the machines susclientid.

    rem Fixes problem with client machines not showing up on the server due to imaging method

    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Win dowsUpdate /v AccountDomainSid /f
    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Win dowsUpdate /v PingID /f
    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Win dowsUpdate /v SusClientId /f
    cls
    @echo Triggering detection after resetting WSUS client identity
    net stop wuauserv
    net start wuauserv
    wuauclt /resetauthorization /detectnow

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. WSUS stopped working
    By Clockworks in forum Windows
    Replies: 9
    Last Post: 27th August 2010, 09:58 PM
  2. WSUS not picking up PCs
    By MK-2 in forum Windows
    Replies: 16
    Last Post: 22nd April 2010, 03:54 PM
  3. PCs not seeing WSUS updates
    By Number6 in forum Windows
    Replies: 24
    Last Post: 19th April 2010, 12:24 PM
  4. WSUS not working - help please
    By leco in forum Windows Server 2000/2003
    Replies: 7
    Last Post: 29th January 2010, 08:31 PM
  5. WSUS Not Working on Some Stone Machines
    By garethedmondson in forum Windows
    Replies: 10
    Last Post: 12th May 2009, 12:53 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •