+ Post New Thread
Results 1 to 11 of 11
Windows Server 2000/2003 Thread, Problems with email relay in Technical; Hi, i am experiencing a strange problem. at work we relay mail for approx. 200 schools. one or two in ...
  1. #1

    Join Date
    Mar 2010
    Location
    UK
    Posts
    43
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Problems with email relay

    Hi,

    i am experiencing a strange problem. at work we relay mail for approx. 200 schools. one or two in particular are either recieving mail that has been delayed for long periods or they're not receiving it at all.

    i have a back log of email queued under "C:\Inetpub\mailroot\Queue". there is no reason that i can see from this end, no trend as such. this tends to be happening to all mail. i have done the following:

    restarted the smtp service
    restarted the IIS service
    removed all mail from the Queue folder, and put it back to hope that it would restart the send process.
    checked the Delivery tab under IIS manager, which i have extended hops to 200 and reduced the resend time to 1, 2, 4 minutes.
    we can telnet to the mailgate fine
    check event logs - nothing that points to the problem
    checked the smtp log, of which i have copied an affected schools log below:

    13:59:14 [mailgate ip address] - - 0
    13:59:14 [mailgate ip address]EHLO - 0
    13:59:14 [mailgate ip address] - - 0
    13:59:14 [mailgate ip address] EHLO - 0
    13:59:14 [mailgate ip address] - - 0
    13:59:14 [mailgate ip address] MAIL - 0
    13:59:14 [mailgate ip address] - - 0
    13:59:14 [mailgate ip address] MAIL - 0
    13:59:14 [mailgate ip address] - - 0
    13:59:14 [mailgate ip address] RCPT - 0
    13:59:14 [mailgate ip address] - - 0
    13:59:14 [mailgate ip address] RCPT - 0
    13:59:14 [mailgate ip address] - - 0
    13:59:14[mailgate ip address] BDAT - 0
    13:59:14 [mailgate ip address] - - 0
    13:59:14 [mailgate ip address] BDAT - 0

    can anyone suggest a reason that may be causing this?

    simply telling the client that it is a problem at his end is not good enough for him.

    any suggestions welcomed!!!!

    thanks!

  2. #2
    jamesreedersmith's Avatar
    Join Date
    Sep 2009
    Location
    Ruskington
    Posts
    1,170
    Thank Post
    78
    Thanked 259 Times in 231 Posts
    Rep Power
    78
    Looks like its not handshaking correctly - is there a full stable root between both boxes?

  3. #3
    pooley's Avatar
    Join Date
    Sep 2005
    Location
    S Wales
    Posts
    1,156
    Thank Post
    81
    Thanked 124 Times in 105 Posts
    Rep Power
    68
    Are the schools getting any specifit NDR's? the mail thats getting stuck, is it external, internal?

  4. #4

    Join Date
    Mar 2010
    Location
    UK
    Posts
    43
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    i can only assume that there is a full stable root between boxes as i can telnet to the mailgate and no problems arrise from this.

    Both ANY email that is relayed to that domain is getting stuck.

    struggling.........

  5. #5
    pooley's Avatar
    Join Date
    Sep 2005
    Location
    S Wales
    Posts
    1,156
    Thank Post
    81
    Thanked 124 Times in 105 Posts
    Rep Power
    68
    Try using smtpdiag from client end, see where it falls over?

  6. #6

    Join Date
    Mar 2010
    Location
    UK
    Posts
    43
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    hi, i just tried that and i got green across the board. no problems apparenltly.

    SOA serial number match: Passed

    Both TCP and UDP queries succeeded. Local DNS test passed.

    Both TCP and UDP queries succeeded. Remote DNS test passed.

    Successfully connected to mailgate.remote.domain.name

    thanks for the suggestions.........still at a loss

  7. #7

    Join Date
    Mar 2010
    Location
    UK
    Posts
    43
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    BTW, email outbound from the school is not a problem.

  8. #8
    pooley's Avatar
    Join Date
    Sep 2005
    Location
    S Wales
    Posts
    1,156
    Thank Post
    81
    Thanked 124 Times in 105 Posts
    Rep Power
    68
    So ok, on the reversal then can you use smtpdiag to send the school an email, see if there is a routing error?

  9. #9

    Join Date
    Mar 2010
    Location
    UK
    Posts
    43
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    i cant see how this is achieved - would the server need to have exchange installed? - as it doesnt.

    the fact that i can telnet to the mailgate of the school surely is proof enough that there is no rooting errors?!

  10. #10

    Join Date
    Mar 2010
    Location
    UK
    Posts
    43
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    all, following a test from my hotmail account i am now getting a undeliverable stating:

    This is an automatically generated Delivery Status Notification. Delivery to the following recipients failed. user@domain.name

    any ideas at all?????

  11. #11

    Join Date
    Mar 2010
    Location
    UK
    Posts
    43
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    hi all,

    new week, same problems!!

    still getting the following from the smtp log:

    00:10:34 Destination ip address - - 0
    00:10:34 ip address EHLO - 0
    00:10:34 ip address - - 0
    00:10:34 ip address EHLO - 0
    00:10:34 ip address - - 0
    00:10:34 ip address EHLO - 0
    00:10:34 ip address - - 0
    00:10:34 ip address MAIL - 0
    00:10:34 ip address - - 0
    00:10:34 ip address MAIL - 0
    00:10:34 ip address - - 0
    00:10:34 ip address RCPT - 0
    00:10:34 ip address- - 0
    00:10:34 ip address BDAT - 0
    00:10:34 ip address - - 0
    00:10:34 ip address MAIL - 0


    any further suggestions????

    thanks

SHARE:
+ Post New Thread

Similar Threads

  1. Email problems
    By badders in forum CLEO
    Replies: 6
    Last Post: 18th June 2009, 05:29 PM
  2. email problems
    By SteveT in forum CLEO
    Replies: 1
    Last Post: 4th June 2009, 02:38 PM
  3. Exchange 2007 and 2003 Email problems
    By pottski in forum Windows Server 2008
    Replies: 0
    Last Post: 27th February 2009, 09:21 AM
  4. Exchange SMTP relay probs
    By MK-2 in forum Windows
    Replies: 3
    Last Post: 7th August 2008, 01:49 PM
  5. Replies: 0
    Last Post: 25th April 2008, 09:25 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •