+ Post New Thread
Results 1 to 13 of 13
Windows Server 2000/2003 Thread, Active Directory / Folder Redirection problem in Technical; Got a bit of a strange problem with folder Redirection and Active Directory. Set up new teacher accounts recently logging ...
  1. #1
    speckytecky's Avatar
    Join Date
    May 2006
    Location
    UK
    Posts
    2,404
    Thank Post
    3,224
    Thanked 245 Times in 198 Posts
    Blog Entries
    3
    Rep Power
    107

    Active Directory / Folder Redirection problem

    Got a bit of a strange problem with folder Redirection and Active Directory.

    Set up new teacher accounts recently logging them on by year. Now when they log on the folder comes up correctly \\server\teachers\year1 for example but the work does not save to there (even though it comes up correctly in my documents \ properties - seems to be saving locally.

    When I look at the folder permissions on the server it has no one at all set with permissions and offers the only option as me taking control? Any suggestions please folks.

  2. #2
    SC-UK's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    569
    Thank Post
    36
    Thanked 85 Times in 71 Posts
    Rep Power
    29
    As a first step, try taking control of the folder and then assigning the correct positions to it. See if that makes a difference to Docs saving in the correct location or not.

    Tom

  3. Thanks to SC-UK from:

    speckytecky (8th September 2009)

  4. #3

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    I think I know what you're talking about! The drive is mapping correctly, but it hasn't been set as their My Documents. Teachers will save to their My Documents thinking it's on the network, when in fact it's a local cache if My Docs is not mapped.

    Within Active Directory, double click the user(s) in question, navigate to the Profile tab, then make sure the Home Folder is set to, Connect: H:\ To: \\server\teachers\year1

  5. Thanks to Michael from:

    speckytecky (8th September 2009)

  6. #4

    Join Date
    Feb 2006
    Location
    South Cumbria
    Posts
    199
    Thank Post
    26
    Thanked 29 Times in 24 Posts
    Rep Power
    21
    Are the share permissions (not the folder permissions) set correctly - I've had this throw up problems in the past

  7. Thanks to Hecate from:

    speckytecky (8th September 2009)

  8. #5
    speckytecky's Avatar
    Join Date
    May 2006
    Location
    UK
    Posts
    2,404
    Thank Post
    3,224
    Thanked 245 Times in 198 Posts
    Blog Entries
    3
    Rep Power
    107
    Quote Originally Posted by Hecate View Post
    Are the share permissions (not the folder permissions) set correctly - I've had this throw up problems in the past
    Currently the student and Teacher Folder share permissions are set to Everyone - so they ought to be what?

  9. #6
    speckytecky's Avatar
    Join Date
    May 2006
    Location
    UK
    Posts
    2,404
    Thank Post
    3,224
    Thanked 245 Times in 198 Posts
    Blog Entries
    3
    Rep Power
    107
    Thanks for all the useful answers so far team.

    Problem persists. What I have set up in AD is User name G1 and in the properties of the AD user file H:\ drive setting it comes up as \\myserver\teachers\yearG1 (this folder has security settings for the user).

    When the user logs on as G1 in start\my documents\ properties\target \\myserver\teachers\G1 (this folder does not have security settings for the user).

    In my computer the drive is shown as yearg1 on myserver\teachers (H)

    When the user opens word or something similar and goes to save the document the default comes up as My Network Places\My Documents and I just have no idea where that folder might physically be – it’s not showing anywhere on the data folder on the server, but logged on as G1 on another workstation it is visible!

  10. #7

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    In Active Directory, if you navigate to: User Config > Windows Settings > Folder Redirection. On the right, right click My Documents and choose 'Properties'.

    Could you tell me what settings/policies you've set here? There should be various settings on both tabs.

  11. #8
    speckytecky's Avatar
    Join Date
    May 2006
    Location
    UK
    Posts
    2,404
    Thank Post
    3,224
    Thanked 245 Times in 198 Posts
    Blog Entries
    3
    Rep Power
    107
    Thanks Michael,

    I have not done a lot with Group Policy before - still got the L plate on!

    It's basic - redirect everyone's folders to the same location in the top box and Target Folder location is: redirect to user's home directory.

    Oddes't thing about it is some redirections seem to at least partially work?

  12. #9
    Friez's Avatar
    Join Date
    Dec 2006
    Posts
    839
    Thank Post
    22
    Thanked 22 Times in 21 Posts
    Rep Power
    22
    Quote Originally Posted by speckytecky View Post
    Thanks Michael,

    I have not done a lot with Group Policy before - still got the L plate on!

    It's basic - redirect everyone's folders to the same location in the top box and Target Folder location is: redirect to user's home directory.

    Oddes't thing about it is some redirections seem to at least partially work?
    Don't know if you ever got any resolution...
    There is a bug (microsoft call it a feature) in SP3 that breaks folder redirection with windows XP for people with non-admin accounts. If you go to a CLIENT workstation and rightclick-properties fdeploy.dll (in system32) and go to the version tab and click File Version....

    There's two main versions of the DLL we've seen....
    5.1.2600.2180 (xpsp_sp2_rtm.040803-2158) this is the DLL from windows SP2.
    5.1.2600.5512 (xpsp.080413-2113) this is the DLL from windows SP3.

    What you need to do is replace the SP3 dll with the SP2 one, but it's a bit fiddly.

    Firstly, there's a folder called DLLCache, it resides in system32 but is HIDDEN to everyone (even admin) you'll have to type it into your explorer browser. This contains a copy of cruical system files. If you just replace the fdeploy.dll in system32, moments later the copy from dllcache will come to replace it.

    So the obvious solution is to just copy the SP2 fdeploy to both folders right?

    Well, it gets a bit technical here. If you straight installed SP3, it will totally deny you this and your OS will ask for the SP3 disk to restore the SP3 dll from. The solution is to install SP2. UPGRADE to SP3, then quickly get in there and replace the dll in both fdeploy and system32 with the SP2 one.

    A nightmare, but should solve MOST folder redirect issues assuming you've got all your AD configuration correct. Hope that helps people with the same prob!

  13. Thanks to Friez from:

    speckytecky (15th September 2009)

  14. #10
    speckytecky's Avatar
    Join Date
    May 2006
    Location
    UK
    Posts
    2,404
    Thank Post
    3,224
    Thanked 245 Times in 198 Posts
    Blog Entries
    3
    Rep Power
    107
    Thanks Friez,

    Sounds a bit scary all that - do you know if MS are working on a solution for this?

    Quote Originally Posted by Friez View Post
    Don't know if you ever got any resolution...
    There is a bug (microsoft call it a feature) in SP3 that breaks folder redirection with windows XP for people with non-admin accounts. If you go to a CLIENT workstation and rightclick-properties fdeploy.dll (in system32) and go to the version tab and click File Version....

    <snip>

  15. #11

    Join Date
    Apr 2007
    Location
    Christchurch
    Posts
    418
    Thank Post
    41
    Thanked 64 Times in 62 Posts
    Rep Power
    25

    redirect problem

    Hiyah just a thought ... have you unticked the box that sais grant the user exclusive rights to my documents under the settings tab in folder redirection ... Ive had problems if its ticked

    cheers
    Brian

  16. Thanks to Brpilot99 from:

    speckytecky (15th September 2009)

  17. #12

    SpuffMonkey's Avatar
    Join Date
    Jul 2005
    Posts
    2,192
    Thank Post
    53
    Thanked 270 Times in 178 Posts
    Rep Power
    131
    We had a problem like this - if you're using mandatory profiles - had to manually create the My Documents and My Pictures folders within the profile being used as the mandatory one - then everything worked OK - bizarre!

  18. Thanks to SpuffMonkey from:

    tosh74 (28th October 2009)

  19. #13
    Friez's Avatar
    Join Date
    Dec 2006
    Posts
    839
    Thank Post
    22
    Thanked 22 Times in 21 Posts
    Rep Power
    22
    Quote Originally Posted by speckytecky View Post
    Thanks Friez,

    Sounds a bit scary all that - do you know if MS are working on a solution for this?
    They haven't fixed this at all (and don't plan to).
    But as a test, try installing a client machine without SP3 and see if that works, if so, then this is your issue. If not, you might have something else wrong (ontop of this glitch probably). I am assuming you're using XP clients?

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 3
    Last Post: 10th July 2009, 03:11 PM
  2. Create Folder At Logon: Active Directory
    By DaveP in forum Windows Server 2008
    Replies: 3
    Last Post: 3rd December 2008, 06:37 AM
  3. Folder Redirection Problem
    By Gonk in forum Windows
    Replies: 9
    Last Post: 7th February 2008, 04:51 PM
  4. Active Directory Problem
    By clarky2k3 in forum Windows
    Replies: 12
    Last Post: 24th January 2008, 09:58 AM
  5. Folder Redirection and Permission problem
    By ArchersIT in forum Windows
    Replies: 8
    Last Post: 24th July 2007, 09:02 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •