+ Post New Thread
Results 1 to 12 of 12
Windows Server 2000/2003 Thread, Corrupt profiles in Technical; Hi We are having some pretty major issues with roaming profiles at the moment and I wondered if anyone had ...
  1. #1

    Join Date
    Nov 2007
    Location
    Suffolk
    Posts
    15
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Unhappy Corrupt profiles

    Hi

    We are having some pretty major issues with roaming profiles at the moment and I wondered if anyone had some advice....

    We are getting approx 50 users come in per day asking for their profiles to be reset because they are corrupted. It's not a permissions issue as far as I can tell because the problem has only been in the last couple of months but has been working for 6 months prior to that with only the occasional problem. I've installed the UPHClean fix from the very beginning but this doesn't seem to help.

    The station GPO's are configured to not cache the local profile (i.e. delete at logoff) This seems to be working ok on the stations I have checked.

    Any ideas anyone? This is driving me nuts at the moment

  2. #2

    elsiegee40's Avatar
    Join Date
    Jan 2007
    Location
    Kent
    Posts
    10,067
    Thank Post
    1,897
    Thanked 2,377 Times in 1,747 Posts
    Rep Power
    833
    Firstly start using delprof... this will clear local profiles more efficiently. I have had problems with 'not cached' roaming profiles and they have dramatically improved since the intoduction of delprof. Search on here... you'll find plenty of threads about to use it.

    Also consider whether you need roaming profiles. Mandatory profiles, don't get afflicted in this way. All teachers have roaming profiles here, but pupil profiles (we're primary) are mandatory.

  3. #3

    Join Date
    Nov 2007
    Location
    Suffolk
    Posts
    15
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks for the quick reply. I looked into delprof but ended up using a startup script I found on here which deletes all cached profiles. Seems to work ok.

    I had looked into mandatory profiles when I set the server up about a year ago but how do you get round the students having their own favourites/application settings?

    Has it really been much of an issue for your students?

  4. #4
    maark's Avatar
    Join Date
    Feb 2006
    Location
    leicester
    Posts
    483
    Thank Post
    90
    Thanked 78 Times in 69 Posts
    Rep Power
    39
    Have you changed anything on the network?
    Do you know for sure it is corrupt profiles - I have had logoff issues caused by sophos and also login caused by scripts looking for missing shares - check event viewer on stations/profile server for clues,
    cheers Mark

  5. #5
    Galway's Avatar
    Join Date
    Jun 2007
    Location
    West Yorkshire
    Posts
    1,438
    Thank Post
    9
    Thanked 324 Times in 232 Posts
    Rep Power
    104
    You can redirect favorites to the users home folder, easy enough to do and have it working great.
    just find the setting in the registry and modify it to the home folder when creating the profile.
    Application data can also be redirected as part of GP, just like roaming profiles, and this is what I do.

    Basically they get a fixed(mandatory) profile, with redirect app data and a redirected faveorites folder to the home folder.
    No problems so far ... and been running for a while.
    Last edited by Galway; 27th April 2009 at 01:08 PM.

  6. Thanks to Galway from:

    familyguy (27th April 2009)

  7. #6

    Join Date
    Aug 2005
    Location
    London
    Posts
    3,158
    Thank Post
    116
    Thanked 529 Times in 452 Posts
    Blog Entries
    2
    Rep Power
    124
    Do you have quotas on the server where the roaming profiles are stored? if so, are you exceeding the quota when users try to log off - Windows handles this very badly and will mess up.

    Does it fail mostly for people with large profiles - if so, you definitely want to look at ways of reducing the size.

    Are you redirecting my documents and desktop? If not, it's worth doing this - it keeps down the size of the roaming profile (ie the stuff which actually has to be moved at logon/off)

  8. #7

    Join Date
    Nov 2007
    Location
    Suffolk
    Posts
    15
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0
    No haven't changed anything recently. I'm pretty sure the issue is corrupt profiles because the users complain of their desktop being 'old' aka Windows 98 style, and they can't access their documents etc. Looking at the NTuser.dat file of a corrupted user, the file size is only about 256K instead of the usual 1Mb. Deleting it and then letting the system create it from the default user profile at next logon usual cures it.....for a while anyway

    Cheers galway, never though of redirecting favourites that way. I shall definitely be looking at mandatory profiles again. I assume I could do the swop over fairly seamlessly without much disruption to the users?

  9. #8

    Join Date
    Nov 2007
    Location
    Suffolk
    Posts
    15
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quote Originally Posted by srochford View Post
    Do you have quotas on the server where the roaming profiles are stored? if so, are you exceeding the quota when users try to log off - Windows handles this very badly and will mess up.

    Does it fail mostly for people with large profiles - if so, you definitely want to look at ways of reducing the size.

    Are you redirecting my documents and desktop? If not, it's worth doing this - it keeps down the size of the roaming profile (ie the stuff which actually has to be moved at logon/off)
    We do use quotas on that partition but I use the File Server Resource Manager so I only have them set on the actual work folders and not the profile folders. We redirect My Documents, the desktop isn't something users can save to so we don't redirect this.

  10. #9

    elsiegee40's Avatar
    Join Date
    Jan 2007
    Location
    Kent
    Posts
    10,067
    Thank Post
    1,897
    Thanked 2,377 Times in 1,747 Posts
    Rep Power
    833
    Mandatory profile are great, especially for speeding up logon times!

    See this thread: Creating a small mandatory profile

    The wiki:
    Mandatory Profiles

    For more info

  11. Thanks to elsiegee40 from:

    familyguy (27th April 2009)

  12. #10

    Join Date
    Nov 2007
    Location
    Suffolk
    Posts
    15
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I'm having trouble with this... Mandatory profile is working fine but redirected folders aren't working. When I do a GPResult it tells me it couldn't create the folder under the root path. I've double checked the permissions and even started again just to be sure but its still not working.

    I had a look at the microsoft KB article at Event ID 101 and Event ID 1000 Messages May Be Displayed When Folder Redirection Is Set Up with Group Policy but I don't have this applied.

    Also its just started popping up an offline files synchronization box at every logon and logoff. I've made sure the share has offline files disabled so not sure what else I can do.

    Any ideas?

  13. #11

    Join Date
    Jun 2007
    Location
    London
    Posts
    895
    Thank Post
    64
    Thanked 171 Times in 140 Posts
    Rep Power
    56
    If you're using Group Policy to redirect folders make sure you disable 'Grant exclusive rights..." for any shared folders. Enable it if you're redirecting to user's own folder e.g. \\%homeshare%%homepath%.

    You can also turn off file sync with GPs.

  14. #12
    Ben-UK's Avatar
    Join Date
    Jan 2010
    Location
    Nottingham
    Posts
    40
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    10
    Did you ever manage to get this fixed familyguy ?

    Thanks Ben



SHARE:
+ Post New Thread

Similar Threads

  1. Corrupt Outlook Archive
    By richard_s in forum Windows
    Replies: 3
    Last Post: 1st April 2009, 01:21 PM
  2. Corrupt GPO
    By gibbo_ap in forum Wireless Networks
    Replies: 1
    Last Post: 31st March 2009, 11:43 AM
  3. Corrupt Domain Controller
    By Gibbo in forum Windows
    Replies: 20
    Last Post: 9th December 2008, 02:07 PM
  4. Corrupt drivers
    By layercake426 in forum Windows
    Replies: 2
    Last Post: 7th July 2008, 10:22 AM
  5. Corrupt AD HELP!!
    By in forum Windows
    Replies: 17
    Last Post: 6th March 2007, 03:03 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •