+ Post New Thread
Results 1 to 11 of 11
Windows Server 2000/2003 Thread, Printers not appearing in Directory and vanishing from clients in Technical; Right, I've installed the printers on the server. Shared them, added them to the list directory but yet when i ...
  1. #1

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,547
    Thank Post
    2,377
    Thanked 750 Times in 459 Posts
    Blog Entries
    2
    Rep Power
    543

    Printers not appearing in Directory and vanishing from clients

    Right, I've installed the printers on the server. Shared them, added them to the list directory but yet when i do a search from my machine i get the "no printers available" message. When i press "The printer i want isnt listed" and click "Find a printer in directory" there they all are.

    I've never managed printers with AD but have tried changing some settings to:

    Allow printers to be published: Enabled
    Allow pruning of published printers: Disabled
    Check published state: Enabled, every 1 hour
    Directory pruning interval: Disabled
    Directory pruning priority: Disabled
    Directory pruning retry: Disabled
    Log directory pruning retry events: Disabled
    Printer browsing: Enabled
    Prune printers that are not automatically republished: Disabled
    Allow print spooler to accept client connections: Enabled

    I've bounced the print spool but doesnt seem to have helped. I seem to have gone from having a few printers listed but now there are none....

  2. #2

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,547
    Thank Post
    2,377
    Thanked 750 Times in 459 Posts
    Blog Entries
    2
    Rep Power
    543
    this is one of those issues where everyone on the internet seems to have had the problem, but no one gives me an answer that works...*internal screaming*

  3. #3

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,547
    Thank Post
    2,377
    Thanked 750 Times in 459 Posts
    Blog Entries
    2
    Rep Power
    543
    I notice that they're appearing in the Device and Printers pages of clients that are locked down....

    41 read and no replies....

  4. #4
    mikkydoos's Avatar
    Join Date
    Jan 2009
    Location
    Birmingham
    Posts
    149
    Thank Post
    41
    Thanked 11 Times in 10 Posts
    Rep Power
    13
    Do they happen to be HP's by any chance. I've had this........

  5. #5

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,547
    Thank Post
    2,377
    Thanked 750 Times in 459 Posts
    Blog Entries
    2
    Rep Power
    543
    nah, Kyocera..

  6. #6

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,684
    Thank Post
    516
    Thanked 2,453 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833
    I have the exact same issue. Still have no idea what causes it. Just random printers refuse to appear in that list, so I have to enter then manually by path.

    [/superhelpfulresponse]

  7. #7
    mikkydoos's Avatar
    Join Date
    Jan 2009
    Location
    Birmingham
    Posts
    149
    Thank Post
    41
    Thanked 11 Times in 10 Posts
    Rep Power
    13
    This is what I experienced .... (although mine were HP)


    1. I used new drivers - PCL5 - HP had stopped supporting something AD-ish in the later versions of their drivers apparently that stopped them working (on a network printer!)

    2. Perms on your GPO (are u installing per user or per computer? )

    3. I've also had major dns issues with printers when I've either changed their name, new printer server or new IP. Is your path \\servername\sharedprinter or \\ipaddress\sharedprinter. Try changing them from one to the other & try deleting the dns host record for one of them and force dns to create a new one.

    I seem to remember dns being the final solution.

  8. #8

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,547
    Thank Post
    2,377
    Thanked 750 Times in 459 Posts
    Blog Entries
    2
    Rep Power
    543
    They seem to be filtering through after a reboot, but i will wait before i think its sorted. DNS did occur to me, the web interface has space for DNS server address so i've added them to one to test it out....

  9. #9

    Join Date
    Sep 2010
    Posts
    559
    Thank Post
    26
    Thanked 62 Times in 58 Posts
    Rep Power
    19
    policy being applied to computer or user if your publishing via GPO

  10. #10
    mikkydoos's Avatar
    Join Date
    Jan 2009
    Location
    Birmingham
    Posts
    149
    Thank Post
    41
    Thanked 11 Times in 10 Posts
    Rep Power
    13
    U have to put DNS address in the printer if using a static address otherwise they definately wont work

  11. #11

    Little-Miss's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    5,547
    Thank Post
    2,377
    Thanked 750 Times in 459 Posts
    Blog Entries
    2
    Rep Power
    543
    Ok, things SEEM to be ok (see that Fate, i haven't said its sorted so don't get tempted)....apart from one user, but thats a whole different issue.

    Interesting thing is i installed the 8 new PC's using the software that came with them, i've just reinstalled an older one by purely using the drivers on the server and that one is appearing in the add printer list....

SHARE:
+ Post New Thread

Similar Threads

  1. XP Clients not appearing in DNS
    By GoldenWonder in forum Windows
    Replies: 5
    Last Post: 30th November 2010, 01:12 PM
  2. Printer Management "List In Directory" tick box
    By farquea in forum Windows Server 2000/2003
    Replies: 6
    Last Post: 23rd August 2010, 11:25 AM
  3. Replies: 10
    Last Post: 26th March 2009, 06:17 PM
  4. SMTP Does Not Appear in the IIS Manager
    By tazz in forum Windows Server 2000/2003
    Replies: 0
    Last Post: 6th February 2009, 10:22 AM
  5. Replies: 31
    Last Post: 2nd November 2007, 05:20 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •