+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 19
Windows 8 Thread, Windows 8.1 KMS problems in Technical; Ok so i have some really strange issues with 8.1 kms activation and it appears to be a permissions issue, ...
  1. #1

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6

    Windows 8.1 KMS problems

    Ok so i have some really strange issues with 8.1 kms activation and it appears to be a permissions issue, does anyone know what permissions are needed on the client for kms activation to work?

    Problems i am getting are as follows when i run slmgr.vbs i get an error telling me that i need to run slui, when i paste the public client key into the ui it says it cannot be validated.

    any help will be greatly appreciated.

    Das

  2. #2

    Join Date
    Nov 2010
    Location
    Birmingham
    Posts
    86
    Thank Post
    13
    Thanked 10 Times in 9 Posts
    Rep Power
    10
    Is the KMS Server itself activated? I know it sounds stupid but wasn't that obvious to us.

    Also what does it say in event viewer on the client for KMS service?

  3. #3

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6
    We don't have any problems with office or windows 7.

    As for the logs the KMS Service logs are blank.

  4. #4

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6
    And yes we are activated.

  5. #5

    Join Date
    Jul 2009
    Posts
    589
    Thank Post
    51
    Thanked 110 Times in 95 Posts
    Rep Power
    68
    Is the KMS server running 2012 (not r2) or below?

    If it is, then run the update below, then install the 2012R2 KMS key from the VLSC.

    Update adds support for Windows 8.1 and Windows Server 2012 R2 clients to Windows Server 2008, Windows 7, Windows Server 2008 R2, Windows 8, and Windows Server 2012 KMS hosts

  6. #6

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6
    Wish it was that easy, update already installed and the code for R2,

    We are using 2012

  7. #7
    Valyyn's Avatar
    Join Date
    Jun 2011
    Location
    Portsmouth
    Posts
    204
    Thank Post
    22
    Thanked 63 Times in 45 Posts
    Rep Power
    54
    This might be a silly question, but is exactly the problem I had yesterday... When you say you added the code for R2, did you just add it into the VAMT tool? That's what I did and it doesn't work. You have to actually replace the KMS server itselfs key with the 2012 R2 one, using slmgr.vbs -ipk followed by slmgr.vbs -ato

    That didn't seem intuitive to me because our KMS is 2008 R2 so it seemed odd telling it to use the 2012 R2 key, but that sorted it for me!

  8. #8

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6
    Trying it now that sounds like the problem, report back soon

  9. #9

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6
    is there anything i need to do on the problem clients? as it doesnt seem to be working

  10. #10

    Join Date
    May 2010
    Posts
    1,115
    Thank Post
    108
    Thanked 101 Times in 76 Posts
    Rep Power
    51
    Firewall ?

  11. #11

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6
    This is the error i get and no its not firewall.

    0xc0000022
    Access Denied
    A process has requested access to an object, but has not been granted those access rights.
    Last edited by dastrix; 26th March 2014 at 01:18 PM.

  12. #12

    Join Date
    May 2010
    Posts
    1,115
    Thank Post
    108
    Thanked 101 Times in 76 Posts
    Rep Power
    51
    Software Protection service ?

  13. #13

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6
    Yeah that's set to network service, am I correct in saying that it starts on demand?

  14. #14

    Join Date
    May 2010
    Posts
    1,115
    Thank Post
    108
    Thanked 101 Times in 76 Posts
    Rep Power
    51
    Mines set to automatic (delayed start, trigger start) on windows 8.1 as a network service

  15. #15

    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    97
    Thank Post
    5
    Thanked 4 Times in 3 Posts
    Rep Power
    6
    ok so its set to delayed start if i start it then run slmgr /ato the service stops

    and i get the same errors

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. [Windows Software] Office 2010 KMS Problem
    By quiet_andy in forum Licensing Questions
    Replies: 1
    Last Post: 26th January 2011, 11:09 AM
  2. Windows 2008R2 & Hyper V Problem!
    By madman070578 in forum Windows Server 2008 R2
    Replies: 7
    Last Post: 28th November 2009, 10:27 AM
  3. Windows Server 2003 Installaion Problem
    By faisalpandu in forum Windows Server 2000/2003
    Replies: 4
    Last Post: 25th October 2008, 11:38 PM
  4. Windows xp home format problem
    By cburrows in forum Windows
    Replies: 4
    Last Post: 20th August 2008, 10:41 AM
  5. Windows Media Player 11 - problem with album info
    By sidewinder in forum Windows
    Replies: 0
    Last Post: 18th December 2006, 11:56 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •