+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 40
Windows 8 Thread, Windows 8.1 Keeps restoring Metro apps in Technical; Actually, this error is coming up because the apps are already removed from the image, so it brings me back ...
  1. #16

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,940
    Thank Post
    886
    Thanked 1,693 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    Actually, this error is coming up because the apps are already removed from the image, so it brings me back to the question as why they keep returning.

  2. #17

    Join Date
    May 2013
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I'm investigating something else at the moment (removing the Camera, Skydrive and Photos apps) but found some information on this blog that you might find useful: Windows 8.1 latent apps | Confidential Files!

  3. #18

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,940
    Thank Post
    886
    Thanked 1,693 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    Thanks, the issue it have removed them, they are not in my image but come back after the imaging process has completed. Annoying I must say!

  4. #19

    Join Date
    May 2010
    Location
    UK
    Posts
    165
    Thank Post
    40
    Thanked 9 Times in 9 Posts
    Rep Power
    10
    Not sure if i've misunderstood, but when I'm creating my reference image I run in admin powershell:

    Get-AppXProvisionedPackage -online | Remove-AppxProvisionedPackage –online

    followed by:

    Get-AppXPackage | Remove-AppxPackage

    This literally removes every app, baring camera, photos and IE. Once I sysprep and capture the image...the apps don't come back... hope this helps!

  5. Thanks to beany1 from:

    jaminben (10th April 2014)

  6. #20

    Join Date
    May 2013
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by FN-GM View Post
    Thanks, the issue it have removed them, they are not in my image but come back after the imaging process has completed. Annoying I must say!
    Are they coming back from the hidden C:\Program Files\WindowsApps folder? You can see the contents using an elevated command prompt without having to change the permissions. I wonder what happens if you delete the apps from there if they still exist after 'removing' them using PowerShell or DISM.

  7. #21

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,940
    Thank Post
    886
    Thanked 1,693 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    I might try that, but i have a feeling it will kick up a fuss.

  8. #22


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,875
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    FWIW, my Windows image (modified using the method described in post #14) doesn't contain any apps in the "C:\Program Files\WindowsApps" folder.


  9. #23

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,940
    Thank Post
    886
    Thanked 1,693 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    Thanks, tried to delete them with the image mounted, had issues. @Arthur how did you open that WIM in 7-zip please? Cheers

  10. #24


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,875
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    Quote Originally Posted by FN-GM View Post
    how did you open that WIM in 7-zip please?
    Right-click .wim, go to 7-Zip menu and select "Open archive".

    7-Zip has been able to open WIM files since 2007.

  11. #25

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,940
    Thank Post
    886
    Thanked 1,693 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    Weird, won't let me do it.

    7zip error.PNG

  12. #26


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,875
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    Quote Originally Posted by FN-GM View Post
    Weird, won't let me do it.
    Do you have the latest version of 7-zip installed?

  13. #27

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,940
    Thank Post
    886
    Thanked 1,693 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    Yep, freshly downloaded this morning (9.20).

  14. #28


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,875
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    Quote Originally Posted by FN-GM View Post
    Yep, freshly downloaded this morning (9.20).
    Perhaps the latest alpha version would be better? (v9.32)

  15. #29

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,940
    Thank Post
    886
    Thanked 1,693 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    Some progress! I have installed that version I can open the WIM. I have deleted some folders it won't let me delete anymore. Argh!

  16. #30


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,875
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    Quote Originally Posted by FN-GM View Post
    Some progress! I have installed that version I can open the WIM. I have deleted some folders it won't let me delete anymore. Argh!
    IIRC, 7-Zip can only view the contents of .wim files.

    You would still need to use PowerShell or DISM to modify the image.

SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Removing Metro Apps from a Windows 8 Image
    By AndiMarv in forum Windows 8
    Replies: 1
    Last Post: 5th October 2013, 01:14 AM
  2. Windows 8 disappearing IE 10 metro app
    By RobertC in forum Windows 8
    Replies: 0
    Last Post: 28th June 2013, 11:35 AM
  3. Replies: 3
    Last Post: 16th May 2013, 11:20 PM
  4. Windows 8 Metro apps behaviour
    By Dos_Box in forum Windows 8
    Replies: 5
    Last Post: 19th September 2011, 09:17 AM
  5. IE8 Keeps Restoring tabs after windows update
    By danny0001uk in forum Windows
    Replies: 1
    Last Post: 20th August 2010, 10:15 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •