+ Post New Thread
Results 1 to 11 of 11
Windows 8 Thread, Cannot UNC to Win8 C: Drive in Technical; I am about to start upgrading my Win7 machines to win 8. Where previously i've been able to simply \machinename\c$ ...
  1. #1

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    117
    Thank Post
    2
    Thanked 2 Times in 1 Post
    Rep Power
    6

    Cannot UNC to Win8 C: Drive

    I am about to start upgrading my Win7 machines to win 8. Where previously i've been able to simply \\machinename\c$ onto the C: drive of all computers in the office using the local Admin account on each computer, i've noticed i now can't do this on Windows 8. It prompts for the password but wont accept my credentials, even if i choose machinename\localadmin as the username.

    I did an upgrade from 7 to 8 so thought it would keep the same settings in place. i Believe in order for this to work you just need to have Password Protected Sharing enabled in Advanced Sharing Settings, which is enabled.

    Can anyone point out what is wrong here?

  2. #2
    free780's Avatar
    Join Date
    Sep 2012
    Posts
    1,027
    Thank Post
    43
    Thanked 84 Times in 80 Posts
    Rep Power
    22
    Is your domain account not just a member of the local admins?

  3. #3

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    117
    Thank Post
    2
    Thanked 2 Times in 1 Post
    Rep Power
    6
    This is not in a domain environment, just a workgroup

  4. #4


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,178
    Thank Post
    235
    Thanked 2,755 Times in 2,029 Posts
    Rep Power
    803
    Setting the following registry value will enable you to access administrative shares in a workgroup environment. Reboot and then try connecting again.

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System]
    "LocalAccountTokenFilterPolicy"=dword:00000001
    or

    Code:
    reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f
    More info here...


  5. #5

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    117
    Thank Post
    2
    Thanked 2 Times in 1 Post
    Rep Power
    6
    Thanks, although can i ask, is this a change in Windows 8 because this worked without having to do the above in Windows 7 and i even did a in place upgrade from 7 to 8.1?

  6. #6


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,178
    Thank Post
    235
    Thanked 2,755 Times in 2,029 Posts
    Rep Power
    803
    Quote Originally Posted by AndyCan View Post
    is this a change in Windows 8
    No.

    Quote Originally Posted by AndyCan View Post
    this worked without having to do the above in Windows 7
    Did you disable UAC? That would explain why you didn't have to make the change mentioned above previously, but you do now.

  7. #7
    free780's Avatar
    Join Date
    Sep 2012
    Posts
    1,027
    Thank Post
    43
    Thanked 84 Times in 80 Posts
    Rep Power
    22
    I take it they all have the same password?
    The administrator account isn't disabled or locked out? Have you tried \\ip\c$ ?

  8. #8

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    117
    Thank Post
    2
    Thanked 2 Times in 1 Post
    Rep Power
    6
    UAC was disabled in windows 7 yes, and until just now UAC was enabled on Windows 8, however i disabled UAC and it still doesnt work like it used to.

    And yes all computers have the same local admin and password account setup. The account is fine, i can log on using that account no problem and i can \\machinename\c$ to all my Windows 7 machines fine, even do it from Windows 8 to a Windows 7 machine, just not to Windows 8 machine.

    Using the IP doesnt change anything, i can connect to the machine fine, it just wont let me access c$ unless i explicitly share the C drive. If i just do \\machinename it shows me all the default shares available, which currently is just the 'Users' folder.

  9. #9


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,178
    Thank Post
    235
    Thanked 2,755 Times in 2,029 Posts
    Rep Power
    803
    Windows 8.x needs UAC enabled for Metro apps to work. Therefore it would be better to keep UAC enabled and then set that registry value above.

  10. #10

    Join Date
    Oct 2008
    Location
    Lincolnshire
    Posts
    2,247
    Thank Post
    13
    Thanked 231 Times in 220 Posts
    Rep Power
    68
    Do you have the local firewall on this PC as it will stop it unless there is exceptions in place for file & print sharing.

  11. #11

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    117
    Thank Post
    2
    Thanked 2 Times in 1 Post
    Rep Power
    6
    the registry key above did it, thanks! I see its disabled by default in Win 8 though compared to 7

SHARE:
+ Post New Thread

Similar Threads

  1. Cannot connect to mapped drive
    By Little-Miss in forum Windows Server 2008 R2
    Replies: 15
    Last Post: 20th July 2012, 12:53 PM
  2. Replies: 2
    Last Post: 24th June 2011, 08:28 AM
  3. LNM failed to format hard drives
    By wesleyw in forum Learning Network Manager
    Replies: 8
    Last Post: 29th April 2006, 08:26 AM
  4. pupils able to access c drive via word 2000 web toolbar
    By projector1 in forum Office Software
    Replies: 22
    Last Post: 8th December 2005, 08:44 PM
  5. Replies: 2
    Last Post: 1st October 2005, 02:55 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •