+ Post New Thread
Results 1 to 3 of 3
Windows 7 Thread, Winlogon Notification Subscriber taking foever! in Technical; I get 2 errors. First one is Event ID 6005 The winlogon notification subscriber <GPClient> is taking long time to ...
  1. #1

    Join Date
    Jun 2008
    Posts
    728
    Thank Post
    118
    Thanked 65 Times in 53 Posts
    Rep Power
    31

    Winlogon Notification Subscriber taking foever!

    I get 2 errors.

    First one is Event ID 6005
    The winlogon notification subscriber <GPClient> is taking long time to handle the notification event (CreateSession).

    Followed an hour or so later with the Event ID 6006
    The winlogon notification subscriber <GPClient> took xxx second(s) to handle the notification event (CreateSession).


    The screen is stuck at Applying Computer Settings and the quickest it's been for me to get to the login screen was 8004 seconds!!!!!!!!!!!!!


    I've applied the following hotfixes which claim to fix the problem(s) but to no avail:
    You encounter a long logon time after you enable the "Do not automatically make redirected folders available offline" Group Policy setting in Windows 7 or in Windows Server 2008 R2
    Unexpectedly slow startup or logon process in Windows Server 2008 R2 or in Windows 7


    I've disabled IPv6 on the LAN and WLAN. Also the same on both DCs
    I've disabled Autotuning with the command: netsh interface tcp set global autotuninglevel=disabled
    I've installed all the latest drivers
    Disabled Card Reader
    Added the registry key of GpNetworkStartTimeoutPolicyValue with the value of 1 in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    I moved the computer object to a unmanaged OU (without policies applied), ran gpupdate /force and rebooted but the problem still exists.

    I am now pulling my hair out over this! I've been at it since last week and haven't managed to reduce the time to within 60 mins.

    Has anyone experienced this and, if so, what was your solution?
    Last edited by Chuckster; 9th May 2012 at 03:25 PM.

  2. Thanks to Chuckster from:

    SimonWindisch (11th October 2013)

  3. #2

    Join Date
    Jun 2008
    Posts
    728
    Thank Post
    118
    Thanked 65 Times in 53 Posts
    Rep Power
    31
    After 2 days of disabling everything in my single GPO of Comp Config, and re-enbaling everything one bit at a time, I discovered just now that disabling "Run logon scripts synchronously” cured my problem!

    No more Event IDs 6005 and 6006! Hurrah!

    This is found under Computer Configuration\Policies\Administrative Templates\System\Scripts

  4. #3

    Join Date
    Aug 2008
    Location
    Reading
    Posts
    63
    Thank Post
    33
    Thanked 2 Times in 2 Posts
    Blog Entries
    1
    Rep Power
    13
    In my case it was a Multipoint Server 2011

    I had an extra 10 network cards defined. I disabled all of these, turned off IPv6 and the problem went away.

SHARE:
+ Post New Thread

Similar Threads

  1. When do you take your holidays?
    By mark in forum General Chat
    Replies: 17
    Last Post: 14th September 2011, 09:09 AM
  2. Sims taking forever to upgrade
    By Rozzer in forum Windows
    Replies: 16
    Last Post: 18th January 2006, 03:52 PM
  3. Replies: 22
    Last Post: 2nd November 2005, 01:11 PM
  4. Replies: 11
    Last Post: 27th September 2005, 12:30 AM
  5. Take me back to a time I know really well.
    By british-wave in forum Jokes/Interweb Things
    Replies: 0
    Last Post: 20th September 2005, 07:59 AM

Thread Information

Users Browsing this Thread

There are currently 7 users browsing this thread. (0 members and 7 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •