+ Post New Thread
Results 1 to 13 of 13
Windows 7 Thread, Win 7 Default Home Folder and Folder Redirection Conflict in Technical; On a Win 2008 R2 Domain I have yet another problem and the solution creates another problem. When you redirect ...
  1. #1

    Join Date
    Feb 2009
    Location
    Essex
    Posts
    224
    Thank Post
    22
    Thanked 16 Times in 12 Posts
    Rep Power
    13

    Win 7 Default Home Folder and Folder Redirection Conflict

    On a Win 2008 R2 Domain I have yet another problem and the solution creates another problem.

    When you redirect the Documents folder on a Windows Vista-based or Windows 7-based computer to a network share, the folder name unexpectedly changes back to Documents describes:

    When you redirect the Documents folder on a Windows Vista-based or Windows 7-based computer to a network share, the folder name unexpectedly changes back to Documents. You expect the folder name to be the user name.

    The solution is:

    Under User Configuration, expand Windows Settings, and then expand Folder Redirection.
    Right-click the Documents folder, and then click Properties.
    On the Target tab, configure the following:

    In the Setting box, click Basic—redirect everyone’s folder to the same location.
    In the Target Folder Location box, click Create a folder for each user under the root path.
    In the Root Path box, type the UNC file path to which you want to redirect the Documents folder.

    In the Documents Properties dialog box, click the Settings tab, and then configure the following:

    Click to select the Grant the user exclusive rights to Documents check box.
    Click to select the Move the contents of Documents to the new location check box.


    However when the Document settings are configured with the "Grant the user exclusive rights to Documents" ticked, when a user logs on to a Windows 7 machine and opens Word, creates a document and goes to "Save As", The default Save folder is shown as "Username\My Documents" which is a local folder on drive C. I do not want users to be able to save here, and want them to save to the Network N:\ drive.

    When I remove the tick from: "Grant the user exclusive rights to Documents", log on, load word, create a document and go to "Save As" the default save location shows as the users home drive "N:\", however doing this renames the users home folder on the server to "My Documents" which is not ideal.

    Going back to: When you redirect the Documents folder on a Windows Vista-based or Windows 7-based computer to a network share, the folder name unexpectedly changes back to Documents I tried Method 3 but it did not work, and am not sure how to implement Method 1 without making things more complex for the users.

    I also found this post here: Controlling Libraries with Group Policy and have implemented this although for what ever reason the changes have not worked and the Public folder is not being deleted, as well as still being able to save files to the root of the user share (%userdomain%\%username%).

    I also followed: Controlling Libraries with Group Policy but again the folder is not being deleted.

    Any help on this one would be more than appreciated. What have other people done to get around this problem?

  2. #2

    Join Date
    Feb 2009
    Location
    Essex
    Posts
    224
    Thank Post
    22
    Thanked 16 Times in 12 Posts
    Rep Power
    13
    Just wondering if this is also something related to Windows Libraries settings?

    I wanted to remove Windows Libraries to prevent users saving to the local computer, so did this using the reg file at: Controlling Libraries with Group Policy

    However before I deleted this I noticed Documents under Libraries set the default folder as C:\Users\<username>\documents and am wondering if this might be something to do with the problem (even though I deleted it using the Reg key).

  3. #3

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,402
    Thank Post
    797
    Thanked 1,591 Times in 1,394 Posts
    Blog Entries
    10
    Rep Power
    428
    There are lots of threads about this on here. It is like this by design. It is caused by the desktop.ini file. Whatever you do dont block this file. You will get slow logons. Method 1 on the Microsoft link is the best way to "fix" it.

  4. #4

    Join Date
    Feb 2009
    Location
    Essex
    Posts
    224
    Thank Post
    22
    Thanked 16 Times in 12 Posts
    Rep Power
    13
    It looks like Method 1 might be the Only way to fix it with out causing the other problem I mentioned, where it then defaults to local folders rather than the redirected documents folder. I had a look for other threads which specifically mention the problem that occurs when I implement method 2, but could not find any making me wonder if anyone had this problem occur as a result of this fix and if someone had found a way around it.

  5. #5

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,714
    Thank Post
    269
    Thanked 1,116 Times in 1,012 Posts
    Rep Power
    345
    Quote Originally Posted by FN-GM View Post
    There are lots of threads about this on here. It is like this by design. It is caused by the desktop.ini file. Whatever you do dont block this file. You will get slow logons. Method 1 on the Microsoft link is the best way to "fix" it.
    Can you not just delete these though? I thought that worked..

  6. #6
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    815
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    39
    Quote Originally Posted by FN-GM View Post
    There are lots of threads about this on here. It is like this by design. It is caused by the desktop.ini file. Whatever you do dont block this file. You will get slow logons. Method 1 on the Microsoft link is the best way to "fix" it.
    Is this what can make the logon stick on "Applying folder redirection"?

  7. #7

    bossman's Avatar
    Join Date
    Nov 2005
    Location
    England
    Posts
    3,855
    Thank Post
    1,162
    Thanked 1,028 Times in 729 Posts
    Rep Power
    323
    Deleting the desktop.ini file will rectify and will rename the document folder as the owner, had the same problem early on with some user folders just called My Documents but once I had deleted the desktop.ini files it sorted it.

  8. #8

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,402
    Thank Post
    797
    Thanked 1,591 Times in 1,394 Posts
    Blog Entries
    10
    Rep Power
    428
    Quote Originally Posted by morganw View Post
    Is this what can make the logon stick on "Applying folder redirection"?
    Yep thats exactly what happens

    Quote Originally Posted by glennda View Post
    Can you not just delete these though? I thought that worked..
    Quote Originally Posted by bossman View Post
    Deleting the desktop.ini file will rectify and will rename the document folder as the owner, had the same problem early on with some user folders just called My Documents but once I had deleted the desktop.ini files it sorted it.
    But its not a fix, its just a work around. The desktop.ini will just recreate itself.

  9. Thanks to FN-GM from:

    morganw (19th February 2012)

  10. #9

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,714
    Thank Post
    269
    Thanked 1,116 Times in 1,012 Posts
    Rep Power
    345
    Ah ok - just checking it didn't break things! I've got a script which runs every.2 hours and deletes desktop.ini files

  11. #10

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,512 Times in 1,206 Posts
    Rep Power
    328
    Certain GPOs can slow down logon too, as I described here

    Deleting the desktop.ini file is a waste of time, as it will just re-create itself. This is the method I use which involves no deleting or any scripts.

    Unfotunately there's no method to deploy this by GPO. If anyone finds a way however, please post it here!

  12. #11

    Join Date
    Feb 2009
    Location
    Essex
    Posts
    224
    Thank Post
    22
    Thanked 16 Times in 12 Posts
    Rep Power
    13
    Ive been reading a lot about this, and it occurred to me the best option would probably be for the desktop.ini file to be deleted at log off.

    A quick search and I found this log off script:
    Redirected My Documents folders showing as ‘Documents’ rather than the users name « Weird & Wonderful IT

    And it works... As long as users log off correctly!

  13. #12

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,402
    Thank Post
    797
    Thanked 1,591 Times in 1,394 Posts
    Blog Entries
    10
    Rep Power
    428
    Quote Originally Posted by CommodoreS View Post
    Ive been reading a lot about this, and it occurred to me the best option would probably be for the desktop.ini file to be deleted at log off.

    A quick search and I found this log off script:
    Redirected My Documents folders showing as ‘Documents’ rather than the users name « Weird & Wonderful IT

    And it works... As long as users log off correctly!
    If you insist in deleting the .ini file you will get better results running the delete script from the server so if they dont log off properly you dont get the issue.

  14. #13
    gshaw's Avatar
    Join Date
    Sep 2007
    Location
    Essex
    Posts
    2,604
    Thank Post
    154
    Thanked 205 Times in 190 Posts
    Rep Power
    64
    Am I right in thinking that this is only a problem if you have the "Documents" folder as the root directory e.g.

    \\server\home\%username% is the folder that becomes "Documents" (then Pictures etc underneath in subfolders aka "follow the root folder")

    as opposed to

    \\server\home\%username%\Documents
    \\server\home\%username%\Pictures
    \\server\home\%username%\Videos
    etc

    Judging by the MS link that seems to be the best method (and looks nice and neat)

SHARE:
+ Post New Thread

Similar Threads

  1. Laptops at school and home (GPO folder redirection)
    By dsk in forum How do you do....it?
    Replies: 8
    Last Post: 26th November 2009, 09:16 AM
  2. Windows XP-SP3 and "Folder redirection"
    By Polski in forum Windows
    Replies: 5
    Last Post: 30th May 2008, 05:07 PM
  3. Replies: 0
    Last Post: 12th March 2008, 09:20 AM
  4. Users Home Folder and Network Drive
    By lovelldr in forum Windows
    Replies: 6
    Last Post: 6th August 2007, 10:17 AM
  5. Folder Redirection and Permission problem
    By ArchersIT in forum Windows
    Replies: 8
    Last Post: 24th July 2007, 09:02 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •