+ Post New Thread
Results 1 to 5 of 5
Windows 7 Thread, Weird Updates Problem in Technical; I have a few Windows 7 machines in an IT suite which are refusing to do any updates. When you ...
  1. #1

    Join Date
    Jan 2010
    Location
    Slough
    Posts
    112
    Thank Post
    21
    Thanked 5 Times in 5 Posts
    Rep Power
    20

    Weird Updates Problem

    I have a few Windows 7 machines in an IT suite which are refusing to do any updates.

    When you try to run updates manaully it comes up with an error message saying that the Windows update service is not running and asks me to start it.

    When i go to services.msc and try to start the service I get "Error 0x80072726: An invalid argument was supplied." This isn't very helpful!!

    The event view just gives me the same message. I have tried the hotfix in Microsoft KB971058 and it made no difference!

    Any clues???

  2. #2

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,214 Times in 761 Posts
    Rep Power
    395
    Have you tried running chkdsk followed by sfc /scannow to check for any system file corruption?

  3. #3
    accura2000's Avatar
    Join Date
    Apr 2007
    Location
    Ashford, Kent
    Posts
    176
    Thank Post
    17
    Thanked 34 Times in 23 Posts
    Rep Power
    21
    I had PC's refusing to update because the date and time was wrong? Worth a check

  4. #4

    Join Date
    Feb 2012
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    may be it want you to update your updater? it sounds ridiculous, but my PC asked me several months ago

  5. #5

    Join Date
    Jan 2010
    Location
    Slough
    Posts
    112
    Thank Post
    21
    Thanked 5 Times in 5 Posts
    Rep Power
    20
    Thanks for the replies! I tried everything but didnt get anywhere.

    I ended up re-imaging the machines and they are fine now!!



SHARE:
+ Post New Thread

Similar Threads

  1. Weird monitor problem
    By sparkeh in forum Hardware
    Replies: 9
    Last Post: 12th June 2008, 11:13 AM
  2. Weird Outlook Problems
    By DSapseid in forum Windows
    Replies: 9
    Last Post: 21st November 2007, 12:21 PM
  3. Weird RIS problem today..............!
    By Kyle in forum General Chat
    Replies: 1
    Last Post: 17th October 2007, 11:49 PM
  4. sims august update problems
    By Jonny_sims in forum MIS Systems
    Replies: 2
    Last Post: 12th September 2007, 04:56 PM
  5. Weird AD problem
    By SpuffMonkey in forum Windows
    Replies: 3
    Last Post: 29th March 2006, 11:57 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •