+ Post New Thread
Results 1 to 3 of 3
Windows 7 Thread, Low Printing Problem - IE9 - Cannot print or preview pages in IE9 in Technical; Hello all, I am posting here, because I am seeing a fairly localised problem with one of our admin office ...
  1. #1
    rich_tech's Avatar
    Join Date
    Mar 2011
    Location
    Wales
    Posts
    1,097
    Thank Post
    132
    Thanked 140 Times in 122 Posts
    Rep Power
    66

    Question Low Printing Problem - IE9 - Cannot print or preview pages in IE9

    Hello all,

    I am posting here, because I am seeing a fairly localised problem with one of our admin office staff, thats being suprisingly stubborn for this one user, I have basically worked through the following post because its a recognised problem that she is having - Unable to print or view the print preview of a webpage in Internet Explorer - I have carried out all the suggestions in there and some more, gfx cards drivers are up to date and I have even elevated the user temporarily to administrator level to access and run that command line and the fix its, but it still remains a temporary fix to the problem, when they log in the next day, the problem returns, we use mandatory profiles for users on our network all other staff use the same profile without any issue, we have had one or two occurrences of this problem before, but a profile deletion has fixed them to date up until this one, we dont use protected mode for IE that im aware of and running it as an administrator didnt fix it.

    Its causing me a headache as emails for staff are through outlook web access within our site, so this person obviously needs to be able to print through IE to record these emails.

    The printer is a brother laser printer set to be the default local printer attached to their printer via USB, mapped for the user through GPP on the domain(this is because SIMS FMS refused to recognise our network pull queue as a valid printer - FMS wouldnt start with that set as the printer), I have even set the user TEMP variable to be within the network space of the user so there are definitely no permissions problems relating to the temp folders as well.

    The printer in question also is installed with the correct drivers and I have even wiped the profile off the computer while doing this, I have even reimaged the PC to find the problem persists for this user after rebuilding, it temporarily fixes, but then occurs again a day or so later.

    It is Win7Enterprise/IE9 PC

    Can anyone make any suggestions as to anything obvious ive overlooked or not tried as of yet ? or has anyone else experienced this problem and worked through it ?

    Thanks, any help would be appreciated at this point ,

    Richard

  2. #2

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27
    IE8 Printing/Print Preview and JAVA dont work for users
    * Original credit to Psymon for this post

    IE8 will display/print blank pages rather then correctly formatted pages due to a lack of a "Low" folder being created in the "Local" area of the logged in profile.
    This has also caused Java to crash the tab in my experience when it also was triggered on a web page.

    MS KB Article: You cannot print or print preview Web pages in Internet Explorer on Windows Vista or on Windows 7

    To Fix:
    Basically you need to make a folder in c:\users\{username}\Appdata\local\temp called "Low" which then needs a special permission applied to it. Due to the fact this folder is flushed out at log out (roaming at least) you will have to do this each time someone logs in.
    A slightly modified version of a bat script created by Psymon is below which can be used as a user logon script and it will automatically create and set the correct permissions on the folder on logon.
    Code:
    Code:
    @echo off
    If not exist %localappdata%\Temp\Low (
     echo.
     echo Creating Low Folder...
     mkdir %localappdata%\Temp\Low
    )
    echo.
    echo Apply Integrity Level...
    echo.
    ICACLS "%localappdata%\Temp\Low" /setintegritylevel (OI)(CI)low
    exit
    This has fixed Java and also the print/print preview issue for us

    This is from the following thread, Windows 7 Gotchas/Tips/FYI. Sounds like the same issue (but only affecting that user).
    Last edited by Psymon; 30th November 2011 at 09:07 AM.

  3. Thanks to Psymon from:

    rich_tech (30th November 2011)

  4. #3
    rich_tech's Avatar
    Join Date
    Mar 2011
    Location
    Wales
    Posts
    1,097
    Thank Post
    132
    Thanked 140 Times in 122 Posts
    Rep Power
    66

    Smile

    Thanks for that, I forgot to look in the thread you mentioned and after the day I had, I just didnt think to even search on here for that, ill give that solution a try tomorrow morning and hopefully it will end this problem for this particular user. Its been hugely frustrating because every day so far these last 7 days I've fixed it working through various things for it to manifest again the next day.

    Richard

SHARE:
+ Post New Thread

Similar Threads

  1. LanSchool - Limit Printing (Or not...)
    By Steve21 in forum Network and Classroom Management
    Replies: 3
    Last Post: 14th April 2011, 02:19 PM
  2. Replies: 4
    Last Post: 7th December 2010, 03:27 PM
  3. Problem with batch backup or SIMS.net using DBAttach
    By GreenICT in forum MIS Systems
    Replies: 5
    Last Post: 18th August 2009, 08:48 AM
  4. Print Costs per Page
    By TechSupp in forum General Chat
    Replies: 10
    Last Post: 7th February 2008, 03:50 PM
  5. Got a folder I cannot delete or take ownership of
    By sidewinder in forum Windows
    Replies: 2
    Last Post: 20th March 2007, 02:49 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •