+ Post New Thread
Results 1 to 13 of 13
Windows 7 Thread, Help windows 7 my documents name in Technical; HI Please can some one help. We are starting to move onto windows 7 and we have noticed an oddity. ...
  1. #1
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,475
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52

    Help windows 7 my documents name

    HI

    Please can some one help. We are starting to move onto windows 7 and we have noticed an oddity. When we create a user we create a folder on the server called the username in the correct folder like staff or intake and give them modify permission to the folder.

    We have started seeing that another who has logged in on a windows 7 machine has started getting the folder name of there area changed into My Documents. If you go to the paths \\servername\users\group area\username this works but if you go to \\servername\users\group area\ we are getting huge numbers of folders called my documents.

    This is very strange.

    Is anyone else getting this and how do you stop it?

    Richard

  2. #2
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,475
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52
    Hi

    I have found this is common see When you redirect the Documents folder on a Windows Vista-based or Windows 7-based computer to a network share, the folder name unexpectedly changes back to Documents

    Now all I have to do is find a way to set the security of the desktop.ini to read only in there folder

    Richard

    Richard

  3. #3
    DAZZD88's Avatar
    Join Date
    Apr 2009
    Location
    Sunderland, Tyne and Wear
    Posts
    788
    Thank Post
    163
    Thanked 77 Times in 66 Posts
    Rep Power
    47
    Either change the security on desktop.ini to prevent changes or delete it atlogon/logoff using your logon/logoff scripts.

  4. #4

    garethedmondson's Avatar
    Join Date
    Oct 2008
    Location
    Gowerton, Swansea
    Posts
    2,260
    Thank Post
    965
    Thanked 324 Times in 192 Posts
    Blog Entries
    11
    Rep Power
    164
    Quote Originally Posted by DAZZD88 View Post
    Either change the security on desktop.ini to prevent changes or delete it atlogon/logoff using your logon/logoff scripts.
    +1 for the deleting method. We have a script here that does it for us. Works fine.

    Gareth

  5. #5


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,591
    Thank Post
    228
    Thanked 856 Times in 735 Posts
    Rep Power
    296
    if you have server 03 or above enable the feature file server resource manager then create a rule for your user folders say d:\users that blocks the creation of the desktop.ini file

  6. Thanks to sted from:

    plexer (31st October 2011)

  7. #6

    Join Date
    Nov 2009
    Location
    Manchester
    Posts
    1,054
    Thank Post
    6
    Thanked 201 Times in 181 Posts
    Rep Power
    52
    I agree with Sted, it is by far the best way.

  8. #7
    kennysarmy's Avatar
    Join Date
    Oct 2005
    Location
    UK
    Posts
    1,286
    Thank Post
    80
    Thanked 45 Times in 31 Posts
    Rep Power
    31
    We use the resource manager to block saving of the file....

  9. #8

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    Have a look towards the bottom of post #5 here. No scripts or modifying files or anything like that required

  10. #9

    Join Date
    Nov 2007
    Location
    Rotherham
    Posts
    1,678
    Thank Post
    122
    Thanked 126 Times in 102 Posts
    Rep Power
    45
    I had that. The problem is that if you use FSRM to block access tI desktop.ini to then can't have it email to every time a file violation occurs when students try and create bat files on the network as it email to every time the system tries to edit desktop.ini

    I am just in the process of testing a modified folder structure. All my users documents will be saved in a folder \\servername\users\username\documents. This will then let me put more folders under \\servername\users\username\ such as favourites, and redirect them and store them in one place. It then won't matter if windows renames the documents folder.

  11. #10
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,456
    Thank Post
    10
    Thanked 494 Times in 434 Posts
    Rep Power
    112
    You shouldn't block desktop.ini, folder redirection at logon will take considerably longer if it doesn't exist or can't be created.

    You should fix the underlying issue and redirect documents (and anything else relevant) as a subfolder of the users home folder.

  12. Thanks to DMcCoy from:

    RabbieBurns (1st November 2011)

  13. #11

    Join Date
    Feb 2008
    Posts
    43
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I agree with DMcCoy

    Quote Originally Posted by DMcCoy View Post
    You shouldn't block desktop.ini, folder redirection at logon will take considerably longer if it doesn't exist or can't be created.

    You should fix the underlying issue and redirect documents (and anything else relevant) as a subfolder of the users home folder.

  14. #12
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,475
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52
    HI Everyone

    Thanks for the comments

    I am trying the delete the desktop.ini route first like below. I have checked the log on after the policy is applied and its about a second slower which I can live with.

    These are the setting I am tryingdesktopinipolicy.jpg

    delete desktop ini
    Data collected on: 01/11/2011 10:29:39 hide all

    Generalhide
    Detailshide
    Domain BALSHAWSCURRIC.LOCAL
    Owner BALSHAWSCURRIC\Domain Admins
    Created 31/10/2011 14:07:22
    Modified 01/11/2011 07:26:04
    User Revisions 16 (AD), 16 (sysvol)
    Computer Revisions 0 (AD), 0 (sysvol)
    Unique ID {CDE22031-2DED-491E-ACA6-EC0CB1029740}
    GPO Status Enabled

    Linkshide
    Location Enforced Link Status Path
    Staff No Enabled BALSHAWSCURRIC.LOCAL/Balshaw CE High School/Staff
    delete desktop ini No Disabled BALSHAWSCURRIC.LOCAL/Balshaw CE High School/Staff/delete desktop ini
    Students No Enabled BALSHAWSCURRIC.LOCAL/Balshaw CE High School/Students

    This list only includes links in the domain of the GPO.
    Security Filteringhide
    The settings in this GPO can only apply to the following groups, users, and computers:Name
    NT AUTHORITY\Authenticated Users

    Delegationhide
    These groups and users have the specified permission for this GPOName Allowed Permissions Inherited
    BALSHAWSCURRIC\Domain Admins Edit settings, delete, modify security No
    BALSHAWSCURRIC\Enterprise Admins Edit settings, delete, modify security No
    NT AUTHORITY\Authenticated Users Read (from Security Filtering) No
    NT AUTHORITY\ENTERPRISE DOMAIN CONTROLLERS Read No
    NT AUTHORITY\SYSTEM Edit settings, delete, modify security No

    Computer Configuration (Enabled)hide
    No settings defined.
    User Configuration (Enabled)hide
    Preferenceshide
    Windows Settingshide
    Fileshide
    File (Target Path: h:\desktop.ini)hide
    desktop.ini (Order: 1)hide
    Generalhide
    Action Delete
    PropertiesDestination file h:\desktop.ini
    Suppress errors on individual file actions Enabled
    AttributesRead-only Enabled
    Hidden Disabled
    Archive Disabled

    Commonhide
    OptionsStop processing items on this extension if an error occurs on this item No
    Run in logged-on user's security context (user policy option) Yes
    Apply once and do not reapply No
    DescriptionDelete the desktop ini file so that my documents does not appear as the name of users home folder on userserver


    Richard

  15. #13
    falko12's Avatar
    Join Date
    Mar 2011
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi i used this at my school a while ago, it was taken from a thread on here but i do not have the link.. (may have been in server 2008 forum)

    1. Navigate to the folder where the students directories are located e.g. \\dms-fs-02\ict$\07


    2. Right click in the column 'Size' then select 'More...' at the bottom of the list


    3. Select 'Filename' in the list, then click OK. The username will now be displayed


    now to make this view the default folder view for all your folders:

    1. complete the 3 steps above
    2. Press Alt to display the menu bar. Click Tools -> Folder options.
    3. Click View tab.
    4. Press the "Apply to folders" button.
    5. Click Apply and click OK.


    Nathan

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 38
    Last Post: 9th August 2012, 10:37 PM
  2. my documents renamed in windows 7
    By Frut02 in forum Windows 7
    Replies: 10
    Last Post: 11th October 2011, 11:33 AM
  3. synchronising My Documents in Windows 7
    By ClaireJoanne in forum Windows 7
    Replies: 1
    Last Post: 12th September 2011, 08:21 PM
  4. Windows crashes whenever I open My Documents
    By marsdenprimary in forum Windows
    Replies: 6
    Last Post: 29th September 2010, 11:44 AM
  5. Replies: 10
    Last Post: 14th August 2007, 07:03 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •