+ Post New Thread
Results 1 to 12 of 12
Windows 7 Thread, Power Management on Windows 7 in Technical; I've created some GPOs which set customised power management settings, but I can't get them to work. Two problems - ...
  1. #1
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,452
    Thank Post
    278
    Thanked 196 Times in 167 Posts
    Rep Power
    75

    Power Management on Windows 7

    I've created some GPOs which set customised power management settings, but I can't get them to work. Two problems - one is that the Power Plan won't become the default even when I tell it to, and the other is that the PCs don't hibernate. They did under XP (sometimes), so it isn't a hardware or BIOS problem. The monitors turn off as scheduled, so I don't think there is some other process stopping the PC from idling long enough for the Power Plan to kick in.

    Suggestions?

  2. #2

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,684
    Thank Post
    823
    Thanked 2,570 Times in 2,187 Posts
    Blog Entries
    9
    Rep Power
    731
    Machine or user config, works alright for me under machine policies here so don't have any experience troublshooting it. Run a gpupdate /force and then check the event logs thoroughly. Maybe look in the mmc.exe > Resultant Set of Policy snapin.

  3. #3

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    If you've used Power Options under GPP, make sure 'Set as the active power plan' is ticked on your power plan.

  4. #4
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,452
    Thank Post
    278
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    These are machine policies - gpresult/r says they've applied, and monitor time-outs happen, but the sleep/hibernate does not. I'll have a look in Event Viewer to see if there's anything helpful in there.

    I have tried that Michael, but for some reason it doesn't work - the policy gets added just fine, but "Balanced (recommended)" is still enabled. I also tried changing the "Balanced" one, but my changes didn't get applied.

  5. #5

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    Try this:

    Computer Config > Policies > Admin Templates > System > Power Management

    In the root here, you should see: Select an Active Power Plan. You could try enabling this.

  6. Thanks to Michael from:

    enjay (31st October 2011)

  7. #6

    Join Date
    Mar 2010
    Location
    Orlando, FL, USA
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Can't tell from your description of the problem, but you might want to check to see if your NIC is set to "Allow this device to wake the computer." I created a new image for our Optiplex 755's and I forgot to uncheck this box. As a result no matter how much I fiddled with the Power Management GPO, they wouldn't stay asleep until I cleared that checkbox on each machine.

  8. #7
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,452
    Thank Post
    278
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    @dobrien - how would disabling the wake-on-LAN setting affect whether or not a PC enters hibernate?

  9. #8
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,452
    Thank Post
    278
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    @Michael - I've changed that setting, but it is hard to say if it has taken effect or not, since I know can't see the Power Settings within Control Panel. I'll leave the computers a little while and hopefully that will tell me if it has worked.

    Whilst in that bit of Group Policy, I noticed that I can actually use it to govern most of the power settings which I've been trying to apply via a Power Plan. Would that be a better way of doing it, or is it just a different way to set the same thing?

  10. #9

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,684
    Thank Post
    823
    Thanked 2,570 Times in 2,187 Posts
    Blog Entries
    9
    Rep Power
    731
    Quote Originally Posted by enjay View Post
    Whilst in that bit of Group Policy, I noticed that I can actually use it to govern most of the power settings which I've been trying to apply via a Power Plan. Would that be a better way of doing it, or is it just a different way to set the same thing?
    I thought that was the bit that you were using, that is how we configured it and it worked first time.

  11. Thanks to SYNACK from:

    enjay (31st October 2011)

  12. #10
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,452
    Thank Post
    278
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    No, I was using Computer Config > Preferences > Control Panel Settings > Power Options to add a new Power Plan. I'll give your method a whirl instead...

  13. #11
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,452
    Thank Post
    278
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    @synack - thanks, that is working a treat - the PC now hibernates exactly how I want it to.

    Next one is how (if?) I can assign different Policies to different PCs within the same OU container, e.g. we have a container called "IT Suite 1", and I want most of the PCs to have the default power settings, but the PC on the projector to have longer time-outs. Is that achievable, or should I just set everything on the longer time-outs?

  14. #12

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,684
    Thank Post
    823
    Thanked 2,570 Times in 2,187 Posts
    Blog Entries
    9
    Rep Power
    731
    Quote Originally Posted by enjay View Post
    @synack - thanks, that is working a treat - the PC now hibernates exactly how I want it to.

    Next one is how (if?) I can assign different Policies to different PCs within the same OU container, e.g. we have a container called "IT Suite 1", and I want most of the PCs to have the default power settings, but the PC on the projector to have longer time-outs. Is that achievable, or should I just set everything on the longer time-outs?
    you could use wmi filtering on the gpo with the computer name to not apply the policy to certain machines and the inverse filter to aply a longer timeout. You can also use gpo level security to deny acces to the policy to certain machines.

SHARE:
+ Post New Thread

Similar Threads

  1. Performance manager on windows 2003
    By ranj in forum Windows
    Replies: 1
    Last Post: 31st January 2007, 11:52 AM
  2. Quota Management in Windows 2003 R2
    By wesleyw in forum Windows
    Replies: 0
    Last Post: 5th September 2006, 10:06 AM
  3. Setting DHCP Vendor Classes on Windows 2003 Server
    By acb_ in forum How do you do....it?
    Replies: 13
    Last Post: 17th July 2006, 11:19 AM
  4. Replies: 7
    Last Post: 24th May 2006, 02:16 PM
  5. Power Settings on Logon Screen
    By mattpant in forum Windows
    Replies: 19
    Last Post: 15th September 2005, 07:30 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •