I am in the process of setting up my windows 7 GPO's. I have followed this

How to remove Windows 7 libraries, homegroup & network etc from explorer
Credit to EJWill for the ADM and solution
In Windows 7 microsoft added a few new explorer/my computer categories such as Libraries and Homegroup. If you want to disable these there is not many easy ways but here are some tips/steps that can remove the links you dont need.

The solution:
From Post:

Using Windows 7 with Group Policy Management installed or a 2008 Server. Navigate too:

User Configuration/Policies/Administrative Templates/Windows Components/Windows Explorer/

Enable Disable Known Folders and add the following:

{2112AB0A-C86A-4ffe-A368-0DE96E47012E} - Music Library
{491E922F-5643-4af4-A7EB-4E7A138D8174} - Videos Library
{7b0db17d-9cd2-4a93-9733-46cc89022e7c} - Documents Library
{A302545D-DEFF-464b-ABE8-61C8648D939B} - User Libraries Folder
{A990AE9F-A03B-4e80-94BC-9912D7504104} - Pictures Library
{031E4825-7B94-4dc3-B131-E946B44C8DD5} - Another reference to User Library

I have disabled the known folders and have a problem when trying to save I get an error. How would I go about re enabling these. I have removed them from the GPO and even tried disabling the function. Nothing has worked. I don't really want to have to recreate the GPO.

Thanks