+ Post New Thread
Results 1 to 3 of 3
Windows 7 Thread, Windows 7 64 bit file association problems (office 2007) in Technical; Hi all, ive just deployed 30 brand new machines in one of our IT suites pre installed with windows 7 ...
  1. #1

    Join Date
    Jun 2011
    Location
    United Kingdom
    Posts
    39
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Windows 7 64 bit file association problems (office 2007)

    Hi all, ive just deployed 30 brand new machines in one of our IT suites pre installed with windows 7 64bit. Now the problem I have is each a time a user logs on to the network I have to associtae file types so that they open in the correct program, this tends to happen with office 2007 documents. The problem is I dont mind doing it once on each machine, setting default programs, eg docx to be opened in word and so on. The problem is every user who logs on hasa problem where it doesnt recognise the default program to open the file. I've set it once logged in as administrator but it doesnt apply to every user who logs on to the machine.

    Any advice as school starts Monday grrrrrr!

    Regards

  2. #2

    ZeroHour's Avatar
    Join Date
    Dec 2005
    Location
    Edinburgh, Scotland
    Posts
    5,643
    Thank Post
    895
    Thanked 1,314 Times in 798 Posts
    Blog Entries
    1
    Rep Power
    444
    GPP can do file associations as a interim fix. You can define the prefence in the users OU under group policy preferences->user->Files I think.

  3. #3

    Join Date
    Jun 2011
    Location
    United Kingdom
    Posts
    39
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    After browsing many forums the only solution that seems to work is this one. I'm going to try it tomorrow. Hopefully it'll work for all users who log on if I do this logged in as local admin



    The program that you're pointing to isn't registered correctly.

    In regedit: Navigate to*Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name.*
    Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and reassociate the file type as you normally would.

    Let me know if that doesn't seem to work.


    Hope this helps anyone else

SHARE:
+ Post New Thread

Similar Threads

  1. Exchange 2007 tools - for windows 7 64 bit
    By mattx in forum Windows 7
    Replies: 4
    Last Post: 17th April 2011, 09:59 PM
  2. Replies: 0
    Last Post: 25th November 2010, 12:25 PM
  3. Samsung Galaxy Portal Drivers - Windows & 64-Bit
    By gtg93 in forum Netbooks, PDA and Phones
    Replies: 0
    Last Post: 12th May 2010, 10:59 AM
  4. RM CC3 file association for office 2003
    By graywoodford in forum Network and Classroom Management
    Replies: 2
    Last Post: 22nd January 2010, 10:27 AM
  5. Office 2007 file convertors
    By dezt in forum Downloads
    Replies: 10
    Last Post: 5th May 2007, 02:40 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •