+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 20 of 20
Windows 7 Thread, Libraries and Public Folder in Technical; Right guys ive cracked it ! This is how to lock them down and this is reliant upon you not ...
  1. #16

    Join Date
    Aug 2009
    Posts
    76
    Thank Post
    2
    Thanked 9 Times in 5 Posts
    Rep Power
    12
    Right guys ive cracked it !

    This is how to lock them down and this is reliant upon you not wanting to keep any user manually setup libraries.

    1. Log on as a user, remove the public folders from all 4 standard Libraries, and untick "show in navigation pane"

    2. Copy these 4 XML files to a network location \\server\share\

    3 Use Group policy preferences (File) to:
    delete any .library-ms from %appdata%\Microsoft\Windows\Libraries
    replace \\server\share\(all for four library XML files) to %appdata%\Microsoft\Windows\Libraries
    making sure you set the file attribute to read only

    4. Set the Policy "Prevent users from adding files to the root of their Users Files folder"

    What will happen is, when the user logs on all the library files are deleted from the users profile and replaced with the set ones from the server share without the public path (just incase) and then made hidden, when the users goes the libraries they appear empty and when they right click and say New > Library they get a file error due to the policy not allowing new files. So they cannot config the Libraries as they are hidden so relies also on locking down your Folder Options.

    If you do not have 2008 server, you can do this with batch scripts to delete and copy over the files and then using the attrib command as per below:

    @echo off
    %systemdrive%
    cd\
    cd %appdata%\Microsoft\Windows\Libraries
    attrib +h Pictures.library-ms
    attrib +h music.library-ms
    attrib +h videos.library-ms
    attrib +h documents.library-ms
    attrib +h *.library-ms

    Hope this helps someone out and glad we now have a way of doing this, as it keeps the files intact so programs can access them if needed, as i know WMP12 has issues if you delete or disable the libraries.

    Cheers

    Scorps

  2. #17

    Join Date
    Sep 2007
    Posts
    90
    Thank Post
    7
    Thanked 32 Times in 17 Posts
    Rep Power
    20
    We took a different approach. Instead of disabling public folders and/or removing libraries, we
    redirect the "Public documents" (and Common pictures, movies, etc...) folder to our Shared drive, much the same as redirecting My documents to their network home share.
    This way we have the best of both:

    • You get to keep the libraries functionality for both "My documents" and "Public documents"
    • You get to keep the "Public documents" functionality, except it's now on the network Shared area.

  3. #18
    DaveCoop's Avatar
    Join Date
    Feb 2009
    Posts
    85
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    12
    Quote Originally Posted by Scorpio View Post
    Hiding them will be ok, trouble is it always throws you into the lib folder when saving in certain apps.
    Has anyone got any further on this one! no point in hiding as the little darlings are trying to save to desktop when its says you need permission windows gives them the option to save to c:\users Nice!!!!! try it open notepad save the file as cmd to desktop annoying to say the least

  4. #19

    fiza's Avatar
    Join Date
    Dec 2008
    Location
    London
    Posts
    2,223
    Thank Post
    446
    Thanked 319 Times in 270 Posts
    Rep Power
    153
    Why is this so difficult? Why have Microsoft forgotten about Domain Admins? All I want is that when a user clicks to save it goes to their home drive. I've managed to redirect my docs to the server but the library location still shows 2 locations. 1 for the server and 1 local. I DONT WANT the local.

    Has anyone resolved this? I have managed to hide Libraries with a custom GPO found on Edugeek.

    BUT when I open Notepad and then click "save as" I still get "Documents Library" appear with the obligatory "some library features are unavailable due to unsupported library locations". It still shows 2 locations. 1 is the users Home Drive and the other is Public Documents on C drive!!!!

    Can someone please tell me how to resolve this?

  5. #20

    Miscbrah's Avatar
    Join Date
    Dec 2011
    Posts
    972
    Thank Post
    273
    Thanked 283 Times in 169 Posts
    Rep Power
    119
    Hi - hope I'm not too late to the party! I knocked up a guide a little while back, be keen to see it tried out and see if it solves any problems for anyone! I know these threads actually come up on Google and I learned how to do this here on Edugeek, so spreading the love.

    If the guide's any good/sucks let me know.

    Linky.

  6. 2 Thanks to Miscbrah:

    fiza (13th June 2012), jenking (22nd June 2012)

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 1
    Last Post: 14th January 2010, 02:34 PM
  2. Folder Redirection and Public Desktop
    By Willott in forum Windows
    Replies: 10
    Last Post: 16th July 2009, 11:20 AM
  3. Cannot Write to Public Folder
    By GaryCantley in forum How do you do....it?
    Replies: 6
    Last Post: 24th June 2009, 01:30 PM
  4. PDA with public folder support
    By kevin in forum Hardware
    Replies: 1
    Last Post: 26th June 2007, 01:54 PM
  5. Viewing a Contact Public Folder in OWA
    By faza in forum Wireless Networks
    Replies: 3
    Last Post: 4th July 2006, 05:43 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •