+ Post New Thread
Results 1 to 6 of 6
Windows 7 Thread, Windows 7 - Group Policy Deployment of Printers in Technical; Afternoon all, Got a problem with printers being deployed through group policy. We're running a windows server 2008 environment with ...
  1. #1

    Join Date
    Feb 2007
    Location
    Stockport
    Posts
    876
    Thank Post
    264
    Thanked 113 Times in 85 Posts
    Rep Power
    40

    Windows 7 - Group Policy Deployment of Printers

    Afternoon all,

    Got a problem with printers being deployed through group policy.

    We're running a windows server 2008 environment with most of our clients running Windows 7 (having upgraded from Vista in the summer).

    All our networked printers are deployed using group policy and under Vista this seemed to work fine.

    Since we upgraded to 7, we've been experiencing problems in that for some machines the group policy will run fine and allow people to use the printer and for others it won't.

    I've checked a few things on one client where the policy deploys fine and on one where it doesn't, and they both seem to have the same group policies applying to them (on the report I've produced for both machines, neither makes reference to the printer policy). My only guess is that the policy is not being called correctly, but I don't know how to resolve this.

    Has anyone come across this before? Does anyone have a solution?

    Many thanks in advance.

  2. #2

    Join Date
    Jan 2009
    Location
    England
    Posts
    1,406
    Thank Post
    304
    Thanked 304 Times in 263 Posts
    Rep Power
    82
    We've had some fun times with W7 and deploying printers. After eventually getting GPP to deploy printers we found that some machines wouldn't deploy some printers at all - despite deploying other printers in the same policy. That issue seems to have resolved its self, but now we've got a weird issue where printers will disappear part way through a users session.

    I suspect its something to do with Win 7 - DHCP/Netlogon/Firewall - Microsoft Confirm a Bug, and printers to reapplying correctly when updated by GPP as we're getting all of the same error messages.

  3. Thanks to Soulfish from:

    Iain.Faulkner (24th September 2010)

  4. #3
    BryanDavidWilliams's Avatar
    Join Date
    Jan 2010
    Location
    Arizona
    Posts
    13
    Thank Post
    4
    Thanked 1 Time in 1 Post
    Rep Power
    0
    We have had decent success deploying printers with a mix of the Print Management Console and then updating default settings with group policy on the GPO server. We have some issues with printers not updating when switching between OUs. For some reason it will retain old OU settings even after moved and a gpupdate /force has been run. I can look at the gpupdate /result and see that they should not be there. Confusing but we never switch OU's with out a re-image so it has worked well for us so far.

    Printers will never work right between the MS print team who can barely get versions of their own software out in cycle with OS and SP releases and HP's Driver issues I give up on the perfect print solution.

  5. Thanks to BryanDavidWilliams from:

    Iain.Faulkner (24th September 2010)

  6. #4

    Join Date
    Mar 2008
    Posts
    5
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    We had the exact same problem. This fixed it. Microsoft KB976399.

  7. Thanks to hcrejazz from:

    Iain.Faulkner (24th September 2010)

  8. #5

    Join Date
    Feb 2007
    Location
    Stockport
    Posts
    876
    Thank Post
    264
    Thanked 113 Times in 85 Posts
    Rep Power
    40
    thanks hcrejazz, I'll give that a go :-)

  9. #6

    Join Date
    Feb 2007
    Location
    Stockport
    Posts
    876
    Thank Post
    264
    Thanked 113 Times in 85 Posts
    Rep Power
    40
    Nope, still the same :-(

SHARE:
+ Post New Thread

Similar Threads

  1. Removing printers deployed by group policy
    By FN-GM in forum Windows
    Replies: 15
    Last Post: 8th October 2011, 11:53 AM
  2. Deploying printers with group policy problems
    By jlucas in forum Windows Server 2008 R2
    Replies: 2
    Last Post: 15th June 2010, 04:01 PM
  3. Group policy assigned printers problem
    By mrbios in forum Windows 7
    Replies: 6
    Last Post: 1st April 2010, 03:32 PM
  4. Deploying printers via group policy
    By Southwell in forum Windows
    Replies: 16
    Last Post: 7th December 2007, 12:28 PM
  5. Question about Group Policy software deployment
    By sidewinder in forum Windows
    Replies: 9
    Last Post: 5th December 2007, 04:35 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •