+ Post New Thread
Page 3 of 5 FirstFirst 12345 LastLast
Results 31 to 45 of 71
Windows 7 Thread, Windows 7 - I've Given Up in Technical; Originally Posted by Silverman Does anybody have an editted authui.dll file they could share to change the user account image ...
  1. #31

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,659
    Thank Post
    858
    Thanked 646 Times in 429 Posts
    Rep Power
    498
    Quote Originally Posted by Silverman View Post
    Does anybody have an editted authui.dll file they could share to change the user account image from an empty frame to a desired logo.

    I have tried editting many of the BMPs within this dll but all I have managed to do is change the colour of this empty frame.

    Would be a massive help if somebody has changed this and could share.

    Thanks.
    Doesn't that break the EULA?

  2. #32


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,877
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    Quote Originally Posted by Silverman View Post
    Does anybody have an edited authui.dll file they could share to change the user account image from an empty frame to a desired logo.
    From what I have read, there are a couple of things you need to do to get a logo displayed instead of the empty frame.

    1) Edit bitmap 12223 in authui.dll i.e. export original picture, edit it to include your logo (128x128 pixels) in the middle of the frame, import it and then save (overwriting the original authui.dll).
    2) Make sure the DontDisplayLastName registry key is set to 1 or the "Do not display last user name" GPO is enabled.

  3. #33

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,756
    Thank Post
    3,265
    Thanked 1,052 Times in 973 Posts
    Rep Power
    365
    Quote Originally Posted by Arthur View Post
    From what I have read, there are a couple of things you need to do to get a logo displayed instead of the empty frame.

    1) Edit bitmap 12223 in authui.dll i.e. export original picture, edit it to include your logo (128x128 pixels) in the middle of the frame, import it and then save (overwriting the original authui.dll).
    2) Make sure the DontDisplayLastName registry key is set to 1 or the "Do not display last user name" GPO is enabled.
    using resource hacker I presume ?

  4. #34


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,877
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    You can do. I used to use Resource Hacker, but recently came across ResEdit which I think is even better.

    There's also XN Resource Editor, Resource Tuner and PE Explorer. Although the last two are not free, they do have several really useful features, such as automatic UPX unpacking and the ability to create application manifests.

    For editing the Windows 7 logon screen, I also found the following links quite useful.

    Windows 7 Logon Editing Guide
    Logon Workshop
    Logon Editor

  5. #35
    Silverman's Avatar
    Join Date
    Oct 2007
    Location
    Worksop, Nottinghamshire
    Posts
    50
    Thank Post
    15
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Arthur View Post
    From what I have read, there are a couple of things you need to do to get a logo displayed instead of the empty frame.

    1) Edit bitmap 12223 in authui.dll i.e. export original picture, edit it to include your logo (128x128 pixels) in the middle of the frame, import it and then save (overwriting the original authui.dll).
    2) Make sure the DontDisplayLastName registry key is set to 1 or the "Do not display last user name" GPO is enabled.
    This is one of the files that I have tried editting but it is as if whatever I put into the middle of the frame is transparent, the only changes that show are edits I make to the actual frame.
    It appears some people have changed this file successfully though which is why I wanted to see a copy of one that has been changed and works.

  6. #36


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,877
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    Did you set that registry entry too? This is key to getting the logo to appear when no one is logged on.

  7. #37

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,659
    Thank Post
    858
    Thanked 646 Times in 429 Posts
    Rep Power
    498
    As i have already said - surely using RegHack, et al to modify an original DLL is in breach of the EULA, and as such I dont think its wise for us to be advertising that fact...

  8. #38
    Silverman's Avatar
    Join Date
    Oct 2007
    Location
    Worksop, Nottinghamshire
    Posts
    50
    Thank Post
    15
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yeah I have that done via GPO, this is what removes the 'Switch User' feature and enables the more classic style login. But at the same time makes this frame appear empty. Seems like a silly feature of Microsoft, I would much prefer to have no frame there or our school logo in the frame but am getting no where with it.

    Quote Originally Posted by Gatt View Post
    As i have already said - surely using RegHack, et al to modify an original DLL is in breach of the EULA, and as such I dont think its wise for us to be advertising that fact...
    Any other ideas about what to do with empty frame? It just looks sloppy and untidy on all the login screens, at the moment I am just leaving it as is as I cannot get this DLL working but I'm interested in what other people have done about it.
    Last edited by Silverman; 14th July 2010 at 08:55 AM.

  9. #39


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    8,877
    Thank Post
    226
    Thanked 2,669 Times in 1,968 Posts
    Rep Power
    786
    Quote Originally Posted by Gatt View Post
    As i have already said - surely using RegHack, et al to modify an original DLL is in breach of the EULA, and as such I dont think its wise for us to be advertising that fact...
    Not sure TBH. Does replacing a single bitmap in a DLL really count as decompiling or disassembling?

  10. #40
    chrbb's Avatar
    Join Date
    Oct 2005
    Location
    Midlands
    Posts
    1,507
    Thank Post
    141
    Thanked 67 Times in 62 Posts
    Rep Power
    46
    Right finally installed and set up my laptops how i want them, all software installed and working (although I'm on 32 bit which I think is more old software friendly), even abacus evolve, starspell, science explorer and microsmile - it's taken an absolute age to get it right! Only had three to do so set them up individually as I didn't want a clone to wrong disk situation.

    No luck with the background, although oddly enough when I tested kartouche, the display reverted to some sort of basic display and the background set by gpo showed until i logged off.

  11. #41


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,588
    Thank Post
    228
    Thanked 856 Times in 735 Posts
    Rep Power
    296
    is the logo you are trying to display and what format? as its not given me any issues even picks it up from an xp user policy for me just a std jpg on server \\server\wherever\i\putit.jpg

  12. #42
    chrbb's Avatar
    Join Date
    Oct 2005
    Location
    Midlands
    Posts
    1,507
    Thank Post
    141
    Thanked 67 Times in 62 Posts
    Rep Power
    46
    Just a standard jpeg, stored on server 2003, works with xp pro, the gpo is working as the background is shown briefly before log off. Is your background being shown without changing anything on the windows 7 computer? I haven't set up rsat.

  13. #43


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,588
    Thank Post
    228
    Thanked 856 Times in 735 Posts
    Rep Power
    296
    Quote Originally Posted by chrbb View Post
    Just a standard jpeg, stored on server 2003, works with xp pro, the gpo is working as the background is shown briefly before log off. Is your background being shown without changing anything on the windows 7 computer? I haven't set up rsat.
    its the same policy that i apply to users with xp yes

  14. #44
    chrbb's Avatar
    Join Date
    Oct 2005
    Location
    Midlands
    Posts
    1,507
    Thank Post
    141
    Thanked 67 Times in 62 Posts
    Rep Power
    46
    So why isn't mine working then, really fed up now! Did you have to alter anything on windows 7?

  15. #45


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,588
    Thank Post
    228
    Thanked 856 Times in 735 Posts
    Rep Power
    296
    Quote Originally Posted by chrbb View Post
    So why isn't mine working then, really fed up now! Did you have to alter anything on windows 7?
    nope i wasnt expecting it to work and diddnt think to change it it just worked

SHARE:
+ Post New Thread
Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Replies: 4
    Last Post: 19th March 2012, 08:58 AM
  2. Replies: 4
    Last Post: 26th May 2010, 05:29 PM
  3. Replies: 0
    Last Post: 4th September 2009, 12:48 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •