+ Post New Thread
Results 1 to 14 of 14
Windows 7 Thread, Folder Redirection / Roaming User Profiles in Technical; Hi, Been trying for a couple of days now to get folder redirection working on Windows 7. Currently works with ...
  1. #1

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27

    Folder Redirection / Roaming User Profiles

    Hi,

    Been trying for a couple of days now to get folder redirection working on Windows 7. Currently works with no issues on Windows XP and Vista. However creating a new user and performing the first log on in Windows 7 has issues with Profiles and Redirection.

    I have tested redirection in the following manner -

    Create a New OU in AD
    Block Inheritance to this new OU
    Create a single Group Policy Object, defining only Folder Redirection
    Create an account in the new OU
    Define the Profile path and Home Drive as current users are set up
    AND
    Define the Profile Path and Home Drive as new areas on a new share (even tested with Everyone - Full Access on share and NTFS permissions)

    When logging in it does not work as it should.

    However if i log into a machine running Vista, then log out and back into Windows 7, there are no issues at all! Windows 7 cannot create the profile properly perhaps? As i have seen issues where the users roaming profile has confused folder redirection (Points it at C:\Users\%username%) and deleting the users profile has solved the issue.

    Either way, profile is created and populated, redirection creates the areas on the home share, however cannot map them properly

    Anyone had this issue and conquered it?

    Many thanks,
    Psy

  2. #2

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27
    Strangely enough Event Viewer suggests the redirection was successful, however when checking the path of the folders they point to C:\Users\username

    Psy

  3. #3

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27
    Strange one.

    Logged into Vista with my newly created home drive area and profile area. Everything worked as intended, redirection took care of everything, and the user profile uploaded only the ntuser and appdata folder.

    When i then logged into Windows 7 with this account, folder redirection DID NOT work, and the user profile uploaded the folders for Music, Docs, Videos etc...

    Folder redirection is not applying to Windows 7 at all

    Psy

  4. #4

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27
    Thought i had it solved but after deleting the profile to test a fresh first time logon back to square 1.


  5. #5

    Join Date
    Mar 2010
    Location
    Adelaide
    Posts
    133
    Thank Post
    2
    Thanked 19 Times in 17 Posts
    Rep Power
    12
    I have seen different results with the Grant user exclusive rights option, if you have it enabled try setting it to disabled.

  6. #6

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27
    Tried both with no luck unfortunately. I am confused as to why it works perfectly fine in Vista, yet not in 7.

    I have got it to the point where logging into a Windows 7 machine creates a user profile, and "Applying Folder Redirection..." creates the folders on the network share.

    However when i go to the users folder on the start menu / desktop all of the shortcuts for Docs, Pics, Music, Downloads point to C:\Users\

    Been looking at this for 2 days now

    Psy

  7. #7

    Join Date
    Mar 2010
    Location
    Adelaide
    Posts
    133
    Thank Post
    2
    Thanked 19 Times in 17 Posts
    Rep Power
    12
    Sorry for the delay, this is a weird one for sure. If it was me I would create a new GPO incase the error is with the object (rare but happens). For testing I also would not use home folders at all as this is against Microsoft best practice. There is also a GPO for having logon wait until the network is ready, enable this.

  8. #8

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27
    I have already created a new GPO with only the folder redirection settings defined after it wouldnt work on the production network.

    I have also played with the settings in the System\Folder Redirection and System\Group Policy with no luck.

    Psy

  9. #9

    Join Date
    Mar 2010
    Location
    Adelaide
    Posts
    133
    Thank Post
    2
    Thanked 19 Times in 17 Posts
    Rep Power
    12
    The Windows 7 user is local user or a roaming/mandatory user?

  10. #10

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27
    Quote Originally Posted by _Adam_ View Post
    The Windows 7 user is local user or a roaming/mandatory user?
    Roaming Users.

    Cheers,
    Psy

  11. #11

    Join Date
    Mar 2010
    Location
    Adelaide
    Posts
    133
    Thank Post
    2
    Thanked 19 Times in 17 Posts
    Rep Power
    12
    Long shot but I have seen the Current User settings in ntuser.dat overwrite the GPO settings on Win 7 boxes. A quick test is in the account remove the profile path to make it a local user (and it will copy the default profile) and log onto a clean machine or delete the cached profile first if you previously logged in with that account.

    If it works as it should you will need to delete the folder paths out from the registry.

  12. #12

    Join Date
    Aug 2007
    Location
    Deal, Kent
    Posts
    343
    Thank Post
    12
    Thanked 73 Times in 51 Posts
    Rep Power
    27
    Just had a go at local profiles with no luck.

    For some reason Event Viewer shows no problems at all, all folder redirection events are successful.

    Every now and then "Contacts" and "Searches" work, but nothing else.

    Psy

  13. #13

    Join Date
    Mar 2010
    Location
    Adelaide
    Posts
    133
    Thank Post
    2
    Thanked 19 Times in 17 Posts
    Rep Power
    12
    At the end of the road here, only so much I can think of without having the environment in front of me. Last ditch woulld be to boot up the 7 box in Safe Mode with Networking or use MSCONFIG to disable all non-MS services and startup programs to ensure a third party app is not mis-behaving. Failing this I would even try a clean 7 image (no patches or any other programs). Since Vista is working my hunch is something on the 7 image is at fault.

  14. #14

    Join Date
    Feb 2010
    Location
    NY
    Posts
    5
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Try and delete the local user folders. Redirection should work then.

    You might want to delete the local user folders on login.

SHARE:
+ Post New Thread

Similar Threads

  1. Mandatory Profiles Home folder redirection
    By Chris_Jones in forum Windows
    Replies: 10
    Last Post: 24th November 2008, 04:04 PM
  2. No access to roaming profiles folder
    By MK-2 in forum Windows
    Replies: 6
    Last Post: 17th October 2008, 01:30 PM
  3. Roaming Profiles and folder Exclusion
    By placky in forum Windows
    Replies: 1
    Last Post: 13th March 2008, 06:15 PM
  4. Replies: 11
    Last Post: 1st November 2007, 08:02 PM
  5. Replies: 8
    Last Post: 30th October 2007, 02:13 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •