+ Post New Thread
Results 1 to 6 of 6
Windows 7 Thread, Wake-on-LAN with Windows 7 in Technical; The Windows 7 PC in my office doesn't respond to the WOL signals which go out. Since the connectivity light ...
  1. #1
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,488
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76

    Wake-on-LAN with Windows 7

    The Windows 7 PC in my office doesn't respond to the WOL signals which go out. Since the connectivity light on the switch goes out when the PC is off, I'm guessing this is a power management feature, although it worked fine with XP and Vista on this PC. This isn't an issue for just one PC in my office, however could present problems on other PCs around the school. Does anyone know how to use WOL with Windows 7?

  2. #2

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,600
    Thank Post
    109
    Thanked 769 Times in 598 Posts
    Rep Power
    181
    I've also noticed that power management defaults on Windows 7 seem to turn off networking in standby (and I guess 'off') power modes.

    I think it's probably the PCI Express settings that do it... these can be found under 'Advanced' in the Power Management settings. I'm going to go out on a limb and suggest that these can also be changed via a GPO.

  3. #3
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,488
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76
    Quote Originally Posted by Ric_ View Post
    I think it's probably the PCI Express settings that do it... these can be found under 'Advanced' in the Power Management settings.
    PCI Express - Link State Power Management: currently set to "moderate power savings", other options are "maximum power savings" and "off". Is that the bit you mean?

  4. #4

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,212 Times in 761 Posts
    Rep Power
    394
    This is curious, because I did not have to do anything to get WOL to work on my Windows 7 machines other than enable it in the BIOS as usual. I certainly did not have to edit any of the power settings from their defaults.

    Have you tried updating the network card driver? I have noticed some of the bundled drivers with 7 are actually quite dated and may not be providing the full feature set.

  5. #5
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,488
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76
    I've just searched from within Device Manager, and it reckons my drivers (dated Oct 2008) are up-to-date.

  6. #6
    nibulon's Avatar
    Join Date
    Dec 2009
    Posts
    9
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I've just setup a windows 7 test machine this week myself - both wake on lan and psshutdown worked fine for me with no tinkering with drivers and settings, using the same .exe's i use on the production XP domain.

SHARE:
+ Post New Thread

Similar Threads

  1. How to Wake on LAN
    By roland in forum How do you do....it?
    Replies: 17
    Last Post: 19th November 2010, 10:02 AM
  2. Wake On Lan and VLANS
    By ant2ne in forum Wireless Networks
    Replies: 6
    Last Post: 16th June 2009, 04:27 PM
  3. Wake on LAN stopped working
    By enjay in forum Hardware
    Replies: 8
    Last Post: 17th June 2008, 03:42 PM
  4. Wake on Lan
    By comedydave in forum How do you do....it?
    Replies: 11
    Last Post: 18th March 2008, 03:08 PM
  5. Wake on LAN and hibernate
    By ZeroHour in forum Windows
    Replies: 3
    Last Post: 21st June 2006, 09:35 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •