+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 29 of 29
Windows 7 Thread, Windows 7 Gotchas/Tips/FYI in Technical; Stop Them Chaning Timezones Caught me out this did, notice a few of our Computers had odd time stamps on ...
  1. #16

    Join Date
    Feb 2008
    Location
    Wiltshire
    Posts
    878
    Thank Post
    274
    Thanked 139 Times in 112 Posts
    Blog Entries
    26
    Rep Power
    42
    Stop Them Chaning Timezones

    Caught me out this did, notice a few of our Computers had odd time stamps on some of the logs we keep.

    Group Policy > Computer Configuration > Policies > Windows Settings > Local Polices/User Rights Assignment

    Set a user group permission that can change timezone on the 'Change the time zone' setting. (ie Administrators Only).

    Utility built into Windows 7 called tzutil.exe that allows you to set a timezone with a script if required.

    Pete

  2. #17
    Mr.Ben's Avatar
    Join Date
    Jan 2008
    Location
    A Pirate Ship
    Posts
    941
    Thank Post
    182
    Thanked 157 Times in 126 Posts
    Blog Entries
    2
    Rep Power
    65
    You encounter a long logon time (Hanging at 'Applying Folder Redirection Policy') after you enable the "Do not automatically make redirected folders available offline" Group Policy setting in Windows 7 or in Windows Server 2008 R2 (including SP1)


    This occurs when:

    You deploy the 'Do not automatically make redirected folders available offline Group Policy' setting in a network environment.

    You redirect multiple folders on a client computer that is running Windows 7 or Windows Server 2008 R2 to a file server.

    There is a hotfix for this problem that solved the problem for me:

    http://support.microsoft.com/kb/2525332

  3. #18

    Join Date
    Feb 2008
    Location
    Wiltshire
    Posts
    878
    Thank Post
    274
    Thanked 139 Times in 112 Posts
    Blog Entries
    26
    Rep Power
    42
    When computer is locked, you have no idea who is logged in and locked the computer.

    If you take a look in: HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Policies/System there is a key called 'dontdisplaylockeduserid' which is set to '3' be default.

    Changing this to 2 will show the Display Name of the user currently logged in.
    Changing this to 1 will show the Logon Name and Display Name of tje current user who is logged in.

    The default value of '3' will not show who is logged in.

    Pete

  4. #19

    Join Date
    Jan 2007
    Posts
    964
    Thank Post
    10
    Thanked 35 Times in 27 Posts
    Rep Power
    22
    Quote Originally Posted by ZeroHour View Post
    [SIZE="4"][U][B]
    When viewing redirected folders share you may see many "My Documents"
    When Windows sets up a new redirected My Documents it creates a hidden desktop.ini file which means that when you browse the share/location from Windows you may see a huge amount of folders called "My Documents"/"Documents" rather then the folder name it should be (e.g. \\server\share\username as the path could look like \\server\share\documents)
    The folders are correctly named but when Windows sees the existance of the hidden desktop.ini in each directory it displays the folder as "My Documents"/"Documents" rather then the real folder name. This can happen with any special folder I believe such as Favourites.

    The solution:
    Remove the desktop.ini file in each my docs redirected folder. This can be done with script or using Group Policy Preferences. You can also redirect to a sub folder which hides the issue (e.g. redirect to \\server\share\username\documents\)
    [/code]
    Could you provide a little bit of guidance doing this using GPP? Not really sure where it needs to go e.g. Computer / User configuration and how high up the tree it needs to be...

    Our home dirs are \\fileserver\staff$\%username%

    Thanks

  5. #20

    Join Date
    Mar 2008
    Location
    UK
    Posts
    54
    Thank Post
    4
    Thanked 4 Times in 4 Posts
    Rep Power
    13
    Could you provide a little bit of guidance doing this using GPP? Not really sure where it needs to go e.g. Computer / User configuration and how high up the tree it needs to be...

    Our home dirs are \\fileserver\staff$\%username%

    Thanks
    Hi Googlemad,

    Set up a Group Policy object and go into User Configuration > Preferences >Windows Settings > Files. In there, add a new File rule by right-clicking on the empty list and selecting New > File. Choose action Delete. Then in the Delete files field, put (in your case) '\\fileserver\staff$\%username%\desktop.ini'.

    You might need to go through and delete the files once but once that's enforced, it should stop the file being created and thus, fix the problem.

    Hope that help,

    Shuriken1.

  6. Thanks to Shuriken1 from:

    googlemad (3rd August 2011)

  7. #21

    Join Date
    Jun 2006
    Location
    Kendal
    Posts
    85
    Thank Post
    2
    Thanked 15 Times in 11 Posts
    Rep Power
    19
    Quote Originally Posted by Shuriken1 View Post
    Hi Googlemad,

    Set up a Group Policy object and go into User Configuration > Preferences >Windows Settings > Files. In there, add a new File rule by right-clicking on the empty list and selecting New > File. Choose action Delete. Then in the Delete files field, put (in your case) '\\fileserver\staff$\%username%\desktop.ini'.

    You might need to go through and delete the files once but once that's enforced, it should stop the file being created and thus, fix the problem.

    Hope that help,

    Shuriken1.
    Alternatively, if you use multiple folders for the user areas (i.e. staff, 07, 08, 09 ect...) I did exactly the same as above but deleted H:\desktop.ini (all home drives are H:\ here) and make sure to tick the common option "run in logged on users security context" (user policy)

  8. #22

    Join Date
    Jun 2008
    Posts
    718
    Thank Post
    119
    Thanked 64 Times in 52 Posts
    Rep Power
    31
    A great important tip...

    You experience the following 2 Event IDs

    Event ID 6005
    The winlogon notification subscriber <GPClient> is taking long time to handle the notification event (CreateSession).

    Followed later with the Event ID 6006
    The winlogon notification subscriber <GPClient> took xxx second(s) to handle the notification event (CreateSession).

    This occurs if you're stuck at the Applying Computer Settings



    Simply disabling (or setting it to Not Configured) "Run logon scripts synchronously” cures the problem.

    This is found under Computer Configuration\Policies\Administrative Templates\System\Scripts

  9. #23

    Join Date
    Jun 2008
    Posts
    718
    Thank Post
    119
    Thanked 64 Times in 52 Posts
    Rep Power
    31

    Event ID 6005 and 6006

    You experience the following 2 Event IDs

    Event ID 6005
    The winlogon notification subscriber <GPClient> is taking long time to handle the notification event (CreateSession).

    Followed later with the Event ID 6006
    The winlogon notification subscriber <GPClient> took xxx second(s) to handle the notification event (CreateSession).

    This occurs if you're stuck at the Applying Computer Settings screen prior to logging on.


    Simply disabling (or setting it to Not Configured) "Run logon scripts synchronously” cures the problem.

    This is found under Computer Configuration\Policies\Administrative Templates\System\Scripts

  10. #24

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,939
    Thank Post
    862
    Thanked 1,442 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    616

    Redirected Start Menu shortcuts not allowing "Pin to Start Menu" on context menu

    This one just caught me out for a few minutes.

    If you are using a redirected Start Menu, and you want to allow users to pin shortcuts to the Start Menu themselves, your shortcuts must all reside inside the Programs folder of your redirected Start Menu folder. Given the layout of the Start Menu in Windows 7 everything displays as if it were in the Programs folder anyway; but any items not in this folder will not display Pin to Start Menu on the context menu.

    The rest of your GPO settings have to allow this as well, of course.

  11. #25
    earlyriser's Avatar
    Join Date
    Apr 2009
    Location
    New Zealand
    Posts
    62
    Thank Post
    11
    Thanked 5 Times in 5 Posts
    Rep Power
    11
    So do I need to do both things? Disable Known Folders AND the ADM file? I've tried each individually, and the ADM file did remove the libraries feature from the navigation bar, but NOT from the open or save dialog boxes. Any help appreciated

  12. #26

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,939
    Thank Post
    862
    Thanked 1,442 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    616

    Save As permissions error when Libraries are disabled

    When libraries are disabled, or otherwise mucked around with, a number of programs will complain about permissions when choosing Save As, although clicking OK does then present the user with a save dialog as normal. Windows is trying to point users at a daft location first, and when it can't, it complains and then presents them with My Documents, as it should do in the first place.

    To prevent computer stupidity and user confusion, the following combination of user GPOs and user GPPs should, just about, get you there. Replace "H:\" with whichever drive letter you map the homeshare to.

    Most programs:
    User Config > Policies > Admin Templates > Windows Components > Windows Explorer > Common Open File Dialog > Items displayed in Places Bar
    - I set Item 1 to the mapped home drive letter e.g. H:\. Item 2 I set to H:\My Pictures but only Item 1 should be necessary.

    Office 2010 (using the custom ADM(X) files):
    Microsoft Office 2010 > File Open/Save dialog box > Places Bar Locations > Places Bar Location 1
    - Name "My Documents", path "H:\". You can fill out the rest of the locations as you please, I imagine.
    Microsoft Excel 2010 > Excel Options > Save > Default File Location
    - H:\
    Microsoft Powerpoint 2010 > Powerpoint Options > Save > Default File Location
    - H:\
    Microsoft Word 2010 > Word Options > Advanced > File Locations > Default File Location
    - H:\

    Outlook 2010
    For right-click-save-as of attachments:
    User Config > Preferences > Windows Settings > Registry
    - right-click > new > registry item
    - Action = Update; Hive = HKEY_CURRENT_USER; Key Path = Software\Microsoft\Office\14.0\Outlook\Options; Value name = DefaultPath; Value type = REG_SZ; Value data = H:\

    For opened-attachments-then-save-as (because otherwise, it dumps the temp file in an AppData folder that the user doesn't have permission to and thus: error message)
    User Config > Preferences > Windows Settings > Folders
    - right-click > new > folder
    - Action = Replace; Path = %HOMESHARE%\OutlookCache; Attributes = Hidden; then the last three checkboxes (delete files, allow deletion, ignore errors)
    Above your homeshares (e.g. \\server\share\Staff, where a home directory would be \\server\share\Staff\username), go into Security > Advanced > Change Permissions. Click Add, Add "Domain Computers" and add permissions for: Read attributes, Create folders / append data, Write Attributes
    Back in the policy you were just working on, go back to the registry section of preferences and add a new registry item
    - Action = Update; Hive = HKEY_CURRENT_USER; Key path = Software\Microsoft\Office\14.0\Outlook\Security; Value name = OutlookSecureTempFolder; Value data = H:\OutlookCache
    All this allows the computer to create a hidden folder in the users homedir that it uses when opening attachments from Outlook. Files are deleted when Outlook is closed so it shouldn't bloat and waste backup space; just in case, the replace action on the GPP will empty it anyway. When a user goes to save a document they have previously open with a double click, they are presented with this folder but no error message; they can then navigate as normal without panic. Using a hidden folder is preferable (in my thinking) from just using the %homeshare% root as otherwise, if they want to save the attachment to that location, they'll not be able to overwrite the read-only temp file. If they choose to overwrite the $document (2).docx file, that gets deleted when Outlook is closed.

    This information was compiled from various sources with a lot of testing and faffing - the GPP folder needing %homeshare% took a while - so hopefully it being all in one place saves someone some aggro.

  13. Thanks to sonofsanta from:

    zbjsy (5th July 2013)

  14. #27

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,939
    Thank Post
    862
    Thanked 1,442 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    616
    Actually, further to the above, for the OutlookCache folder preference, just tick the "run in logged on user's security context" then you don't need to faff with permissions. My brain had clearly had enough by the end of yesterday. Kindly passing mod: could you edit the below amendment into the post above in the relevant place to keep it useful and keep the thread neat? The editing window has closed for me

    For opened-attachments-then-save-as (because otherwise, it dumps the temp file in an AppData folder that the user doesn't have permission to and thus: error message)
    User Config > Preferences > Windows Settings > Folders
    - right-click > new > folder
    - Action = Replace; Path = %HOMESHARE%\OutlookCache; Attributes = Hidden; then the last three checkboxes (delete files, allow deletion, ignore errors); on the common tab, "run in logged on user's security context"
    User Config > Preferences > Windows Settings > Registry
    - right-click > new > registry item
    - Action = Update; Hive = HKEY_CURRENT_USER; Key path = Software\Microsoft\Office\14.0\Outlook\Security; Value name = OutlookSecureTempFolder; Value data = H:\OutlookCache
    All this allows... (etc.)

  15. Thanks to sonofsanta from:

    zbjsy (5th July 2013)

  16. #28

    Join Date
    Jun 2008
    Posts
    718
    Thank Post
    119
    Thanked 64 Times in 52 Posts
    Rep Power
    31
    Run this reg on all your machines and you will never have the issue of home folders being renamed to Documents.

    Code:
    Windows Registry Editor Version 5.00
    
    ; Prevents User folders being renamed to Documents after logging on
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{FDD39AD0-238F-46AF-ADB4-6C85480369C7}]
    "LocalizedName"=hex(2):00,00

  17. #29

    Join Date
    Jun 2008
    Posts
    718
    Thank Post
    119
    Thanked 64 Times in 52 Posts
    Rep Power
    31
    Run this reg on all your machines and you will never have the issue of home folders being renamed to Documents.

    Code:
    Windows Registry Editor Version 5.00
    
    ; Prevents User folders being renamed to Documents after logging on
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{FDD39AD0-238F-46AF-ADB4-6C85480369C7}]
    "LocalizedName"=hex(2):00,00

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 4
    Last Post: 19th March 2012, 08:58 AM
  2. Replies: 0
    Last Post: 4th September 2009, 12:48 AM
  3. Any Gotchas When Ghosting W2K3 Server?
    By SYSMAN_MK in forum O/S Deployment
    Replies: 6
    Last Post: 13th March 2009, 02:27 PM
  4. Install Windows Server 2003 admin pack on Windows Vista
    By FN-GM in forum Wiki Announcements
    Replies: 0
    Last Post: 27th March 2008, 04:19 PM
  5. Any gotchas when installing Citrix Presentation Server 4.5?
    By Geoff in forum Thin Client and Virtual Machines
    Replies: 6
    Last Post: 24th May 2007, 08:57 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •