+ Post New Thread
Results 1 to 5 of 5
Windows 7 Thread, Delay to Devices and Printers in Technical; Hello I am hoping that somebody can help with the following situation: In a particular classroom with a particular networked ...
  1. #1
    Bankesy's Avatar
    Join Date
    Jan 2011
    Location
    Chelmsford
    Posts
    92
    Thank Post
    4
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Delay to Devices and Printers

    Hello

    I am hoping that somebody can help with the following situation:

    In a particular classroom with a particular networked printer the Windows 7 workstations are what I would consider to be slow at detecting the presence of the printer.

    What I mean by this is:
    1. In applications such as Office I will get a 'No Printers Installed' message but after closing down and re-opening it will appear
    2. Opening devices and printers from the start menu does not display and printers or faxes for a few minutes but does eventually

    Here is what I've tried so far:
    1. Updating the printer driver
    2. Installing the driver manually (not via group policy) to another machine in another room-worked perfectly fine
    3. Office repair\uninstall and re-install
    4. Running a Microsoft Fix-It which repaired print spooler issues (apparently)
    5. Fully updating Windows
    6. Hard drive clean up (de-frag\error checking)

    Conclusions so far:
    1. It's not an Office problem
    2. It's not a driver problem
    3. It's not a PC problem as 3 out of 4 in the room are the same make and model but the symptoms occur on the 1 other machine as well
    4. It's not login related as the symptoms occur regardless of staff\student logon

    One possible hint: the delay I speak of does not occur when logging on locally, only when logging into the network.

    Any knowledge or suggestions on this are welcome, perhaps and obvious troubleshooting step I've missed?

  2. #2
    Zourous's Avatar
    Join Date
    Mar 2007
    Location
    East Sussex
    Posts
    333
    Thank Post
    95
    Thanked 116 Times in 39 Posts
    Rep Power
    52
    You might have already tried it, but have you deleted the actual printer off of the print server and started again? Sometimes I've found this to be the solution.

  3. #3
    Zourous's Avatar
    Join Date
    Mar 2007
    Location
    East Sussex
    Posts
    333
    Thank Post
    95
    Thanked 116 Times in 39 Posts
    Rep Power
    52
    Also, if you moved one of the PC's it has a problem with to a different room, does the same problem happen?

  4. #4
    Bankesy's Avatar
    Join Date
    Jan 2011
    Location
    Chelmsford
    Posts
    92
    Thank Post
    4
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Hello

    Thank you for your reply.

    I have not completely removed and re-installed the driver from the server, I was trying to avoid this at first due to lack of experience.

    Do you mean have I physically moved the PC to a different room? Are you thinking this might make a difference because it will be connected to a different switch in effect?

  5. #5
    Zourous's Avatar
    Join Date
    Mar 2007
    Location
    East Sussex
    Posts
    333
    Thank Post
    95
    Thanked 116 Times in 39 Posts
    Rep Power
    52
    It should be fine to remove the driver from the server providing there are no other printers sharing the same driver.

    Yes, move the PC physically, then whatever the result you've cut the problem down. If the PC works in another room you can disregard the PC being at fault and it could be a location thing (i.e. switch, cables, databox), if it doesn't it must be something on the PC.

SHARE:
+ Post New Thread

Similar Threads

  1. Devices and printers empty
    By sidewinder in forum Windows 7
    Replies: 7
    Last Post: 13th May 2014, 04:41 PM
  2. device and printers
    By ful56_uk in forum Windows 7
    Replies: 10
    Last Post: 5th September 2011, 12:52 PM
  3. Replies: 3
    Last Post: 6th May 2010, 09:46 AM
  4. remove "devices" from devices and printers
    By mrbios in forum Windows 7
    Replies: 1
    Last Post: 3rd February 2010, 04:52 PM
  5. Windows 7 and "Devices and Printers" not loading
    By teckedd in forum Windows 7
    Replies: 1
    Last Post: 8th December 2009, 12:07 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •