+ Post New Thread
Results 1 to 10 of 10
Windows 7 Thread, User Profile Service failed the logon - FIX in Technical; Just in case anyone has had this error recently , I thought I'd share a fix we found. The issue ...
  1. #1
    JNStiles's Avatar
    Join Date
    Jun 2013
    Location
    Liskeard, Cornwall
    Posts
    13
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    User Profile Service failed the logon - FIX

    Just in case anyone has had this error recently, I thought I'd share a fix we found. The issue is to do with clients not being able to logon and displaying this error...
    user-profile_thumb (1).png

    We found various explanations online, but the most recent suggestions were that this was due to a January 2014 update. However, we recently upgraded IE in our suites to version 11, so who knows?

    Anyway, the error can be fixed by altering the NTFS permissions on C:\users\default (You'll need to show all hidden drives in order to see this folder) and select the "Replace all child objects permissions with inheritable permissions from this object" so that it is enabled

    Change Permissions.PNG

    This will allow users to login from then on. I can't explain why, as before making this change all subfolders and files have permissions that reflect the default user's.
    Anyway this can be done through GPO, under Computer Configuration > Policies > Windows Settings > Security Settings > File System.

    GPO.PNG

    Hopefully this gets someone out of trouble!

  2. #2
    simongrahamuk's Avatar
    Join Date
    Jun 2006
    Location
    Durham, UK
    Posts
    232
    Thank Post
    40
    Thanked 12 Times in 12 Posts
    Rep Power
    19
    You need to clear out the profiles from the registry. the path below is where you will find them.

    remove them from here and all will be well.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

  3. #3
    JNStiles's Avatar
    Join Date
    Jun 2013
    Location
    Liskeard, Cornwall
    Posts
    13
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Doesn't work. Even when you use accounts that have never been logged on to the machine and have no profile in the registry, the same error occurs.

  4. #4
    Jamman960's Avatar
    Join Date
    Sep 2007
    Location
    London/Kent
    Posts
    991
    Thank Post
    186
    Thanked 196 Times in 157 Posts
    Rep Power
    46
    I've also had this recently, in my case once logged in locally I found that the eventlog, netlogon and many other services wouldn't start due to dependencys etc

    My solution so far after a ton of googling has been to reset winsock - netsh winsock reset (elevated cmd needed)

    I figured it was a fluke but I've been told this morning a couple of other machines have come up with the same issue so I'll give the above fix a go also

    James

  5. #5


    Join Date
    Jan 2012
    Posts
    2,695
    Thank Post
    963
    Thanked 356 Times in 271 Posts
    Rep Power
    213
    Quote Originally Posted by simongrahamuk View Post
    You need to clear out the profiles from the registry. the path below is where you will find them.

    remove them from here and all will be well.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
    Deleting these, and the contents of C:\Users (besides Default) always seemed to sort this error out for me.
    I have had some instances where Netlogon wouldn't start - I usually just reimaged the machine, but I'll keep that winsock in mind. Thanks!

  6. #6

    Join Date
    Mar 2010
    Location
    Leeds
    Posts
    420
    Thank Post
    80
    Thanked 46 Times in 41 Posts
    Rep Power
    18
    just out of curiosity have you got ab tutor installed? I found at my old place when re installing ab tutor on machines netlogon would stop running and we had to do the reset winsock as mentioned above.

  7. #7

    Join Date
    Jun 2010
    Posts
    387
    Thank Post
    35
    Thanked 57 Times in 54 Posts
    Rep Power
    32
    Struggling with this issue at the moment on a number of Windows 8 machines.

    In my case it appears to be caused by an update which ironically is supposed to resolve the roaming profile issue Incompatibility between Windows 8 roaming user profiles and roaming profiles in other versions of Windows

    Remove the update and it allows users to log on again - but screws up their roaming profile if they go back to a windows 7 machine. Install the update again and it prevents them from logging in.

    Notice there is a rollup for windows 8.1 which includes this hotfix and others so starting to look at reinstalling all windows 8 machines with 8.1 and the rollup to see if it resolves the issue.

    Non of the default user permission suggestions worked for me.

  8. #8
    RowlandoGloom's Avatar
    Join Date
    Jul 2009
    Location
    Wallsend
    Posts
    50
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    11
    I did notice in the MS article - there is a registry setting to make the change manually should you not wish to actually install the update itself:

    'HKEY_LOCAL_MACHINE\System\CurrentControlset\Servi ces\ProfSvc\Parameters'

    As per the article, the value 'UseProfilePathExtensionVersion' should be set to '1', which makes the change and causes the problem.

    If you change it to '0' instead, the setting wont be applied - making the machine work as before. If it's not there (which it probably is) create it and set it to '0'

    You can then set this in group policy preferences, so all machines pick it up and change it back to '0' should the update ever put it back to '1'

    Hope this helps. If you want more info, I.ve created some below:

    Paul.



    It's simply so profiles are the following:
    user. WinXP
    user.v2 Win 7
    user.v3 Win 8
    user.v4 Win 8.1, so they use different profiles for each version.

    If you manually create the respective .v3 folder for a test user for example, it will let the user log on a Win 8 machine if the value above in the registry is set to 1.

    Changing that value above to 0 stops it (trying to) using .v3 and .v4 profiles, sharing the .v2 with Win7, 8 and 8.1

    Probably a .v5 for 8.2 or Win9!
    Last edited by RowlandoGloom; 26th March 2014 at 12:27 AM.

  9. #9
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,535
    Thank Post
    361
    Thanked 263 Times in 215 Posts
    Rep Power
    100
    Quote Originally Posted by JNStiles View Post
    Anyway, the error can be fixed by altering the NTFS permissions on C:\users\default (You'll need to show all hidden drives in order to see this folder) and select the "Replace all child objects permissions with inheritable permissions from this object" so that it is enabled
    This particular issue only effects people using local profiles rather than mandatory or roaming from what i've seen but an alternative solution is to find the individual file (it's always the same one, with the same name) within the default profile appdata folder (it's in the internet explorer folder somewhere, you can find it in the event log anyway which one you need) and set up a GPP to delete that file from all computers, then you'll never get that problem again.

    EDIT: i should mention, deleting it appears to have no negative side effects.
    Last edited by mrbios; 25th March 2014 at 11:43 PM.

  10. #10
    Norphy's Avatar
    Join Date
    Jan 2006
    Location
    Harpenden
    Posts
    2,362
    Thank Post
    54
    Thanked 309 Times in 240 Posts
    Blog Entries
    6
    Rep Power
    119
    I had this problem today.

    The problem turned out to be a load of SQM files sitting in the default user profile. Removing those fixed the issue.

    The SQM files belonged to Windows Live and a removed instance of Visual Studio.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 5
    Last Post: 28th November 2013, 01:33 PM
  2. Replies: 5
    Last Post: 25th September 2013, 10:16 AM
  3. Replies: 4
    Last Post: 8th September 2012, 12:43 AM
  4. Replies: 19
    Last Post: 22nd March 2012, 11:45 AM
  5. Replies: 8
    Last Post: 25th May 2011, 09:44 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •