+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 17
Windows 7 Thread, Bypass proxy for local addresses in Technical; Hi All, Any help appreciated as always.... Since IE 10 for some reason the tick box for bypass proxy for ...
  1. #1

    Join Date
    Jun 2010
    Location
    Cardiff
    Posts
    74
    Thank Post
    32
    Thanked 2 Times in 2 Posts
    Rep Power
    9

    Bypass proxy for local addresses

    Hi All,

    Any help appreciated as always....

    Since IE 10 for some reason the tick box for bypass proxy for local addresses is un-ticked even though the exceptions are specified. I have looked over the registry settings and all look ok is there something im missing ? does anyone know if their is a key to actually tick the box ?

  2. #2

    Join Date
    Dec 2009
    Posts
    250
    Thank Post
    5
    Thanked 28 Times in 26 Posts
    Rep Power
    14
    Not rolled out IE 10 as yet, however I know that Microsoft have moved a lot of the IE settings from the IE Maintainance Mode to the Group Policy Preferences section of the GPO. This let you configure different settings depending on the version of IE.

    I'm guessing it's possible that setting for IE 10 need to be made under here? (apologies if you're already doing this)

  3. #3

    Join Date
    Jun 2010
    Location
    Cardiff
    Posts
    74
    Thank Post
    32
    Thanked 2 Times in 2 Posts
    Rep Power
    9
    Hi there, Yes i'm using windows 8 to do this as the option is no longer visible for ie 10 under windows 7 / server 2008. Im actually using reg keys as well at a different level to ensure everything gets picked up. has always worked up till version 10 ! Thanks for getting back though !

  4. #4
    pleach85's Avatar
    Join Date
    Jan 2011
    Posts
    22
    Thank Post
    3
    Thanked 6 Times in 6 Posts
    Rep Power
    9
    I think this is what you are looking for

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Internet Settings]
    "ProxyOverride"="<local>"

  5. Thanks to pleach85 from:

    ninjabeaver (2nd April 2014)

  6. #5

    Join Date
    Jun 2010
    Location
    Cardiff
    Posts
    74
    Thank Post
    32
    Thanked 2 Times in 2 Posts
    Rep Power
    9
    Hi Thanks for that. Sadly that's the key i'm using to list the exceptions but it doesn't seems to Tick the actual "bypass for local addresses" box it just lists them in the exceptions box

  7. #6
    pleach85's Avatar
    Join Date
    Jan 2011
    Posts
    22
    Thank Post
    3
    Thanked 6 Times in 6 Posts
    Rep Power
    9
    If you add <local> to that list you already have it should tick the box.

  8. #7

    Join Date
    Jun 2010
    Location
    Cardiff
    Posts
    74
    Thank Post
    32
    Thanked 2 Times in 2 Posts
    Rep Power
    9
    Many thanks Will give it a go !

  9. #8

    Join Date
    Jul 2008
    Location
    London
    Posts
    3
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I do have <local> on the "ProxyOverride" list, policy is applied successfully, I can see the "ProxyOverride" key with the list in the registry, still IE10 ignores it and leaves the 'Bypass proxy for local addresses' without the tick.

    I don't see anything stopping IE from using settings from registry...

  10. #9
    pleach85's Avatar
    Join Date
    Jan 2011
    Posts
    22
    Thank Post
    3
    Thanked 6 Times in 6 Posts
    Rep Power
    9
    Sorry that's not working for you. I've tested on ie 10 and 11 and seems to be working fine for me. My ProxyOverride reads

    this;that;<local>

    (the <local> always appears at the end... might be important!)
    I can only suggest setting it up as you want it to appear and then export the ProxyOverride regkey.

  11. Thanks to pleach85 from:

    ninjabeaver (2nd April 2014)

  12. #10
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,182
    Thank Post
    206
    Thanked 221 Times in 190 Posts
    Rep Power
    72
    @pleach85 is correct, just by adding ;<local> to the end of your ProxyOverride reg key will enable the bypass. You can even test it by editing the registry key manually - add the <local> to the end, close regedit and check Internet Settings.

    If its still not working then you may have conflicting GPO's somewhere (which happened to me last month)


    EDIT

    I have tested this on IE 8, 9, 10 and 11
    Last edited by themightymrp; 13th December 2013 at 03:27 PM.

  13. Thanks to themightymrp from:

    ninjabeaver (2nd April 2014)

  14. #11

    Join Date
    Jul 2008
    Location
    London
    Posts
    3
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thank you for your suggestions.

    Changing keys processing order to:

    1. ProxyEnable
    2. ProxyServer
    3. ProxyOverride

    sorted the problem out.

  15. Thanks to Laputa from:

    zag (2nd April 2014)

  16. #12

    Join Date
    Aug 2007
    Posts
    811
    Thank Post
    98
    Thanked 64 Times in 46 Posts
    Rep Power
    25
    When setting the IE proxy bypass settings with group policy preferences you have to press f6 (I think) to "enable" the settings you've made. Should go from red underlined to green.

    Caught us out!

  17. #13
    StevieM's Avatar
    Join Date
    Apr 2013
    Location
    Liverpool
    Posts
    754
    Thank Post
    304
    Thanked 327 Times in 216 Posts
    Rep Power
    78
    Forgive my ignorance, but how do I apply the settings for all users? I have them set up correctly on an admin account, but the settings don't apply to other users.

  18. #14
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,182
    Thank Post
    206
    Thanked 221 Times in 190 Posts
    Rep Power
    72
    Are you setting these up in group policy?

  19. #15
    StevieM's Avatar
    Join Date
    Apr 2013
    Location
    Liverpool
    Posts
    754
    Thank Post
    304
    Thanked 327 Times in 216 Posts
    Rep Power
    78
    Quote Originally Posted by themightymrp View Post
    Are you setting these up in group policy?
    They were set up in GP but the option is no longer there since IE10 was installed. Managed to do it by editing a VB script. Thanks anyway.

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Cannot bypass authentication for squid proxy using ncsa authentication
    By asb2204 in forum Internet Related/Filtering/Firewall
    Replies: 6
    Last Post: 23rd January 2013, 09:48 PM
  2. Bypass Proxy for Addresses
    By Hightower in forum Internet Related/Filtering/Firewall
    Replies: 3
    Last Post: 14th June 2010, 09:43 AM
  3. Pupils bypassing proxy...
    By indie in forum Windows
    Replies: 15
    Last Post: 23rd December 2008, 01:01 PM
  4. Replies: 8
    Last Post: 18th July 2008, 02:34 PM
  5. how to set proxy for explorer.exe
    By randomconept in forum General Chat
    Replies: 8
    Last Post: 22nd October 2007, 11:23 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •